
SmartSoft-AES Software Release Notes 
___________________________________________________________________________ 
 
Release 6.6.0 – May 2026 (Win10/11; 64-Bit) 
___________________________________________________________________________ 
OVERVIEW 

Auto Z, New Intro Turbo Configuration, Bug Fixing 
NEW FEATURES 

UI 
1. Main Menu>Tools>Resource Monitor: Add GDI objects monitoring 
2. Main Menu>Tools>Resource Monitor: Add User objects monitoring  
3. Make some error dialogs more consistent 
4. Added support for new Pfeiffer Intro Turbo 
 
System  
5. Only make the rough pump state match the turbo state when running vacuum tasks so that they can be 

controlled separately through service controls 
 

Sample  
6. Add Auto Z with fast and precise modes 
7. Add sample thickness value for platens 
8. Add Recessed and Pre Tilt platen types 
 
SEM  
9. Add some wait time when loading an SEM setting through a queue 
10. Add queue task to start and stop the SEM Image 
 
Hardware  
11. When running Ion Gun outgas, load INITIAL setting at the start to zero out supplies 

 
BUG FIXES 

UI 
1. Fix issues with case sensitivity in settings names for consistency between the file name and the setting 

displayed within SmartSoft-AES 
2. Fix issue with system colors not being universal across SmartSoft-AES 
3. Fixed issue with clicking off an edit control without pressing enter, into a new window where the value 

was not being saved correctly 
4. Main Menu>Automation>Queue Editor: Fix issue with drive to position tasks failing when they shouldn’t  
5. Fix issue with being able to enter invalid values into combo boxes 
6. Clean up ammeter units logging 
 
System  
7. Fix issue with taking intro photos at different rotation orientations 
8. Fixed issues with Agilent configuration for some service controls 
 
Sample  
9. Fix issues adding an image to the position list 
10. Fix issue with stage values not being set correctly on startup 
 
SEM  
11. Do not attempt to restart the SEM image when running a queue 
12. Fix rotate horizontal failing on systems with rotation limit switches 



 
AES 
13. Clip mosaic FOV value so that it does not go above the allowed FOV allowed for the current SEM setting 
14. Fix issue with HERO mode not showing up when it should 
 
Hardware  
15. Fix issue with new sputter settings not showing up in the Sputter Tool 
16. Fix issue with 781, 781B simulation 
17. Fixed issue with the Ion Gun outgas routine ramping emission to sputter setting when in neutralizer 

mode 
18. Fix issue with 781B readbacks when not configured 

 
KNOWN ISSUES AND LIMITATIONS 

1. Issues can occur when stopping windowed line scans 
2. SEM photos taken during elastic peak acquisitions may appear darker than normal 

___________________________________________________________________________ 
 
Release 6.5.1 – June 2025 (Win10/11; 64-Bit) 
___________________________________________________________________________ 
BUG FIXES 

Sample 
1. Fix issue with loading in stage settings on systems with a large rotation center offset. 

__________________________________________________________________ 
 
Release 6.5.0 – June 2025 (Win10/11; 64-Bit) 
___________________________________________________________________________ 
OVERVIEW 

EGun Tuning, Bug Fixing 
NEW FEATURES 

SEM 
1. Added EGun Tuning for issue following opening of the isolation valve 

 
Hardware 
2. Drive without stage protection when driving during Ion Gun tuning 

 
BUG FIXES 

UI 
1. Cleaned up check box control interaction 
 
Sample 
2. Fixed an issue that invalidated stage settings in 6.4.0 

 
___________________________________________________________________________ 
 
Release 6.4.0 – May 2025 (Win10/11; 64-Bit) 
___________________________________________________________________________ 
OVERVIEW 

97mm Platen Option, Bug Fixing, Minor New Features 
NEW FEATURES 

UI 
1. Added Comment to Ribbon Menu under Data Manager 
2. Improved outgas preview and outgas preview button hint 
3. Added support to make sure that popup views are within the screen height 



4. Replace some list components with an updated component 
5. Improved feedback when saving a setting 
6. Improve logging for Data Sampling 
7. Main Menu>Help>Contact Us…: Add contact information for PHI USA and Ulvac-Phi. SmartSoft-

AES\Contact.txt can be edited to include system or region specific information 
8. Add auto show pinnable side toolbar menus 

 
Configuration 
9. Add 97mm Stage option 

 
Sample 
10. Improved acquisition simulation data 
11. Use file explorer to open folders 
12. Add 97mm platen type 
13. Limit tilt range when 97mm platen is on the stage 
14. Limit Zalar radius to a max of 4mm with 97mm stage option 

 
SEM 
15. Support both full screen and tile layout in SEM tab 
16. Add 781B diagnostics 
17. Add service queue task to set the EGun Beam state 

 
Hardware 
18. Updated the Analyzer/Detector schematic 
19. Changed the bake to run through the queue and auto start the chart recorder 

 
BUG FIXES 

UI 
1. Moved history settings section to be above favorites  
2. Add sputter setting name to sputter queue task summaries 
3. Fixed chart recorder setup tab not displaying correctly 
4. Drive to position by name queue task will now reference queue position lists if they exist 
5. Allow all user levels to overwrite DEFAULT and PREVIOUS settings 
6. Fix issue with some queue settings not being imported from the UI correctly 
7. Fix issue with some views not being initialized correctly 

 
Sample 
8. Fix issue causing Stage settings with rotation center correction to not save the correct values 

 
SEM 
9. Added hints to FE reset and Z align buttons 

 
AES 
10. Fixed an issue where the acquisition status popup window was not showing 
11. Fixed issue with missing file header information 
12. Improved saving raw data file 

 
Hardware 
13. Save the chart recorder to csv after Ion Gun outgassing 
14. Changed default Ion Gun neutralize setting from NEUTRALIZE_NEUT to NEUTRALIZE 
15. Changed default Ion Gun baud rate from 115200 to 9600 
16. Fixed an Ion Gun ramp log message units 
17. Improve turbo simulation 



18. Fixed issues with Ion Gun tuning settings looping 
19. Fixed an issue where the queue would hang if Ion Gun tuning validation failed 
20. Allow for easier aborting of Ion Gun tuning by clicking the tune button while tuning running 
21. Fixed an issue causing bake failures due to CPU slowness 

___________________________________________________________________________ 
 
Release 6.3.0 – January 2025 (Win10/11; 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Bug Fixing, Minor New Features 
NEW FEATURES 

UI 
1. Added right click menu to pin tabs to pin or unpin all tabs. 
2. Improved Queue Editor UI for easier navigation. 
3. Main Menu Bar>Tools>Resource Monitor…: Default to the max for Memory, Handle, and Thread 

monitors. 
4. Added Zoom to Task button to expand the current job and highlight the current task in the Queue Editor.  
5. Added Select all/Unselect all right click option to the Queue Editor for updating job and task active 

states. 
 

Sample 
6. Changed functionality for Intro Photo Zoom mode. Zoom to current cursor position rather than last 

clicked position. 
 

AES 
7. Improved acquisition status feedback. 

 
Hardware 
8. Added the ability to change the baud rate for multiple devices. 
9. Added default neutralize setting for Ion Gun. 
10. Updated the Analyzer/Detector schematic. 
11. Added an option to disable pressure interlock monitoring during a bake. 
12. Added a 10 second delay to power loss recovery task after turning on the rough pump and before 

opening V7. 
 
BUG FIXES 
         Installation 

1. Fixed an issue with missing VC++ runtime files. No longer need to run the VC++ redistributable. 
2. Removed .NET prerequisite from the Die Navigation Option Installer. 

 
UI 
3. Cleaned up Queue Editor tasks list. 
4. Main Menu Bar>File>Save System Parameters: Fixed Auto Save parameters reverting to Never Save. 
5. Fixed a bug causing Invalid Window Handle error on shutdown. 
6. Fixed an issue where SmartSoft shows up off screen on startup. 
7. Fixed a bug where the currently selected item in a list sometimes had the incorrect font color. 

 
Sample 
8. Changed the wording of the auto pinning procedure to be more specific. 
9. Fixed an issue with zooming out on SPS image not displaying the reference image. 

 
SEM 



10. Cleaned up SEM hardware initialization error messages. 
 

AES 
11. Fixed continuous sputter combo box flickering. 
12. Removed warning for high number of cycles when starting a profile acquisition. 
13. Fixed a bug with long profile acquisitions aborting by limiting the number of curves visible in the 

Spectral Viewer at one time. 
14. Fixed a bug causing the acquisition status popup menu to not show. 

 
Hardware 
15. Fixed a compatibility issue with the PBR cold cathode. 
16. Reset Outgas Supply if outgas procedure is aborted. 
17. Fixed issue with corrupted Ion gun settings files. 
18. Only ramp Ion Gun emission when filament is cold and coming from Off mode. 
19. Set theoretical work function values to read only. 
20. Cleaned up Ion Gun gas warning when starting a profile in the Queue. 
21. Remove “_NEUT” from Ion Gun settings. 
22. Fixed Ion Gun Diagnostics not reading. 

 
KNOWN ISSUES AND LIMITATIONS 

3. When hovering over the SmartSoft-AES Icon in the Windows Toolbar, the preview may not be accurate. 
4. Issues closing incomplete Map files. 
5. SEM tries to restart after acquisition run in queue. This can cause issues when running multiple 

acquisitions back-to-back in a queue. To resolve this, turn off SEM before starting the queue. 
___________________________________________________________________________ 
 
Release 6.2.1 – May 2024 (Win10; 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Die Navigation, Work Function & Channel Offset Calculations, UI/UX Improvements, Bug Fixing 
NEW FEATURES 

Installation 
1. Die Navigation activation key required for the configuration option. 
2. Removed the Enhanced IR option key. 

 
Configuration 
3. New configuration option for Die Navigation. Requires the activation key to be installed to turn on. 
4. Remove Enhanced IR option, capabilities will be available for all customers without installing the key. 

 
UI 
5. Main Menu>View >Reset Layout: Return main view menus to their original sizes.  
6. Can now maximize sizable windows. 
7. Main Menu>Tools>Analyzer and Detector: Added calculations for Work Function and Channel Offsets. 

 
Sample 
8. Added Die Navigation functionality to align pins to die corners. 
9. Added additional alignment pin sets and save alignment set with platen. 

 
AES 
10. Added copy button for Map acquisition images including spatial area definitions. 
11. Added Load SEM task to the Queue Editor. 
12. Added optional load SEM Setting to AES Acquisitions. 



13. Added Z height to Mosaic Acquisitions. 
 

BUG FIXES 
         Installation 

1. Fixed issue where ConfigurationSetup.Exe would not be run from CustomActions.exe. 
 

UI 
2. Add reserved queue settings. 
3. Fixed an issue that would cause application log messages to not appear. 
4. Improved application log backups. 
5. SmartSoft will no longer take focus away from currently selected UI control when mousing over the 

Intro Photo Wafer Map or SEM image. 
6. Mouse wheeling up/down to change a value will now be applied to whichever UI control the mouse is 

hovering over, rather than the currently selected control. 
7. Improve Z ordering of windows to fix issues caused by hidden prompt dialogs locking up the UI. 
8. Main Menu>Tools>Analyzer and Detector> Support 20-378A diagnostics. 

 
System 
9. Fixed an issue with missing context menu for Park Platen glyph. 

 
Sample 
10. Add reserved section to Stage Settings selection. 
11. Stop sample handing procedures before stopping stage movements when using header bar stop. 
12. Fixed an issue where platen settings would be lost on restart. 
13. Removed +15V stage diagnostic. 
 
SEM 
14. Improved auto video errors. 
 
AES 
15. Fixed an issue failing to read Map files for a More Acquisition. 
16. Improved saving of intermediate data files. 
17. Fixed an issue when removing regions from Profile More Acquisitions. 
18. Removed inaccurate acquisition time estimates. 
19. Allow header bar stop button to abort acquisitions. 
20. Added Application log for Mosaic Acquisitions. 
21. Fixed an issue where the spectral data plot would not appear when starting a Profile Acquisition. 
 
Hardware 
22. When tuning Ion Gun reserved settings, skip Initial, Zero, Default and Previous settings. 
 
CommChecker 
23. Made general improvements to operation of CommChecker. 

 
KNOWN ISSUES AND LIMITATIONS 

6. When hovering over the SmartSoft-AES Icon in the Windows Toolbar, the preview may not be accurate. 
7. SmartSoft-AES shows invalid window handle error on shutdown. 
8. Issues closing incomplete Map files. 

 
___________________________________________________________________________ 
 
Release 6.2.0 – November 2023 (Win10; 64-Bit) 
___________________________________________________________________________ 



 
OVERVIEW 

Queue Editor, Header Bar, Ribbon Menu, UI/UX Consistency and Improvements, Automated Ion Gun 
Outgas and Tuning, Windows 11 Support, Bug Fixing 

NEW FEATURES 
Installation 
1. A batch file to do weekly settings backup is installed and added to the Windows Task Scheduler to be 

run every Sunday at 3AM. The backup schedule can be modified by using Task Scheduler. The backup 
settings are compressed and saved in C:\SmartSoft-AES\SettingsBackup. 

2. Add error message on CustomActions.exe failure. 
 

Configuration 
3. Add support for GigE intro photo cameras. 
4. Add support for Imaging Source Intro cameras. 
5. Add USB connection monitoring. 
6. Add support for 15-680 Hot/Cold stage. 
7. Add Mosaic Map option for AES SmartMosaic to Configuration Properties. 
8. Add simulation support to System Configuration. 
9. Add support for 20-068 Ion Gun Control. 
 
UI 
10. Login: Administrator password has been reset.  Please contact CS for the new default password. 
11. Main Menu Bar>View>Header Bar: Display current platen name, task/donut status, platen presence 

status/platen. 
12. Main Menu Bar>View>Header Bar>Stop Button: Many of the individual stop buttons in the UI have been 

removed. Pressing the same start button may stop the specific procedure, however this is not always 
the case. The universal stop button will stop almost any procedure being run.  

13. Main Menu Bar>Header Bar>System Status Indicator: This is the symbol in the far right of the header 
bar. It is used as an indicator for any system errors. When there is any error, the symbol will turn red 
with a triangular shape. Click on it to review errors/warnings in Application Log. 

14. Resizable Viewer Display: In the output area, provide tab pin to choose which viewer to display and 
vertical splitter to resize the width of each viewer. 

15. Main Menu Bar>View>Ribbon Menu: Add ribbon menu UI option for quick access to commonly used 
functionality and information. 

16. Main Menu Bar>Automation: Replace Autotool functionality with the Queue Editor and added quick 
access menu items for STARTUP and SHUTDOWN Queues. Please refer to the Queue Editor User Guide 
for more information. 

17. Main Menu Bar>Tools: Added SEE Database Apps. 
18. Improved window management: Add minimize button for most popup windows. 

 
System 
19. System Bird’s Eye: Always show park platen station if configured. 

 
Sample 
20. Position List>Point Generation: Add point generation for easier creation of many points. 
 
SEM 
21. Allow mouse wheel to resize the IR box size and spacing. 
22. Add warning message when setting Beam Voltage >20 kV from lower voltages. 

 
AES 



23. Add “Add to Queue” buttons for all acquisition types. This includes queue customization that can be 
found in the “AES Setup…”. This custom setup is applied when using the “Add to Queue” button. 
Please refer to the Queue Editor User Guide for more information. 

24. Add "Auto-Close Last Acquisition File" option to spectral display viewer. 
25. Mosaic: Added AES Map and SEM SmartMosaic acquisition mode. 
26. Ion Gun parameters in data file are always pre-sputter parameters and a neutralize set of Ion Gun 

parameters are added. 
 
Hardware 
27. Main Menu Bar>Tools>Outgas Conditioning: add automated outgas for the Ion Gun. 
28. Ion Gun: 20-068 Support 
29. Ion Gun: Add automated tuning for sputter settings. This requires a faraday cup platen to be loaded and 

the FARADAY CUP & FARADAY CUP ADJ stage settings to be set up properly. Tuning will be run on the 
currently loaded setting. Or tuning can be set up from the queue editor tool palette to loop through all 
settings, all reserved settings, or all favorited settings. 
 

Simulator 
30. Use new common simulator. 
31. Add ability to persist parameter values in the SmartSoft Simulator. 

 
BUG FIXES 

Configuration 
32. Removed running CustomActions.exe on SmartSoft startup. 
33. Turn SEE option on by default. 
34. Fix issue with CustomActions.exe failing to register WinUSB drivers. 

 
UI  
35. Consolidate startup error messages. 
36. Main Menu Bar>Tools>Chart Recorder: Refresh the chart recorder every hour to reduce memory usage. 
37. Main Menu Bar>Tools>Chart Recorder: Remove unconfigured parameters from the drop-down menu. 
38. Main Menu Bar>Tools>Chart Recorder: Show pressure values in scientific notation. 
39. Fix issue closing popup menus using the ‘X’ title bar button. 
40. Tooltip/hint display duration now based on length of the tooltip. 
 
System 
41. Valve Bird’s Eye: Fix issue with vacuum tasks not updating rough pump state. 
42. Sample Transfer: Ensure driving stage using absolute positioning during park/unpark. 
43. System Bird’s Eye: Improve platen drag/drop functionality for Intro/Extract and Park/Unpark. 
44. System Bird’s Eye: Change gun state indicator colors. White = Off, Yellow = Standby/Blank/Ready, 

Green = On. 
45. Vacuum: Turn off 777B Pressure Control when V8 is closed. 
46. Fix issue with HERO bias box initializing itself in an unknown state. 

 
Sample 
47. Stage: Fix issue where stage rotation would stop rotation at 180 degrees. 

 
SEM 
48. Restart SEM after Photo with preview. 

 
AES 
49. Depth Profile: Fix issue with sputter failing by timeout after Alt Sputter Position Depth Profile. 
50. Depth Profile: Fix issue with crashing when opening Depth Profile file in MultiPak. 
51. Element Database Editor: Fix issue when adding Xe transitions changing name to CustomXeX. 



  
Hardware 
52. Ion Gun: Correct the problem with emission being set to target value before ramping emission. 
53. Ion Gun Diagnostics: Fix for Filament Current units, should be (A) instead of (uA). 
54. Ion Gun/E-Gun: Fix issues with filament usage displays.  

 
KNOWN ISSUES AND LIMITATIONS 

55. When hovering over the SmartSoft-AES Icon in the Windows Toolbar, the preview may not be accurate. 
56. Issues with GigE camera failing to take intro photo. 

___________________________________________________________________________ 
 
Release 5.7.1 – August, 2019 (Win7; 32-Bit) 
Release 6.1.1 – August, 2019 (Win10; 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

R-Limit switch support for 15-680 Hot/Cold stage, Enable/Disable Motors, I-Neut header 
 
NEW FEATURES 

UI 
1. Menu Bar>Hardware>System Configuration: Add R-limit switch support for 15-680 H/C stage.  Note 

that H/C stage is controlled by supplementary software package (external to SmartSoft). 
 
Sample 
2. Sample>Stage>Properties: Add ‘Enable All’ and ‘Disable All’ motors buttons. 
 
Hardware 
3. Ion Gun: Support Ion Neut parameters separate from Presputter parameters in data file header. 
 

___________________________________________________________________________ 
 
Release 5.7.0 – October, 2018 (Win7; 32-Bit) 
Release 6.1.0 – October, 2018 (Win10; 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

SEE diagnostics; Minor feature enhancements; Bug fixing  
 
NEW FEATURES 

SEE 
1. The System Evaluation Environment (SEE) is a new service utility built into the SmartSoft software which 

periodically records all system parameters while SmartSoft is running.  Notes: By default this utility is 
not activated; and Proprietary analytical data is never collected with SEE.  

2. Menu Bar>Hardware>System Configuration>System…>SEE: SEE data collection can be fully activated 
or deactivated in the configuration menu. 

3. Menu Bar>Hardware>System Log Setup…>Data Sampling: SEE data collection can be partially 
activated or deactivated for individual hardware devices by selecting Data Sampling.  Note that Data 
Sampling for individual devices is only valid when SEE data collection is activated in the System 
Configuration.  
 

UI 



4. Menu Bar>Hardware>System Configuration: Simplified UI: configuration options are organized by 
sessions; property dialogs are added for detailed configuration options. 

5. Menu Bar>Hardware>System Configuration: Add support for the Gamma MPCq pump controller. 
6. Menu Bar>Hardware>Chart Recorder…: The Chart Recorder now includes an ‘Auto Scale’ feature which 

optimizes the data displays for all plots. 
7. Menu Bar>Hardware>Resource Monitor…: Add monitoring of C: hard disk space.  A warning message is 

displayed when the available disk space falls below an enterable threshold value. 
8. Menu Bar>System>Task Scheduler…: A ‘Once’ checkbox option is added to the task scheduler to limit 

the processing of the task to run only one time. 
 
System 
9. Menu Bar>Hardware>System Configuration>Ion Pump Control: SmartSoft-AES adds supports for the 

Gamma MPCq pump controller. 
 

Sample 
10. None 

 
SEM 
11. SEM>SEM Properties>Image: An improved image processing routine is available for enhancing live SED 

images. 
   

AES 
12. AES>Data Manager>Lab Book: The lab book can now include an unlimited number for data file entries.  

Previous limit was 150. 
13. AES>SEM Viewer>Image Registration: The saved reference image is now displayed as part of the image 

registration setup dialog. 
14. AES>SEM Viewer>Image Registrations>Properties: One can now pre-select the acquisition behavior 

when an image registration fails (Prompt User, Continue, Stop).  Prompt User - will display a dialog box 
and wait for operator intervention; Continue - will continue the data acquisition without image 
registration; Stop - will stop the acquisition at the current frame or cycle.   

15. AES>SEM Viewer>Image Registrations>Properties: One can now select the number of retries before 
reporting and IR failure.   

 
Hardware 
16. None 

 
Service 
17. CommChecker.exe: A new utility called CommChecker is included in the SmartSoft-AES\bin folder. 

CommChecker is used to check the communication channels as defined in the SmartSoft-AES 
configuration properties file for trouble shooting purpose. 

 
BUG FIXES 
 

18. UI>Tab Stop: Tab stops are removed for all menus. 
19. UI>Menu Bar>System>Task Scheduler…: Fixed problem where the Task Scheduler incorrectly reports 

“AutoTool is already running”. 
20. System>Intro Photo>Take Intro Photo: Corrected the problem where taking intro photo is very slow and 

SmartSoft becomes unresponsive. 
21. Sample>Position List>Z Position = 0.0: A default Z position of 0.0 indicates that the Z position is 

unknown at the time the position is created (e.g. platen not on the stage; import from defect file).  Drive 
to Position ignores the Z move when the Z position is 0.0.  SmartSoft now displays a prompt which 



clarifies that a  default value of 0.0 maintains the current Z position; while a value of 0.001 drops the Z 
to a minimum Z position.  
 

KNOWN ISSUES AND LIMITATIONS 
22.  

___________________________________________________________________________ 
 
Release 5.6.2 – March, 2018 (Win7; 32-Bit) 
Release 6.0.2 – March, 2018 (Win10; 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Low energy data collection 
 
BUG FIXES 

1. Add support for low energy data collection (0-10eV). 
 

___________________________________________________________________________ 
 
Release 5.6.1 – January, 2018 (Win7; 32-Bit) 
Release 6.0.1 – January, 2018 (Win10; 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Critical Bug Fix Version 
 
BUG FIXES 

2. Fix for image registration not working when acquiring More>Profile or More>Map. 
 

___________________________________________________________________________ 
 
Release 5.6.0 – October, 2017 (Win7; 32-Bit) 
Release 6.0.0 – October, 2017 (Win10; 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Windows 10 Support; Agilent Ion Pump Support; Image Registration at Analysis Position 
 
NEW FEATURES 

UI 
1. SmartSoft-AES includes new high-resolution desktop icons. 
2. Menu Bar>Tools>System Configuration>Bypass Valve: Adds support of the upper chamber bypass 

valve (V10): V10 automates control of the upper chamber bypass valve during system bake. 
3. Menu Bar>Tools>System Configuration>Ion Pump: Adds Agilent ion pump support . 
4. Menu Bar>Tools>Bake and Sublimation: Adds AutoTool tasks: Start Bake; Start Sublimate; Start Degas. 
5. Menu Bar>Tools>Chart Recorder: The Chart Recorder implements a real-time chart history for tracking 

system parameters.  The parameters to be monitored are configurable.  The chart background color, 
line width, axes labels, and data markers are also configurable. 
 

System 
6. System>Vacuum>Pressure Log: Implements a permanent pressure log which records intro pressure, 

main chamber pressure, and upper chamber pressure.  The pressure log is written to a file in the 



settings/log directory.  Write interval is set and modified in the properties. This log can be archived 
and/or deleted without trouble. 

7. System>Intro Photo> IntroUSB Camera Model: Adds support for DFK 41BU02 in addition to DFx 
41BU02. 

8. AES>Survey>Image Registration: Image registration is now available at multiple analysis positions using 
the Position List. Activation key required 

9. AES>Periodic Table: One can now edit acquisition region default energy window information stored in 
the element database.  New elements can also be added:  Periodic Table>Popup Menu>Edit Data 
Base…  

 
Hardware 
10. Hardware>Ion Gun: Adds AutoTool task to set ion gun beam state (Ion Gun:Beam State = Off | Standby | 

Blank | Sputter | Neutralize). 
 

BUG FIXES 
UI 
11. Menu Bar>Tools>Bake and Sublimation: The configuration flag used to pre-bake a system configured 

w/o an upper chamber (Has Upper Chamber=True) is moved from Bake properties.phi to 
ConfigManager properties.phi. 

12. Menu Bar>Tools>Bake and Sublimation: The main chamber pressure interlock is disabled during a 
system bake to prevent damage to the V9 isolation valve  o-ring.  

13. Menu Bar>System>Zip Log Files: Fix issue where dialog is sometimes hidden under SmartSoft-TOF 
main window. 

14. Menu Bar>System>Zip Log Files: Automatically close down the dialog after zipping files. Reduce the key 
stroke as we usually zip up one file at a time. 

15. System>Intro Photo>GigE Camera: Fix issue with GigE camera so the camera doesn’t require ‘Device 
User ID’ set to ‘Intro’ to work. 

16. System>Vacuum>Diagnostics: Implement Turbo Speed Interlock for Dual Turbos; Intro turbo 
interlocked to V3, V6; Second turbo interlocked to V4, V8. 

17. Sample>Stage>Drive to Position Tolerance: Increase tolerance of the R check for the decision to move 
or not.  Previously the tolerance was 0.1 (dThetaDiff < 0.1) and now it is raised to 0.2 in the DLL. 

18. Sample>Stage>Properties>Center of Rotation: Correctly adjust for the current x, y image shift values 
when calculating the center of rotation.  This is not a problem if image shift is 0, 0 when the center of 
rotation is calculated. 

19. Sample>Stage>Properties>Center of Rotation: The 'Test' center of rotation button is missing in previous 
version. The ‘Test’ center of rotation is now back using simple rotation steps of 120 degrees to visually 
check the center of rotation. 

20. AES>Image Registration Retry: When image registration fails (hit edge or below threshold), IR performs 
and auto retry one time before displaying the manual IR retry dialog box. 

21. Diagnostics>Read Hardware: Multiple read hardware buttons can now be active at the same time 
without negatively impacting system performance.   

 
___________________________________________________________________________ 
 
Release 5.5.0 – January, 2017 (Win7) 
___________________________________________________________________________ 
 
OVERVIEW 

SmartSoft-AES V5.5.0: Support 64-bit SmartSoft-AES window program; Support V11  
 
Note: This is the first version of SmartSoft-AES that supports both 32-bit and 64-bit installations. The 64-bit 
installation takes advantage of the larger memory address space and increased RAM size.  This allows the 
SmartSoft software to better handle large data files and increased pixel display resolutions. 



 
NEW FEATURES 

 
System 
1. System>System Glyph>V11:  V11 support is added to the dual turbo pump option.  V11 is the valve 

between the TMP and the Rough Pump.  Note: Dual TMP option was added in V5.4 
 

BUG FIXES 
 

1. Menu Bar>Hardware>System Configuration>Intro Camera: Make it backward compatible and doesn’t 
require users to re-select Intro Camera configuration. Previous Yes | No will be remapped to Canon | None. 

2. System>Cold Cathode: The cold cathode gauge is shut down when pump intro is stopped (i.e. V3 Closed).  
This is done to protect the cold cathode from contamination when intro pressure is too high. 

3. Map Setup>More Map: Only the number of frames field can be modified during a More Map.  Other fields 
have been correctly disabled. 

4. Ion Gun>Settings: Fix “Create Session” error on startup.  This error occurs when Ion Gun reserved settings 
are missing (e.g. INITIAL, PREVIOUS). 
 

___________________________________________________________________________ 
 
Release 5.4.0 – October 2016 (Win7) 
___________________________________________________________________________ 
 
OVERVIEW 

SmartSoft-AES V5.4.0: Support for New PHI Electronics (MOD 32-631 & MOD 781B); Support for New 
Hardware Configurations (EDS/EBSD, Dual TMP, GigE Camera); New Features; Bug Fixes  

 
NEW FEATURES 
 

UI 
1. Menu Bar>Hardware>System Configuration->Intro Camera: Adds support for GigE camera. 
2. Menu Bar>Hardware>System Configuration->E-Gun Control: Adds support for PHI MOD 32-631 E-Gun 

Control. 
3. Menu Bar>Hardware>System Configuration->E-Gun Deflection: Adds support for PHI MOD 781B E-Gun 

Deflection. 
4. Menu Bar>Hardware>System Configuration->Intro Camera: Support GigE camera. 
5. Menu Bar>Hardware>System Configuration->Dual TMP: Adds support for Dual TMP.  The second turbo 

pump option allows for simultaneously pumping on the intro chamber while differentially pumping the 
ion gun. 

6. Menu Bar>Hardware>System Configuration->EDX: Adds support for EDX.  Note EDX is controlled by a 
separate computer workstation.  Set SEM>SEM Properties>Image>Input Signal to External during EDS 
operation. 

7. Menu Bar>Hardware>System Configuration->EBSD: Adds support for EBSD. Note EBSD is controlled by 
a separate computer workstation.  Set SEM>SEM Properties>Image>Input Signal to External during 
EBSD operation. 

8. Menu Bar>System>Zip Log Files: Provide a tool to easily zip up system logs, application logs, and 
settings files for problem diagnostics. 

 
System 
9. Intro Photo>Properties…>Calibrate: The Intro Camera application now includes a simplified point & 

click interface which allows for drawing an area on the intro photo to calibrate the image.  This point & 
click interface is also available to define the clipping area.  Also new is the ability to import a BMP or 



JPEG image from and external camera source (e.g. an external microscope).  This import feature can 
also be used to recalibrate a previous taken intro “.pho” photo file. 

10. Valve Viewer>ToolBar>Large Pressure Display: The large pressure displays are shown in a sizable and 
movable window. 

11. Valve Viewer: A second turbo pump is shown on systems configured with the Dual TMP option. 
 
Sample 
12. Position List>Toolbar>Lock Button: A Lock button is added to the position list which, when pressed, 

prevents editing the position list. The Lock button automatically gets pressed when running AutoTool. 
 
SEM 
13. SEM>Reduced Image: When Reduced Image is selected the SEM is automatically taken out of Auto 

Contrast mode.  Auto Contrast mode is restored when Reduced Image is completed. 
14. SEM>Auto Video: The Auto Video button now allows the operator to define the starting Brightness and 

Contrast values. Optimizing these values allows for a faster completion of the Auto Video routine.  
Default values: Brightness = 90.0; Contrast = 0.0 

 
 
 
BUG FIXES 
 
1. Menu Bar>Hardware>System Configuration: The default product ID is for the 38-101 (x8018) Data Acq.  

However, most AES systems are shipped with the 38-101A (x8021) Data Acq.  This fix was added to the 
ConfigurationSetup.exe 

2. SEM>KnobBox: When the Knob Box is configured but not connected (and not simulated); errors are 
continuously generated in the system log.  This bug will cause the C drive to fill with log data over the course 
of a few days.  Protection has been added to log only one error in the system log on startup.   

3. AES>LabBook>Filename: The list of invalid characters now includes '~', '_', and '+'.  SmartSoft has a special 
meaning for these three characters: '~' is used when a duplicate filename is found; '_' is used for 
acquisitions with multiple areas; and '+' is used for More filenames.  The complete list of invalid characters 
is: '/\:*?<>|~_+' 

4. Ion Gun>Properties>Blank Electron Beam During Sputter:  This feature was missing from the UI in previous 
versions (it was available, however, in the Ion Gun>Properties>Properties.phi file).  It is now back in the Ion 
Gun>Properties dialog. 

 
KNOWN BUGS 
 
1.  
 
HELPFUL HINTS 
1.  
            
___________________________________________________________________________ 
 
Release 5.3.1 – December 2015 (XP, Win7) 
___________________________________________________________________________ 
 
OVERVIEW 

SmartSoft-AES V5.3.1: AES Multiplier ‘Park’ mode; Bug Fixing 
 
NEW FEATURES 
 

UI 



1. Menu Bar>Analyzer: EMS park mode.  The AES Multiplier is now set to a ‘Park’ energy when not 
acquiring data.  Typical value: 1000V.  This feature is designed to extend the lifetime of the MCP 
 

BUG FIXES 
 
1. SEM>Auto Contrast:  The Auto Contrast feature should be disabled when using Reduced Image.  However 

the contrast and threshold values are not correct when auto contrast is de-selected. - Fixed 
2. SEM>Rotation:  Image rotation does not rotate around the center of the image as expected. - Fixed 
 
HELPFUL HINTS 
1. Entry fields must be 'terminated' either by selecting the <Enter> key or by moving to another parameter field.  

If the application is exited before the value is terminated the change will not be saved. 
            
 
___________________________________________________________________________ 
 
Release 5.3.0 – August 2015 (XP, Win7) 
___________________________________________________________________________ 
 
OVERVIEW 

SmartSoft-AES V5.3.0 adds: 0-3200eV Analyzer Range; EDS Support; Common UI Feature; Bug Fixing 
 
NEW FEATURES 
 

UI 
1. Menu Bar>Tools>System Log: Backup copies of the system log are now stored in the C:\SmartSoft-

AES\Log directory 
2. Status Bar: The size of the status line fields can now be customized by clicking and dragging the edge of 

the field.  Fields can be returned to their default size by selecting the Reset Default Size option from the 
status line context menu. 

3. Status Bar>Highlight: The highlighting tool indicates which menu items are Settings and which items are 
Properties.  Settings are loaded as a group of values using the Settings>Load command; while 
Properties are common across the entire system. 

4. Menu Bar>System>E-Mail Notification: One can now send custom email messages or text messages 
during the running of an AutoTool sequence.  This is accomplished by using the AutoTool Send E-Mail 
task. 

5. Menu Bar>System>Coffee Timer: This feature adds the capability to schedule the processing of an 
AutoTool task at a specified day and time. 

 
AutoTool 
6. Menu Bar>Automation>AutoTool:  The Active list item adds the ability to deselect a task from the 

sequence without permanently deleting the task. 
 
System 
7. System>Intro Camera: External image files (.bmp, .jpg) can now be imported and used to navigate on 

the sample.   
 
Sample 
8. Sample>Position List: The 3-point alignment routine is now compatible with die navigation.  This 

support is similar to that found on the SMART-Tool 
9. Samplet>Stage: A warning message is now display when the tilt is greater than 30 degrees. 
 
SEM 



10. SEM: A new Settings Editor is available for viewing and editing the settings text files.  The Settings Editor 
is accessed through a context menu from the Settings Box.  This Settings Editor is available for all 
hardware applications. 

11. SEM: 'V9 Open' & 'V9 Close' controls are added to SEM application. 
12. SEM: The knob box can now be customized to change the behavior of the pressed and un-pressed knob 

states.  Many users find it easier to use the pressed state for coarse moves and un-pressed state for 
fine moves.  (SmartSoft-AES\Settings\Properties\Properties.phi) 

13. SEM>Properties>Image: Input Signal: Internal|External support is added for systems configured with an 
EDS option. 

 
AES 
14. AES>Data Manager>Properties…>Filename: The auto file naming feature has been expanded to include 

digits, date, time, and delimiter type 
15. AES>Survey: The acquisition range has been extended to 0-3200.  This requires an analyzer control 

upgrade from the 20-378 to the 20-378A.  The 20-378 has a range of 0-2500; compared to the 20-378A 
which has a range 0-3200.  Note: the analyzer control model number is set in the hardware 
configuration menu. 

16. AES>Profile>Test Acquire: Test Acquire now supports ‘Area’ and ‘Line’ analysis areas.  The analysis 
area mode can be selected from the SEM context menu. 

 
Hardware 
17. Hardware>Ion Gun: The emission current startup ramping is optimized to improve the lifetime of the 

ionizer. 
18. Hardware>Ion Gun>Diagnostics: Systems configured with the 20-066 ion gun control now take 

advantage of an extended set of diagnostics read backs.  Note: this may require a firmware upgrade. 
 

BUG FIXES 
 
1. Sample>Stage: The accuracy of Eucentric Tilt Correction has been improved. 
2. SEM>SEM: Cannot set the beam voltage to 10.000kV, however 9.99kV works.  This problem only existed on 

some 710 instruments. - Fixed 
3. SEM>SEM>Stigmation X, Y are not loaded correctly from data file.  - Fixed 
4. AES>Data Manager: Every "More" acquisition is counted as a file number. Start with Test1, then do 5 "More" 

acquisition (Test1+1.spe, Test1+2.spe, …) and next valid filename is Test6.spe. Test2.spe-Test5.spe are 
missing.  - Fixed 

5. AES>Profile>Test Acquire: The test acquire spectrum becomes distorted if test point moved during test 
acquisition.  - Fixed 

6. AES>Map: Immediately after restarting the SmartSoft_AES "More" map does not work.  Acquire a map 
acquisition and "More" is working again. - Fixed 

7. AES>Map Display: Beam Voltage is missing in the annotation fields displayed at the bottom of a map 
display. - Fixed 

8. Hardware>Ion Gun: Unable to perform a Timed Sputter when the gun is in the Neutralize mode. - Fixed 
9. Menu Bar>Tools>Analyzer and Detector…: No record of AES multiplier voltage in “File Information” 

parameters. - Fixed 
10. Menu Bar>Tools>Analyzer and Detector…: The AES multiplier voltage is not set correctly after conditioning 

routing. - Fixed 
 
KNOWN BUGS 
1. Some USB thumb drives can cause a loss of communication with the Bertan. 
 
NOTES 
1. SmartSoft-AES can now be run on either a 32-Bit or 64-Bit OS.  Note: This feature can only be configured by 

your ULVAC-PHI service engineer. 



            
___________________________________________________________________________ 
 
Release 5.2.1 - July, 2014 (XP, Win7) 
___________________________________________________________________________ 
 
OVERVIEW 

SmartSoft-AES V5.2.1 adds: Minor Acquisition Improvements; Bug Fixing 
 
NEW FEATURES 

AES 
1. AES>Profile: Profile data is updated more frequently during profile acquisitions.  Data is added to the Profile 

Viewer at the end of each region instead of waiting for all regions (i.e. the end of the cycle). 
2. AES>Map: Selecting a “Frame Stop” or “Next Frame” now completes all scans of a frame (peak, 

background, and background for 3 point map) before stopping or moving to the next region.  Previously, a 
“Frame Stop” would stop at the end of a scan.  In this case if all scans of a frame were not completed, the 
partial frame of data was discarded. 

 
FIXED FROM PREVIOUS VERSION 
1. SEM>SEM Image:  Memory management has been optimized when working with large SEM image files 

(2048x2048 pixels, and 4096x4096 pixels).  This optimization greatly improves the ability to save, display, 
and perform image registration using large images.  However, there are still basic limitations imposed by 
the Microsoft Operating System.  It is recommended to display only one 4096x4096 image in SmartSoft-AES 
at a time. 

2. SEM>SEM Image: Image persistence now includes an “On/Off” selection.  In the “On” mode the current 
image (weighted 50%) is added to the summation of all previous images (weighted 50%).  This summation 
continues until the persistence is set to “Off”. 

3. SEM>SEM Image: Reduced imaging w/persistence has been fixed. 
4. AES>Profile: The “Delay After Sputter” feature has been changed to pause before performing the image 

registration instead of after the image registration.  This change allows the sample to “settle” after 
sputtering and before performing the IR correction. 

5. AES>Survey>More Acquire: Analysis points used during an acquisition are now correctly reloaded into the 
“Area Define” application prior to a “More” acquisition.  This fix also applies to Profile and Line acquisitions. 

6. AES>Map>More Acquire: Deselected regions in the region list are now correctly skipped during a more map 
acquisition. 

7. AES>Map: The “Stop” button was intermittent ignored.  This has been fixed.  
 
HELPFUL HINTS 
1. Entry fields must be 'terminated' either by selecting the <Enter> key or by moving to another parameter field.  

If the application is exited before the value is terminated the change will not be saved. 
            
KNOWN ISSUES AND LIMITATIONS 
 
1.  

 
___________________________________________________________________________ 
 
Release 4.2.0 – March 2014 
___________________________________________________________________________ 
 
OVERVIEW 

SmartSoft-AES V5.2 adds support for a 15-5000 hot and cold stage option. 
 



NEW FEATURES 
 
General UI 
1. User Settings 

a) User settings combo boxes now store a history of the 5 most recently used user settings.  These recent 
settings are displayed at the top of the combo box list followed by a separator.  Also, reserved settings 
are now grouped at the bottom of the combo box list.  In previous versions the reserved settings were 
scattered throughout the list appearing in alphabetical order.   

 
Sample 
2. Sample>Stage: 15-5000 Stage (Optional) 

a) The 15-5000 H/C stage from the VersaProbe II system is now supported as an option for the AES 710 
system.  Note:  with the 15-500 stage a sample positioned normal to analyzer/e-gun is at a 45 degrees 
tilt angle. 
 

FIXED FROM PREVIOUS VERSION 
1. SEM>SEM: Magnification value missing from .sem files.  Because of this MultiPak display the wrong 

magnification on the image. – Fixed 
2. SEM>SEM: SEM Persistence On/Off is now supported.  Persistence signal averages the current fame of SED 

data to a composite of all previous frames. 
 
HELPFUL HINTS 
1. Entry fields must be 'terminated' either by selecting the <Enter> key or by moving to another parameter field.  

If the application is exited before the value is terminated the change will not be saved. 
            
KNOWN ISSUES AND LIMITATIONS 
 
1.  

 
___________________________________________________________________________ 
 
Release 5.1.0 – September 2013 
___________________________________________________________________________ 
 
OVERVIEW 

SmartSoft-AES V5.1 adds: Video Chain 38-101A Improvements; Real-time Histogram Equalization; Reduced 
Image; Bug Fixing. 

 
NEW FEATURES 
 
General UI 
1.  
Sample 
2. Sample>Vacuum: Software vacuum interlock: Close V9 if the chamber vacuum pressure is over the 

interlock 
3. Sample>Vacuum: Software vacuum interlock: Close V4 if TMP RPM is under the interlock 
SEM 
4. SEM>SEM>E: Enhance Contrast function for live SEM image 
5. SEM>: Add support new 38-101A 
6. SEM>SEM>Reduced Image: Added for improved image display rate during precision tuning. 
7. SEM>Beam V: Regulate the ramping rate of E-gun Beam voltage (Default value is set to 1kV/sec) 
AES 



8. Analysis Area: Allow Load Area Setting in AutoTool.  Allow for more fequent IR during acquisitions w/many 
analysis positions;  Also added for Analysis Line 

9. Analysis Areas: Hide the analysis areas that are not selected (instead of setting to black color).  Added to 
Tools>System Colors>Position Inactive=None 

10. Set the number of "More" cycles in AutoTool 
11. Image Registration: Display the confidence threashold as parameter in UI. 
12. Image Registration: Save IR parameter when SS-AES is restarted. 
Hardware 
13.  
 
FIXED FROM PREVIOUS VERSION 
1. SEM: Attempting to Load Setting w/invalid setting name results in a partial load of parameters (bad load). 
2. MCD: Usage Time is always 0.0 hrs. 
3. Bake: Request to change bake sequence to simulate upper chamber pump and gauge. 
4. Z-Align: Energy shift after cardrack recycle. 
5. Z-Align: 1ev Energy Shift 
6. Survey: eV/Step not recorded correctly unless default value is also set. 
7. More Map Fails when adding a new region 
8. More Profile fails when adding a new region 
9. Bake: Unable to enter 'Required Pressure' value 
 
HELPFUL HINTS 
1. Entry fields must be 'terminated' either by selecting the <Enter> key or by moving to another parameter field.  

If the application is exited before the value is terminated the change will not be saved. 
            
KNOWN ISSUES AND LIMITATIONS 
 
1.  

 
___________________________________________________________________________ 
 
Release 5.0.0 – November 2012 
___________________________________________________________________________ 
 
OVERVIEW 

SmartSoft-AES V5.0 supports next generation scanning and data acquisition electronics for the AES 710 
system.  This configuration also replaces the Watcher program used for vacuum control and system bake 
with functionally contained entirely within SmartSoft-AES. 

 
NEW FEATURES 
 
General UI 
1. Vacuum and Bake: Function are now controlled entirely through SmartSoft-AES 
 
System 
2. System>Transfer:  Add support for one-button sample transfers on systems configured without Watcher 

(i.e. systems that are configured with the AVC:auto valve control) 
 
Sample 
3. Sample>Sample Viewer>Toolbar>Grab Cursor: Interactively pans the Sample Viewer image by holding 

down the <left mouse> and moving the mouse cursor. 
4. Sample>Stage: Add support for PCI version of MEI board (15-680 stage only). 



5. Sample>Position List>Create Position…>Point Generation: Support is now available to create multiple 
positions using a number of different fill patterns (e.g. circle, cylinder, square).  The default fill pattern 
creates evenly spaced points across the current FOV.     

 
SEM 
6. SEM>SEM Viewer>Toolbar>Grab Cursor: Interactively pans the SEM Viewer image by holding down the <left 

mouse> and moving the mouse cursor.  This interactive move is accomplished by deflecting the electron 
beam (i.e. x, y image shift) and is only active when the FOV is smaller than the FOV Crossover value.    

7. SEM>SEM Viewer Toolbar>Histogram: Add histogram display which shows the gray-scale distribution of the 
SEM image.  

 
FIXED FROM PREVIOUS VERSION 
 
HELPFUL HINTS 
1. Entry fields must be 'terminated' either by selecting the <Enter> key or by moving to another parameter field.  

If the application is exited before the value is terminated the change will not be saved. 
            
KNOWN ISSUES AND LIMITATIONS 
 
1.  


