
SmartSoft-XPS Software Release Notes 
 
 
___________________________________________________________________________ 
 
Release 4.5.0 – May, 2025 (Win10/11: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Platen Editor, Platen Image Viewer, Cr Stretch/Shear, Stage Bias, Beam Size Offsets, Bug Fixes. 
 
NEW FEATURES 

Configuration 
1. Support more devices baud rates in ConfigManager Properties.phi 
2. SPS and Chamber camera: Add serial number differentiation of cameras for when USB cameras 

are same model. 
3. Set Ion Pump Model default to be ‘Agilent’ for Quantes. Quantes doesn’t have an Ion Pump, but 

the model is referenced for TSP for supporting sublimation. 
 
System 
4. Startup: Prompt user to turn on Card Rack Power at startup, similar to other systems. 
5. SEE Database: Disable/Enable SEE data sampling (periodic reads) for devices affected by Card 

Rack Disable/Enable to cut down on a lot of system log errors when Card Rack is Disabled. 
6. Photo>Aux Intro Camera: Add support for taking Aux Intro Photo. 

 
UI 
7. Main Menu>View>Reset Layout: Return main view menus to their original sizes. 

8. Menu Bar>Tools>Outgas Conditioning…: Reset outgas supply to the starting/before value if that 
supply ramp is aborted. 

9. Menu Bar>Tools>Outgas Conditioning…: Improved E-Neut outgas procedure. 
10. Menu Bar>Tools>Outgas Conditioning…: Updated the outgas preview for readability. 
11. Menu Bar>Tools>Outgas Conditioning…: Hardware view appearance updated. 
12. Menu Bar>Sessions>XPS>XPS Periodic Table: This menu option is removed as it no longer 

worked with now multiple Periodic Table views for different acquisitions. 
13. Menu Bar>Automation>Queue Editor: Add ‘Zoom to Task’ button that expands current job and 

highlights the current running task. 
14. Menu Bar>Automation>Queue Editor: Add ‘Select All’ and ‘Unselect All’ to right-click context 

menu. 
15. Menu Bar>Automation>Queue Editor: Add settings name to Timed Sputter task summary. 
16. Ribbon>Data Manager: Add Comment Control for easy access to editing file comments. 
17. Ribbon>Stage: Add Stage ribbon control for convenience and consistency with SS-VP. 
18. Enable maximize button for sizable views throughout the UI 
19. Tab pinning: Add ability to pin tabs in multiple tab views, also add right-click context menu to pin 

or unpin all tabs. 
20. Show platen information with platen image when hovering over the platen thumbnail in the bird’s 

eye view and header bar. 
21. Improved saving setting feedback by temporarily displaying a green thumb up glyph and 

changing the caption to ‘Saved’ 
22. Settings: Moved ‘history’ sections above ‘favorites’ sections. 
23. Queue: Add validation of Settings being loaded by queue Load Settings tasks to make sure 

setting exists. 
 
Sample 
24. Platen Editor: Platen Editor Feature added to manage creating platens, Prep to Intro transfer, 

take intro photo, setup positions, setup acquisitions, and add acquisitions to queue, while queue 
is already running. 



25. Take Intro Photo: With Platen Editor support, allow taking Intro Photo for platen that is not the 
current platen. 

26. Stage>Settings: Add right-click context menu “Settings Editor…” feature 
27. Platen Image: Maintain x. y cursor position during zoom with mouse wheel. 

 
XPS 
28. Image Data View: Add copy button for copying images to clipboard. 
29. Data File: Made changes to not delete intermediate data files on acquisition error, remove from 

lab book and data display, but keep valid data files on disk. 
30. Acq Setup>Periodic Table: Add Vb1, Vb2, WF1 custom UPS regions. 
31. Mosaic: Add support for saving Z R T position with Mosaic areas. 
32. Mosaic: Add application log for Mosaic. 
33. SXI: Change error notification of SXI Image clipping from dialog to a logged message. 
34. Spectrum: Save data after each cycle 

 
Hardware 
35. Ion Gun: Change default neutralize setting from ‘NEUTRALIZE_NEUT’ to ‘NEUTRALIZE’. 
36. GCIB: Change default Filament Limit (A) from 0.0 to 4.0. 
37. X-Ray>Diagnostics: Add High Power Watchdog diagnostics values to read Watchdog Mode and 

whether X-Ray E-Gun is disabled by Watchdog. 
38. X-Ray>Properties>Scan Pattern: Add Cr Tilt Corrections (Stretch, Shear) to replace Skew 

Corrections. 
39. X-Ray >Properties…>Service: Added Beam Size Offsets that are similar to Beam Power Offsets. 

Overrides X-Ray Setting Offsets for Beam Size acquisitions. 
40. X-Ray: Change valid ranges (min/max) of ‘Beam Diameter (um)’ and ‘Beam Power (W)’ to 

reasonable limits. 
 
BUG FIXES 

System 
1. Allow all user levels to overwrite PREVIOUS and DEAULT reserved settings for usability. 
2. Single Turbo Configuration: Add warnings and confirmation dialogs so that user is aware that 

operations that Pump Intro will turn off the Ion Gun, as the Turbo will switch over to pumping the 
Intro. 

3. Platen Transfer: Fix issue where Aux station could incorrectly be used as a target station to move 
a platen when Aux station is not configured. 

4. System: Fix issue where even if user had done a ‘Save All’ or had periodic save on, a SmartSoft 
crash and restart would still appear to lose some settings such as position list. 

5. System: Quantes Chamber Pumpdown: Fix error when Chamber Pumpdown fails to not 
reference Ion Pump when there isn’t one.  Also print out current Ion Gauge Pressure along with 
Target OK Pressure. 

6. SEE: Add missing sample current readbacks to SEE data. 
7.  

 
UI 
8. Menu Bar>File>Save System Parameters: Fix problem where logging in as ‘User’ user level 

would cause save system parameters frequency to be set to ‘Never Save’ for all user levels. 
9. Menu Bar>Tools>Bake and Sublimation…: Fix sublimation cycles not updating correctly. 
10. Menu Bar>Tools>Bake and Sublimation…: Fix problems with Stage Initialization after bake. 
11. Menu Bar>Tools>Chart Recorder…: Fixed Chart Recorder ‘Setup’ tab not displaying correctly. 
12. Menu Bar>Automation>Queue Editor: Clean up queue tasks (settings tasks were always 

executing, settings tasks not opening editor view, tasks attached to wrong sessions, remove 
some tasks that should not appear in add to queue drop down). 

13. Menu Bar>Automation>Queue Editor: Fix Line Acq Setup in Queue Editor showing ‘Time Per 
Region’ instead of ‘Time Per Step’. 

14. Fixed a bug where the currently selected item in a list sometimes had the incorrect font color. 



15. Improve Z ordering of windows to fix issues caused by hidden prompt dialogs appearing to lock 
up SmartSoft. 

16. Fix popup properties views to limit their height size to available screen size. 
17. Shutdown: Fix Invalid window handle error dialog showing on SmartSoft shutdown. 
18. Fix bug where SmartSoft can come up and not be visible when Top or Left values in 

Properties.phi file were outside of monitor’s bounds. 
19. Application Log: Restrict Application Log combo box from editing to prevent problems. 
20. Queue: Fix Ion Gas Off warning displaying multiple times during queue validation for Timed 

Sputter tasks in queue. 
21. Queue: Fix validation of Drive to Position Name task to check position list settings being loaded 

by queue. 
 
 

Sample 
22. Platen Image>Photo Auto Alignment: Fix ‘AUTO PIN’ queue setting to be a reserved setting so 

that adding acquisitions to queue will not add to ‘AUTO PIN’ queue. 
23. Platen Image: Fixed an issue with zooming out of SPS image (also mosaic image) not displaying 

the platen reference image. 
24. Platen Image: Fixed platens without image overlay set displaying the last successfully loaded 

platen image. 
25. Platen Navigation: Change wording of Auto Alignment initial prompt. Timing marks do not need to 

be used, these are optional. 
26. Position List: Fix Position List ‘Info’ button not working (wouldn’t do anything). 
27. Position List: Fix tab key handling when editing position list, also fix IR Type field disappearing 

when copy/paste. 
28. Stage>Properties>Rotation Center: Fix an issue where some places were using X value instead 

of Y value for center of rotation (Stage control ok, UI such as stage marker may have been off). 
29. Z-Align: Increase allowed acquisition steps per Z-Align from 50 to 100 to help with starting from 

lower Z heights. 
 

XPS 
30. Acquisition Setup: Fixed being able to change range in region table for unscanned acquisitions 

when range should be static. 
31. Acquisition Start: Add check that current platen is at stage before acquisition starts. This prevents 

a platen transfer failure in queue allowing an acquisition to be run on wrong platen. 
32. Acquisition Properties: Refactor logic for shutting down or keeping I-Neut and E-Neut after 

acquisitions complete to try fix issues with I-Neut and E-Neut staying on after acquisitions. 
33. Mosaic: Fix Stitch Mosaic task failing to launch utility app for SmartMosaic. 
34. Data File Header: Fix ‘Instrument Model’ saved to data file header so that it’s compatible with 

what Multipak looks for.  This fixes issue where Depth Profile information in Mutlipak was not 
being read in completely from data file. 

35. Data File Header: Fix some missing and incorrect file header information. Presputter Gun Type, 
Presputter Time, Presputter Setting, Defect Position Name, Defect Position Alignment. 

36. Raw Data File: Improve saving raw data file to make sure that it gets saved in the SmartSoft bin 
directory. 

37. SXI Image Registration: Fix SXI Image Registration failing if E-Neut mode of SXI reference image 
did not match XPS acquisition E-Neut mode. 

38. Z-Align: While Queue is moving position to position in position list, fixed check of position being 
valid for Z-Align (ie. Don’t run Z-Align on empty image position). 

39. Z-Align: Fix problem where Z-Align acquisitions could cause a divide by zero failure if initial 
acquisitions acquired zero signal when calculating an average background signal. 

 
Hardware 
40. Hardware>Ion Gun: Fix issue where I-Neut settings were getting set to zero emission current. 
41. Hardware>Ion Gun: Changed default Ion Gun baud rate from 115200 to 9600. 
42. Hardware>Ion Gun: Fixed Ion Gun ramp log message units. 



43. Hardware>Ion Gun: Fix “Neut Emission” in data file headers always recording zero emission 
44. Hardware>X-Ray: Fix X-Ray mode changes not being displayed on ‘Reinitialize’. 

 
KNOWN BUGS 

1. The Unload Prep operation is currently disallowed if the platen in the Prep is current (Platen 
Settings loaded in the UI). It is recommended to Browse to a new platen for the platen on the 
Prep, or Create New platen to replace the platen on the Prep. 

 
NOTES 

1. Starting with V4.5.0 Cr source Stretch and Shear corrections replace older Skew and R 
corrections. If updating software, Cr tuning should be redone. 

2. Make sure that SmartMosaic has been installed.  This option is by default enabled and 
considered a standard feature. 

3. Starting with V4.4.0 Option Keys are stored and referenced differently.  When updating software 
from older versions of SmartSoft-XPS, option key installations will need to be uninstalled and 
have new option key installations run to have ConfigManager recognize installed options. 

4. Platen Settings are not backwards compatible for files created before V4.2.  Should create new 
platens and avoid using old platen definitions to avoid problems with Platen Max Z and platen 
photo image handling. 

 
 
___________________________________________________________________________ 
 
Release 4.4.0 – February, 2024 (Win10/11: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Header Bar, New Hardware Support, UI Updates, Auto Photo Alignment, Bug Fixes. 
 
NEW FEATURES 

Installation 
1. A batch file to do weekly settings backup is installed and added to Task Scheduler to be run 

every Sunday at 3AM. The backup schedule can be modified by using Task Scheduler. The 
backup settings are compressed and saved in C:\SmartSoft-XPS\SettingsBackup. 

2. Installation image contains folder containing SmartMosaic installation.  SmartMosaic option in SS 
is by default enabled.  Should make sure that this application has been installed.  SmartSoft 
Installation instructions have been modified to include installing SmartMosaic. 

3. XPSElement.sqlite which resides in the Configuration directory has been modified so that HXPS 
survey and custom regions have a default of 1 sweep instead of 4. 

 
Configuration  
1. Add FXS Shutter  
2. Add X-Ray Crystal Heater 
3. Add GCIB Nozzle Heater 
4. Add GCIB Quad Steering 
5. Add Gauze Lens 32-450 

 
UI  
6. New Header Bar: Display current platen name, task/donut status, platen presence status/platen 

transfer, system pressures, gun status, system status indicator to alert users of warnings and 
errors. 

7. New Header Bar>System Status Indicator: This is the symbol in the far right of the header bar. It 
is used as an indicator for any system errors. When there is any error, the symbol will change to 
red triangular shape. For warning, symbol will change to a yellow triangular shape. Click on it to 
review errors/warnings in Application Log. 



8. Menu Bar>System>Logout…: Administrator password has been reset.  Please contact CS for the 
new default password. 

9. Menu Bar>Tools>Outgas Conditioning…: Add GCIB outgas. 
10. Ribbon/Dashboard>Sputter Tool: Add gun setting consistent with SmartSoft-VersaProbe. 
11. User Level: Allow basic User level users view diagnostics, but not able to utilize service level 

control in diagnostics views. 
12. Output Area Tab Pins: Tab views in output area now have pins to lock tab view to keep view 

visible while navigating away from tab to other tab views. 
13. Platen/SXI Vertical Slider: Add slider bar between Platen Photo View and SXI Image Viewers to 

allow adjusting space allocated for display. 
14. Diagnostics Views User Level: Allow base User level access to diagnostics views, but restrict 

diagnostics controls that are Service level operations. 
 

Startup  
15. Add checking Analyzer communication on startup and report problem at startup. 

 
System 
16. Bird’s Eye View: Platen drag and drop updated to display drag status with cursor change.  This 

works with header diagram as well as in-between bird’s eye view and header. Old method of 
dragging platen outline was problematic. 

17. Bird’s Eye View: Gun mode colors have been updated, Green – On, Yellow – Standby/Blank, 
White – Off. 

 
Sample 
18. Sample>Position List>Alignment:  When alignment pins are cleared, pin position reset to 0,0 
19. Sample>Platen Photo: Add Platen Photo Auto Alignment feature. 
20. Sample>Z-Align: Add Image Scan Size X/Y area controls.  This controls size of Z-Align scan 

pattern used for SXI Z-Align acquisitions. 
 

XPS 
21. XPS>Acq Setup>Properties…>Region: Support HXPS Prescan, breaking up wide scan HXPS 

regions to improve data acquired. 
22. XPS>Mosaic: Mosaic View is located under XPS session and removed from being sub-tabs 

within other application views.  This is consistent with SmartSoft-VP. 

 
Hardware 
23. Hardware: Favorites added to hardware settings controls.  Can mark settings as favorites for 

easy access. 
24. Hardware>Analyzer Properties…>Retard: Fine Focus control added for when Gauze Lens 32-

450 is configured. 
25. Hardware>Analyzer>Diagnostics: Add ’32-450’ and ’32-450 ADC’ diagnostics views when 32-450 

Gauze Lens is configured. 
26. Hardware>Analyzer>Diagnostics: HXPS systems had Fan Status backwords. 
27. Hardware>C60: Old Auto Startup feature has been removed in favor of outgas tool support. 
28. Hardware>E-Neut: Support BaO, and Ta as filament type. Support different sets of Standby 

Filament Current, Software Limit, and Cathode Work Function for each filament type. 
29. Hardware>GCIB: Add Emission Readback button consistent with other guns. 
30. Hardware>GCIB: Add Quad Steering X/Y controls which are enabled when Quad Steering is 

configured. 
31. Hardware>GCIB>Properties…>Nozzle: Add new controls for GCIB Nozzle heater when 

configured.  Also ‘Target Temperature’ in main UI view. 
32. Hardware>IonGun>Diagnostics: Add Beam, Condensor, and Objective arc counts for 20-068 Ion 

Gun configuration. 
33. Hardware>IonGun: Fix Ion Gun Emission ramping not starting at zero (would briefly start at 

setpoint before going to zero and ramping). 



34. Hardware>Xray>Properties>Service: Add crystal heater temperature controls when X-Ray crystal 
heaters are configured. 

35. Hardware>Xray>Beam Size: Removed any scan pattern skew correction from Beam Size scan 
patterns. 

36. Hardware>Xray>Properties…>Service: Add Beam Power Scan Offset X/Y.  These scan offsets 
are only used with Beam Power scan patterns. 
 

BUG FIXES 
 

1. UI>Menu Bar>Tools>Bake and Sublimation…: Fix cycling card rack power needing SS restart. 
2. System>Photo>Intro Camera: Fix problem where GigE camera would fail to take picture. 
3. System>Photo>Intro Camera: Fix problem where Take Picture could fail in an access violation 

error that would require restart of SmartSoft to recover. 
4. System>Photo>SPS>Diagnostics: Fix diagnostics view not updating properly. 
5. System>Photo>SPS>SPS Station…: Fix SPS Imaging button not correctly reflecting imaging 

state. 
6. System>Photo>SPS: Fix system log filling up with benign errors about ‘zero bytes read’ when 

configured for GageChek SPS encoder. 
7. Sample>Position List>Alignment:  Save alignment pin set selected with each platen set of 

settings so that changing platens changes alignment pin sets 
8. Sample>SXI: Fix error message not being displayed to user when SXI fails due to gauze lens SXI 

mode not ready. 
9. Sample>SXI Image Viewer: Fix behavior where clicking on ‘gray area’ outside of image would 

result in position list positions getting enabled that were previously disabled. 
10. Sample>Stage>Properties…>Positions: Fix Stage Transfer Position Get Stage Position button 

not updating transfer position in DLL unless a position value was modified/toggled. 
11. Sample>Stage>Diagnostics>Motor: Fix Set Position for selected motor not working. 
12. Sample>Stage>Diagnostics: Add precision to values displayed for ‘Position’, ‘Minimum Limit’, 

‘Maximum Limit’, and ‘Position Error’. 
13. XPS>Acq Setup: Fix Start Acq button behavior so that they depress and stay depressed while 

queue starts.  Used to popup after clicked until acquisition started in queue. 
14. XPS>Line>Acq Setup: Fix bug where trying to start Line Acq when HP X-Ray setting is loaded 

would result in error even though selected X-Ray setting for Line was not HP. 
15. XPS>Map>Acq Setup: Fix bug where trying to start Map Acq when HP X-Ray setting is loaded 

would result in error even though selected X-Ray setting for Map was not HP. 
16. XPS> Acq Setup>Properties…: Fix issue where Acquisition Presputter would not be recorded in 

data file header correctly.  Implemented new way to keep track of position being sputtered or not 
before acquisition based on stage position. 

17. XPS>Platen Manager>Properties…>Directory: Restore Auto Directory feature. 
18. XPS>SXI: With HXPS, fix Cr SXI not starting due to invalid parameter error.  Changed default BE 

for Cr from 5470 to 5387. 
19. XPS>Data File Header: Fix Presputter Yes/No potentially not recorded correctly. Implement new 

method to keep track of if position has been sputtered to record acquisition presputter Yes/No. 
20. Hardware>Analyzer: For HXPS systems, fix default ‘Cr Photon Energy’ to 5414.8 eV. 
21. Hardware>E-Neut: Fix problem where gun was blanked when switching from Auto to Manual 

emission mode while E-Neut is On. 
22. Hardware>X-Ray: For HXPS systems, improve keeping track of anode material displayed for 

anode positions.  
23. Hardware>X-Ray: Fix changing mode from ‘Blank’ to ‘On’ not unblanking the X-Ray Beam Park 

scanning when anode initialization or move occurs.  
24. Hardware>X-Ray>Properties…>Service: Fix Beam Parking scanning utilizing skew and rotation 

corrections (for Cr source).  
 

KNOWN BUGS 



1. Although able to Intro a Platen from Prep to Intro to start pumpdown of Platen at Intro while 
Acquisitions running (with separate diff pumps), not currently able to save Intro Photo taken at 
Intro to the platen at the Intro while current platen is the platen being acquired at the Stage. 

 
NOTES 

5. Make sure that SmartMosaic has been installed.  This option is by default enabled and 
considered a standard feature. 

6. Starting with V4.4.0 Option Keys are stored and referenced differently.  When updating software 
from older versions of SmartSoft-XPS, option key installations will need to be uninstalled and 
have new option key installations run to have ConfigManager recognize installed options. 

7. Platen Settings are not backwards compatible for files created before V4.2.  Should create new 
platens and avoid using old platen definitions to avoid problems with Platen Max Z and platen 
photo image handling. 

8. When changing E-Neut Filament type in Configuration Setup, if this is not a first time install 
(EGunNeut Settings present), E-Neut Work Function and Software Limit (A) will need to be 
manually updated for the new filament type in E-Neut Properties. 

9. HXPS Lens table should be replaced when updating Quantes systems with lens table provided in 
this version to remove 448 PE from acq setup options. 

10. Platen Editor feature that existed with old Queue implementation has been removed.  Queue 
Editor allows users to setup multiple acquisitions with existing platens while queue is running. 
 

 
___________________________________________________________________________ 
 
Release 4.3.3 – January, 2023 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Support displaying Aux Intro without Aux Ion Gauge Configuration 
 
NEW FEATURES 
 

System 
1. System>Chamber View: Support displaying Aux Intro without Aux Ion Guage Configuration. 

 
BUG FIXES 

1. System>SPS: Fix benign errors filling up system log about reading zero bytes when configured 
with Gage-Chek SPS Encoder. 

2. System>Q2 Main Turbo:  Q2 Main Turbo 11-779/20-779 control support.  Previous support was 
for 42-2XX control.  To change to 11-799/20-799, edit ConfigManager Properties.phi 'Quantera2 
Main TMP Ctrl (2xx|779)' parameter. 

3. System>Platen Manager: Restore Auto Directory feature. 
 

KNOWN BUGS 
1. After Improved Queue support, V4.2.0, data file header information for Presputter (Presputter 

Yes/No, Target Sputter Time) can be incorrect. 
 
NOTES 

1. Platen Settings are not backwards compatible for files created before V4.2.  Should create new 
platens and avoid using old platen definitions to avoid problems with Platen Max Z and platen 
photo image handling. 

2. When changing E-Neut Filament type in Configuration Setup, if this is not a first time install 
(EGunNeut Settings present), E-Neut Work Function and Software Limit (A) will need to be 
manually updated for the new filament type in E-Neut Properties. 

3. HXPS Lens table should be replaced when updating Quantes systems with lens table provided in 
this version to remove 448 PE from acq setup options. 



4. Platen Editor feature that existed with old Queue implementation has been removed.  Queue 
Editor allows users to setup multiple acquisitions with existing platens while queue is running. 

5. Make sure to run ConfigurationSetup to make sure all configuration files are present for new 
Dynamic Correction Factors support. 

 
  



 
___________________________________________________________________________ 
 
Release 4.3.2 – July, 2022 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Disable Dialog Minimize, Support Enable/Disable Aux station, Bug Fixes. 
 
NEW FEATURES 

 
UI  
1. Dialog Minimize:  Disallow dialogs to be minimized.  This eliminates some confusion finding 

minimized dialogs as well as issues where minimized dialogs disappear. 
 
System 
1. System>Platen Transfer: Add right-click enable/disable of Aux station. Disabled Aux station 

disallows transfers and disallows station to become current. 
 
BUG FIXES 
 

4. XPS>Acq Setup>Properties: Fix view sizing that was clipping presputter setup. 
5. XPS>Refresh Acq: Fix restarting refresh acquisition failing. 
6. Hardware>Xray: Fix mode radio button sticking when switching modes (mode changes but mode 

displayed incorrect). 
 

KNOWN BUGS 
1.  

 
NOTES 

1. Platen Settings are not backwards compatible for files created before V4.2.  Should create new 
platens and avoid using old platen definitions to avoid problems with Platen Max Z and platen 
photo image handling. 

2. When changing E-Neut Filament type in Configuration Setup, if this is not a first time install 
(EGunNeut Settings present), E-Neut Work Function and Software Limit (A) will need to be 
manually updated for the new filament type in E-Neut Properties. 

3. HXPS Lens table should be replaced when updating Quantes systems with lens table provided in 
this version to remove 448 PE from acq setup options. 

4. Platen Editor feature that existed with old Queue implementation has been removed.  Queue 
Editor allows users to setup multiple acquisitions with existing platens while queue is running. 

5. Make sure to run ConfigurationSetup to make sure all configuration files are present for new 
Dynamic Correction Factors support. 

  



 
 
___________________________________________________________________________ 
 
Release 4.3.1 – April, 2022 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Support Imaging Source GigE Intro Camera, Bug Fixes. 
 
NEW FEATURES 

Configuration  
1. Add GigE (Imaging Source) Intro Camera 

 
System 
2. System>Photo>Properties>GigE Properties: Disable SLI LED Lights controls for Aux station 

camera. 
 

Sample 
3. Sample>Platen Image View: Add Std, Ang, and SPS buttons to switch alignment set manually. 

 
BUG FIXES 
 

1. Ribbon/Dashboard>Queue: Fix Save not working in Queue editor for saving changes to 
Directory. 

2. Sample>Stage>Diagnostics: Enable/Disable motors not working, including Enable All and Disable 
All buttons in Stage Properties. 

3. XPS>SXI: Fix SXI erroring out with only Access Violation logged in system log when scan pattern 
clipping occurs (SS-XPS V4.3.0 bug). 

4. Hardware>Xray: For Quantes, fix bug where anode position #19 (or highest defined Cr anode 
position) was not recognized as a ‘Cr’ anode position. 
 

KNOWN BUGS 
1.  

 
NOTES 

1. Platen Settings are not backwards compatible for files created before V4.2.  Should create new 
platens and avoid using old platen definitions to avoid problems with Platen Max Z and platen 
photo image handling. 

2. When changing E-Neut Filament type in Configuration Setup, if this is not a first time install 
(EGunNeut Settings present), E-Neut Work Function and Software Limit (A) will need to be 
manually updated for the new filament type in E-Neut Properties. 

3. HXPS Lens table should be replaced when updating Quantes systems with lens table provided in 
this version to remove 448 PE from acq setup options. 

4. Platen Editor feature that existed with old Queue implementation has been removed.  Queue 
Editor allows users to setup multiple acquisitions with existing platens while queue is running. 

5. Make sure to run ConfigurationSetup to make sure all configuration files are present for new 
Dynamic Correction Factors support. 

 
  



 
___________________________________________________________________________ 
 
Release 4.3.0 – January, 2022 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Mosaic Image, Dynamic Correction Factors, Improved E-Neut, Gage-Chek SPS, Bug Fixes. 
 
NEW FEATURES 

Configuration  
37. Add SPS Encoder configuration for Quadra-Chek or Gage-Chek. 
38. E-Neut: E-Neut Filament type can be set. Please check ‘E-Neut Filament’ type in System 

Configuration. 
39. Options: Add Mosaic Map option. 
40. Launch ConfigurationSetup automatically after installations complete. 
41. Change default COM ports: SPS Encoder = 2, C60 = 15, Main Pump = 17. 
 

 
UI  
42. Menu Bar>System>Zip Log Files…:  Create temp SEE database file to zip to avoid problem 

where .sqlite.shm and .sqlite-wal get out of sink with main .sqlite file. 
43. Menu Bar>Tools>Outgas Conditioning…: Display ramp parameters in Queue Task Summary. 
44. Menu Bar>Tools>Outgas Conditioning…: E-Neut outgas improvements. 
45. Menu Bar>Tools>Chart Recorder…: Add GCIB PressureInKPa to be monitored. 
46. Menu Bar>Tools: Add a SEE Database Apps menu to the Tools menu and add the SEE options 

to that menu. 
47. Ribbon/Dashboard>Sputter Tool: Add E-Neut during sputter support. 
48. Ribbon/Dashboard>Queue>Queue Editor: Improve Copy/Paste support. 
49. Ribbon/Dashboard>Queue>Queue Editor: Add ‘Sleep Until’ task, can select date/time. 
50. Ribbon/Dashboard>Queue>Queue Editor: Connect Wait For Chamber Pressure queue task, also 

add Wait For Intro Pressure queue task. 
 

System 
51. System>Platen Transfer: For systems with Aux transfer rod, make sure that rod is retracted for 

transfers to Aux station to be valid. 
52. System>Platen Manager: Change default max z-height for platens: Standard = 26mm, Angle 

Resolve = 12mm. 
53. System>SPS Camera: Read ranges of Gamma, Hue, Saturation from the camera. 
54. System>SPS: Change default center position to be ‘Center’ instead of ‘Upper Left’. Also add 

more access to diagnostics view through right-click access on more SPS views. 

 
Sample 
55. Sample>Platen Image View: Add support to move from Intro Photo>SPS>Intro Photo using 

GoogleBar zoom. 
 

XPS 
56. XPS>Acq Setup: Add combined ‘Add Queue’ and ‘…’ buttons to all acq setup menus. 
57. XPS>SXI>Mosaic: Add Mosaic option SXI support  
58. XPS>Map>Mosaic: Add Mosaic option Map support  
59. XPS>Profile: For HP acquisitions with X-Ray mode during sputter set to Park, the X-Ray is left 

On (cannot park HP X-Ray).  Add user confirmation when this combination is set up on validation. 
60. XPS>Spectrum>Mosaic: Add Mosaic option Spectrum support 
61. XPS>Data File Header: Add E-Neut active status to header  



62. XPS>Data Manager: Support Add To Position List for .sps, .pho, .sem, .sxi, .map files.  
Only supports maps acquired from position list. 
 

Hardware 
63. Hardware>E-Neut: Changing modes and other operations will no longer block UI while operation 

executes. 
64. Hardware>E-Neut: Standby filament current is now set by filament type. 
65. Hardware>E-Neut: Default values for Work Function and Software Limit set based on filament 

type.  *NOTE*: defaults work for new installations w/o settings, updates will need to have these 
values updated. 

66. Hardware>E-Neut: Change default filament type to BaO. 
67. Hardware> Detector>Properties>Channels: Add ‘Dynamic Correction Factors’ support, rename 

classic single pass energy acquisition to ‘Single Point Correction Factors’. 
68. Hardware>Xray>Properties>Service: Change default Beam Parking setting to INITIAL from 

PREVIOUS.  
69. Hardware>Xray>Application Log: Restore X-Ray filament and emission readings log.  New 

application log name is ‘Xray Filament Emission Log’. 
 

BUG FIXES 
 

25. Menu Bar>Tools>Outgas Conditioning…: Fix Application Log messages. 
26. Menu Bar>Tools>Power Loss Recovery…: Fix menu option not launching Power Loss Recovery. 

Also add 2-min delay between disabling card rack power and enabling card rack power. 
27. Ribbon/Dashboard>Queue: Fix Save To File Chart Recorder Task.  Would default to blank data 

field where filename should be. 
28. Ribbon/Dashboard>Queue: Fix changing Area type in Queue Editor not picking up on changes to 

default area size since startup. 
29. Ribbon/Dashboard>Sputter Tool: Fix divide by zero error happening if zalar happens to start at 

center of rotation. 
30. Ribbon/Dashboard>Sputter Tool: Fix Stopping Zalar causing a long timeout, also fix Zalar Hitting 

Limit Switch not causing error and stopping zalar during sputter. 
31. Ribbon/Dashboard>Sputter Tool: Fix checking ‘E-Neut’ checkbox actually setting Zalar ‘rotation’. 
32. Ribbon/Dashboard>E-Neut/Ion Gun: Fix filament usage not updating. 
33. System>System Log: Fix logging of Read Ion Pump parameters when system not configured with 

Ion Pump. 
34. System>System Log: Fix name clash when logging MotorHdwrCtrl and CrFXSMotorHdwrCtrl. 
35. System>System Log: Fix collisions happening a lot on systems with a lot of turbos, which would 

cause a lot of errors being logged and read/write calls to turbos to fail. 
36. System>Stage>Diagnostics>Cr FXS (Quantes): Shutter Status is always ‘Unknown’.  This status 

cannot currently be read from hardware.  To help with confusion, dither status and add hint. 
37. System>Platen Transfer: Restore restrictions to not allow platen transfers while queue is running, 

except between Prep and Intro on separate diff pump systems. 
38. System>Platen Transfer: Fix unable to transfer platen from Prep to Intro while queue is running 

on system with separate turbo pumps (diff pump). 
39. System>Platen Transfer: With single turbo systems, turn Ion Gun Off when transferring through 

Intro/Chamber barrier to prevent IG gas being left on without diff pumping. 
40. System>Platen>Browse…: Fix being able to click/drag platen thumbnail image causing bad 

behaviors that require SmartSoft restart. 
41. Sample>Platen Image View: Fix Angle Resolve platen blue box not drawing to correct size. 
42. Sample> Platen Image View: Fix right-click menu ‘Default Area Size…’ not working. 
43. Data Viewer>Peak ID: Fix HXPS Peak ID not working and giving an error in system log. 
44. XPS>SXI: Fix E-Neut Auto/Off radio buttons not working. 
45. XPS>Acq Setup: Fix defaulting pass energy to 6.5 if saved setting PE not found in PE list. 
46. XPS>Map Acquisition: Fix Stop Failing when Map frame time is fast (ie. 0.5 or 1.0 ms time per 

pixel, small area). 



47. XPS>Map/Line Acquisition: Fix Pixel Size calculator not using highlighted current position in 
position list. 

48. XPS>Profile Acquisition: Fix Alternate Sputter Position depth profile causes subsequent non-
althernate sputter position sputtering to fail and time out. 

49. XPS>Profile Acquisition: Fix problems with multiple SXI child area data file headers only saving 
first area information.  This would affect Multipak and trying to run More on these files. 

50. XPS>Spectrum: Fix unscanned Spectrum Acq not doing Cycle Stop when Stopping Acq. 
51. Data Acquisition: Data Acq DLL attempts Abort and Mode Reset operations to address SXI 

Gauze Lens Not Ready errors. 
52. Hardware>E-Neut: Set min SXI Pulse Frequency to 2 (frames), as value of 1 causes SXI with E-

Neut to not work. 
53. Hardware>GCIB: Fix bug where Blank mode during timed sputter not blanking fast enough (wait 

for bend before raster Off).  
54. Hardware>Xray: Fix refresh issue where changing offsets would not appear in other locations 

until other parameter values changed (Main View and Properties).  
55. Hardware>Xray>Diagnostics: Fix Filament Current readback displaying setpoint instead of 

readback from hardware. 
 

KNOWN BUGS 
2.  

 
NOTES 

11. Platen Settings are not backwards compatible for files created before V4.2.  Should create new 
platens and avoid using old platen definitions to avoid problems with Platen Max Z and platen 
photo image handling. 

12. When changing E-Neut Filament type in Configuration Setup, if this is not a first time install 
(EGunNeut Settings present), E-Neut Work Function and Software Limit (A) will need to be 
manually updated for the new filament type in E-Neut Properties. 

13. HXPS Lens table should be replaced when updating Quantes systems with lens table provided in 
this version to remove 448 PE from acq setup options. 

14. Platen Editor feature that existed with old Queue implementation has been removed.  Queue 
Editor allows users to setup multiple acquisitions with existing platens while queue is running. 

15. Make sure to run ConfigurationSetup to make sure all configuration files are present for new 
Dynamic Correction Factors support. 

  



 
 

 
Release 4.2.0 – March, 2021 (Win10: 64-Bit) 

 
OVERVIEW 

Improved Queue, Ribbon/Dashboard, Bug Fixes. 
 
NEW FEATURES 

SEE  
1. Monitor and generate errors when USB devices are connected or disconnected. 

 
UI  
2. Ribbon/Dashboard: Queue Status: Display Status and Stop/Abort of running Queue. 
3. Ribbon/Dashboard: Acq Status: Display Status and Stop/Abort of running Acquisition. 
4. Ribbon/Dashboard: Queue: Overview and basic control of Queue.  Access to Queue Editor for 

modifying Queue Tasks. 
5. Ribbon/Dashboard: Data Manager: Easy access to common Data Manager parameters. 
6. Ribbon/Dashboard: Acquisition: Control of most common XPS Acquisition Properties. 
7. Ribbon/Dashboard: Sputter Tool: Easy access control for timed sputtering with configured sputter 

guns. 
8. Ribbon/Dashboard: Vacuum: Display vacuum pressure status. 
9. Menu Bar >Queue>Queue Editor…: New Tree View style Queue Editor allows editing queue 

even while queue is running. 
10. Menu Bar >Queue>Queue Editor…: File numbering will auto increment when running acquisitions 

through the Queue instead of saving a snapshot of what number to use.  There is a reset 
numbering override to set the file number used through the Queue Editor. 

11. Menu Bar >Queue>Queue Editor…>Tool Palette>Service: Outgas can now be performed through 
the Queue. 

12. Menu Bar>Tools>Outgas Conditioning…: Control parameters for Outgas procedures can be 
setup here. 

13. Parameter Hints: Hint display duration now depends on hint text length. 
14. Menu Bar>Tools>Chart Recorder…: The Chart Recorder now displays pressure values in 

scientific notation. 
 

System 
15. Installation>Custom Actions:  Install USB drivers in addition to normal dll registration. 
16. Platen Creation/Platen Load: Refactored Create Platen and right-click -> ‘Browse…’ platen 

management. 
17. System>Photo: Add support for Auxiliary Intro Camera. 
18. System>Vacuum>Vacuum Diagnostics>Interlock: Add Intro Ion Gauge Filament selection. 
19. System>Platen Transfer: Platen being moved will become current platen (blue box). Old 

implementation used to make platen at stage current after transfer completes. 
20. System>Platen Manager>Properties>Filename: Auto Filename and Auto Comment options 

changed to be more consistent across techniques. 
 
Sample 
21. Sample>SXI: Display Persistence: Min Persistence for Preview and Registration changed to 2 

frames. 
22. Sample>Stage>Initialize: Turn X-Ray Off if it is in On or Park mode.  Fail to initialize if unable to 

change mode. 
23. Sample>Stage>Stage Properties: Add Enable All and Disable All buttons for controlling all 

motors. 

 
 



 
XPS 

24. XPS >Acquisition Properties>Acceptance Angle: Quantes configuration only allows ‘Standard’ 
acceptance angle. 

25. XPS>Refresh Acquire: Regenerate and reset scan pattern to pick up changes to X-Ray 
Parameters. 

26. XPS>Data File Header: For data files, storing Ion Gun Neutralizer parameters separate from Ion 
Gun  Presputter parameters. 

27. XPS>Data Viewer: Added ‘Auto-Close Last Acquisition File’ checkbox to control closing last 
acquisition data file displayed when new data file plot added. 

28. XPS>Map: More Map disabled until it can be supported in a useful way with new Queue support.  
Old implementation was very limited and not useful. 

29. XPS>Profile>Profile…: Add Sputter Offset feature for profile acquisitions. 
 
Hardware 
30. Hardware>Analyzer>Properties…>TFC Constants: Quantes configuration only allows ‘New TFC’ 

algorithm, all other configurations only allows ‘Traditional A/B’ algorithm. 
31. Hardware>Schematic…:Update missing hardware schematic diagrams. 
32. Hardware>E-Neut>Diagnostics: New support added for reading ADC values. 
33. Hardware>GCIB: 777B Pressure Ctrl: Turn Pressure Control off when V8 closed. 
34. GCIB/IonGun: 777B: Monitor pressure control power. Restore ON state if power OFF. 
35. Hardware>Xray>E-Gun State: Don’t allow X-Ray On or Park when stage is not initialized. 
36. Hardware>Xray>Anode: Set default anode position before positions are set to 9mm instead of 0, 

which would likely be over water line. 
37. Hardware>Xray>Anode: Initialize anode motor before Beam Size and Beam Power operations.  

This can be disabled/enabled through Xray Properties -> Service Tab. 
38. Hardware>Xray>Anode: Initialize anode motor Initialize Anode Motor on startup. 
39. Hardware>Xray: When X-Ray mode is set to ‘On’ force drive to currently loaded anode position. 
40. Hardware>Xray>Xray Diagnostics: Remove “Read” from captions for diagnostics readings. 

 
BUG FIXES 
 

1. System: Change to prevent SmartSoft from refreshing display on Windows group policy updates, 
causing a lot of flickering of UI. 

2. System>ConfigManager Properties: Fixed bug where ConfigManager properties file could end up 
blank.  This would end up resetting Configuration settings. 

3. System>Exit: Fixed bug where shutdown of SmartSoft while SXI was running could cause 
SmartSoft to hang. 

4. System>System Menu>Zip Log Files…: Fix problem zipping files when last line in file doesn’t 
start with a time tag. 

5. System: Intro Platen:Change default Intro Pressure setpoint for transfer to 2.7E-4 Pa. Limits 
change to 1E-3Pa to 1E-7Pa. 

6. System>Photo: Fix Spatial Area definition missing from Intro Photo data file header.  Multipak 
uses this with Spatial Area feature when showing location of SXI. 

7. System>Photo: GigE Intro Camera: Fix system log messages with GigECamera dll. 
8. System: USB Camera: Fix 64-Bit Installation installing 32-bit IC Imaging dlls causing USB 

cameras to fail to initialize. 
9. Sample>Intro Photo>Platen Size Box (Blue Box): Fix Angle Resolved Platen Type sizing. 
10. Sample>Position List: Fix IR active checkbox handling in position list. 
11. Sample>Stage: Fix Zalar Rotation speed not changing Zalar Limits circle on platen image. 
12. Sample>Stage: Fix Stage application log displaying a lot of ‘NAN’ values instead of motor 

number. 
13. XPS>Data File Header: Fix Technique stored in data file header saving incorrectly. 
14. XPS>Map: Fix acquisition status displaying frames progress starting and two frames and ending 

one frame above max frames. 



15. XPS>Spectrum>Step Size: Fix floating point divide by zero error happening due to being able to 
select invalid 2.0 eV step size option for 448 PE (Quantes).  Fixed PE default step size 
selections. 

16. XPS>Spectrum>Element Database: Fix bug with Element Database Editor where editing Xe 
transition names would be converted to “CustomXe…”. 

17. XPS>Spectrum>Sputter: Fix bug where presputter w/ zalar option would not finish before 
acquisition to follow would start (starts while driving stage back to home position). 

18. XPS>Spectral Data>Peak ID: Fix Quantes HXPS Peak ID not working. 
19. XPS>SXI Viewer>Image Registration: Fixed bug where if SXI IR is started after SXI has already 

been restarted (ie. FOV change), IR Preview fails due to failing to stop SXI. 
20. XPS>SXI Viewer>Image Registration: Fix SXI IR not displaying in live SXI Viewer. 
21. XPS>SXI: Fix tiny SXI Error dialog with no information that could pop up on some imaging 

acquisition failures. 
22. XPS>SXI: Change Dual Source Ar Ion Gun to Standby from Blank during SXI and restore mode 

after. 
23. XPS>Z-Align: Fix bug where Z-Align with pulsed I-Neut or SXI IR with I-Neut could lock up UI for 

5-6 minutes before timing out. 
24. Hardware>C60: Fix Temperature, Grid, and Repellor needing to be restroked when changing 

from Off mode to Standby. 
25. Hardware>GCIB: Fix a bug where ‘Pressure (kPa)’ parameter value was not updating when 

setting loaded, but pressure was getting set to hardware correctly. 
26. Hardware>GCIB: Fix a bug where Ar leak valve would not show closed after presputter. 
27. Hardware>GCIB: Fix a bug where pressure readback display wasn’t updating unless readback 

button was pressed. 
28. Hardware>Dual Ar Ion Gun (GCIB/IonGun): Increase raster calibration X/Y range to 50. 
29. Hardware>Dual Ar Ion Gun (GCIB/IonGun): Fix sputter time not counting down. 
30. Hardware>E-Neut: Improve E-Neut error handling in addition to fixing Source Tolerance Required 

feature.  
31. Hardware>Ion Gun: Fix Extractor Pressure window sizing becoming too large and can’t resize. 
32. Hardware>Xray: Fix a bug where acquisition would continue without a message when heat 

exchanger (water flow status) is stopped. 
33. Hardware>Xray>Beam Size: Fix a bug where Beam Size acquisition would drive to beam size 

anode position, but then drive to X-Ray Setting anode position before running beam size 
acquisition. 

34. Tools>Chart Recorder:  Fixed bug where parameters for non-configured features would be shown 
in drop-down menu. 

 
KNOWN BUGS 

1. This version does not prevent Users from transferring platens while queues are running.  Moving 
a platen while a queue is running can have detrimental effects, especially if an acquisition is 
running when the platens are moved.  This should be avoided until SmartSoft prevents this in the 
future. 

 
NOTES 

1. Platen Settings are not backwards compatible for files created before V4.2.  Should create new 
platens and avoid using old platen definitions to avoid problems with Platen Max Z and platen 
photo image handling. 

2. HXPS Lens table should be replaced when updating Quantes systems with lens table provided in 
this version to remove 448 PE from acq setup options. 

3. Platen Editor feature that existed with old Queue implementation has been removed.  Queue 
Editor allows users to setup multiple acquisitions with existing platens while queue is running. 

4. Ion Gun neutralization with this version is always what used to be ‘continuous’ option.  If user 
wishes to run ‘per position’ neutralization, currently need to add IG mode -> Standby to queue 
sequence. 

 
 



 
 
 
 
___________________________________________________________________________ 
 
Release 3.10.4 – January, 2020 (Win7: 32-Bit)  
Release 4.1.4 – January, 2020 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Aux station camera, Dual Source Ion Gun. 
 
NEW FEATURES 

Intro 
1. Intro>Photo: Add support for Auxiliary station camera. 

 
Hardware 
2. GCIB: Increase max X/Y raster calibration to 50.0. 
3. GCIB: Dual Source: If GCIB is in blank mode when starting SXI, switch it to Standby mode, then 

restore gun mode after SXI completes. 
 

BUG FIXES 
 
 
___________________________________________________________________________ 
 
Release 3.10.3 – August, 2019 (Win7: 32-Bit)  
Release 4.1.3 – August, 2019 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Depth Profile, SXI, and IR improvements, Bug Fixes. 
 
NEW FEATURES 

Sample 
1. Sample>SXI: Change min persistence of N-frame SXI acquisitions (Preview, IR) to 2 frames. 
2. Sample>Stage>Properties: Add ‘Enable All’ and ‘Disable All’ motors buttons. 

 
Hardware 
3. Ion Gun: Support Ion Neut parameters separate from Presputter parameters in data file header. 
 

BUG FIXES 
 

1. Sample>Image Registration: Fix bug where ‘IR Preview’ or ‘Test IR’ would cause an error about 
‘Failing to stop SXI’ if SXI was running and was restarted (ie. FOV change). 

2. Sample>Position List: Fix the IR Active checkbox grouping so that SXI and children positions are 
grouped together. 

3. Sample>Platen Viewer: Fix the Zalar Range Circle not updating ‘live’ when zalar speed adjusted. 
4. XPS>Depth Profile>GCIB Profile: Ignore turbo pump status read call failures.  Daisy-chained 

turbo pumps sharing physical comm lines can have calls fail. 
5. XPS>Timed I-Neut During Acq:  Fix bug where timed I-Neut pulse before Z-Align would cause 

acquisition to lockup trying to switch back to continuous I-Neut after Z-Align. 
6. XPS>Depth Profile: Fix bug where Depth Profile with IR enabled fails, then Ion Gun or GCIB 

auto-shutdown occurs before user reacts to IR failure.  Selecting ‘Stop’ would cause a lockup in 
this state.  Fixed ‘Stop’ not working. 



 
___________________________________________________________________________ 
 
Release 3.10.2 – March, 2019 (Win7: 32-Bit)  
Release 4.1.2 – March, 2019 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Bug Fixes. 
 
NEW FEATURES 

1.  
 

BUG FIXES 
1. System>Config Manager: Fix bug where PhiConfigManager Properties.phi file would get 

overwritten as a blank file unless SmartSoft exited normally.  
2. System>Exit:  SmartSoft will inform the user to stop SXI before it shuts down.  SmartSoft would 

not properly shut down the SXI for the user on exit. 
3. XPS>Refresh Acquisition: Fix the ‘Restart’ button functionality so that Analyzer parameters 

changed would get applied to the Scan Pattern of the restarted acquisition. 
 
___________________________________________________________________________ 
 
Release 3.10.1 – November, 2018 (Win7: 32-Bit)  
Release 4.1.1 – November, 2018 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Improved HXPS Support, Bug Fixes. 
 
NEW FEATURES 

Intro 
1. Intro>Platen Thumbnail: Add capability to change thumbnail caption color. 

 
Hardware 
2. Hardware>Dual Source: Update glyph diagram to not show rotation, tilt, trapezoid raster controls. 
 

BUG FIXES 
 

1. Sample>Position List: When driving to position stage sometimes moves even when already at 
position when at 360.0 rotation.  Increase limits of position to account for some actual stage 
position error greater than 360.0. 

2. System>Vacuum:  Improve support for Vacuum Pumpdown and Backfill procedures on Quantes 
systems. 

3. Hardware>Analyzer: Cr Retard Modulation Ratio was missing. 
4. Hardware>Analyzer: Fix problem with Quantes Analyzer control where changing Shutter Bias 

would not have any effect when SXI is running. 
5. Hardware>Ion Gun: Fix Auto Pressure Control not working when option checked on software 

startup. 
  



 
___________________________________________________________________________ 
 
Release 3.10.0 – October, 2018 (Win7: 32-Bit)  
Release 4.1.0 – October, 2018 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

SEE Diagnostics, Dual Source GCIB/Ar Ion Gun, SXI Image Registration Enhancements, HXPS 
Support (official release), Bug Fixes. 

 
NEW FEATURES 

SEE  
1. The System Evaluation Environment (SEE) is a new service utility built into the SmartSoft 

software which periodically records all system parameters while SmartSoft is running.  Notes: By 
default this utility is not activated; and Proprietary analytical data is never collected with SEE.  

2. Menu Bar>Hardware>System Configuration>System…>SEE: SEE data collection can be fully 
activated or deactivated in the configuration menu. 

3. Menu Bar>Hardware>System Log Setup>Data Sampling: SEE data collection can be partially 
activated or deactivated for individual hardware devices by selecting Data Sampling.  Note that 
Data Sampling for individual devices is only valid when SEE data collection is activated in the 
System Configuration. 

 
UI  
4. Menu Bar>Tools>System Configuration: Simplified UI: configuration options are organized by 

sessions; property dialogs are added for configuration details. 
5. Menu Bar>Tools>System Configuration: Add Dual Source GCIB and Ion Gun options, along with 

77B pressure control. 
6. Menu Bar>Tools>System Configuration: Support DFK 42AUC03 USB camera for SPS. 
7. Menu Bar>Tools>System Configuration: Add support for the Gamma MPCq pump controller. 
8. Menu Bar>Tools>Chart Recorder…: The Chart Recorder now includes an ‘Auto Scale’ feature 

which optimizes the data displays for all plots. 
9. Menu Bar>Tools>Resource Monitor: Add monitoring of C: hard disk space.  A warning message 

is displayed when the available disk space falls below an enterable threshold value. 
10. Menu Bar>Tools>Bake and Sublimation: Change the maximum baking time and cool down time 

to 200 hrs. 
11. Menu Bar>Tools> Bake and Sublimation: MPCe TSP cycle time includes ON and OFF time. 
12. Menu Bar>System>Task Scheduler: A ‘Once’ checkbox option is added to the task scheduler to 

run task only one time. 
13. Menu Bar>System>Zip Log Files: Include timestamp in the default filename. 
14. Status Bar: Add Acquisition Setup Properties indicators. 

 
Intro 
15. Intro>SPS: Add SPS diagnostics for USB SPS camera to set 0,0 calibration to ‘Center’ or ‘Upper 

Left’. 
16. Intro>Intro Camera: GigE: Log error description along with error code in system log. 
 
System 
17. System>Vacuum>Valves: Change V15 caption from 'Backfill Main TMP' to 'Cooling Vacuum 

Area'. 
18. System>Vacuum>Vacuum Diagnostics (Non-EPC): Support continuous read button. 
19. System>Vacuum: Add support for MCPq sublimation. 
 
Sample 
20. Sample>Z-Align: Check if Z-height is equal to or lower than initial Z-Align drop. If this is true start 

Z-Align at current Z-height. 



21. Sample>Stage>Stage Properties: Add Protection During Acquire and Protection During Drive.  
Protection During Acquire: lowers the Z and R when the stage is moved to the next analysis point 
during an acquisition; Protection During Drive: lowers the Z and R when stage is moved using the 
stage Drive All feature. 

 
XPS 
22. XPS>Data Manager>Lab Book: The lab book can now include an unlimited number for data file 

entries.  Previous limit was 150. 
23. XPS>HXPS: Add HXPS support to acquisitions.  
24. XPS>Spectrum>Properties: Support selecting pre-sputter gun type. 
25. XPS>Depth Profile>Sputter Rate Table: Support selecting sputter gun type per layer in sputter 

table. 
26. XPS>Acquisition Setup>Refresh Acquisition Viewer: Add Restart button. 
27. XPS>Acquisition Setup>Refresh Acquisition Viewer: Add FWHM reading to data display. 
28. XPS > SXI Properties>Image: Add enhanced live image processing options: Bright Band 

Correction, Noise Reduction, and Contrast Enhancement. 
29. XPS >SXI Viewer>Image Registration: The saved reference image is now displayed as part of 

the image registration setup dialog. 
30. XPS > SXI Viewer>Image Registrations>Properties: One can now pre-select the acquisition 

behavior when an image registration fails (Prompt User, Continue, Stop).  Prompt User - will 
display a dialog box and wait for operator intervention; Continue - will continue the data 
acquisition without image registration; Stop - will stop the acquisition at the current frame or cycle.   

31. XPS > SXI Viewer>Image Registrations>Properties: One can now select the number of IR retries 
before reporting a failure.   

 

Hardware 
32. Hardware>C60: Timed Sputter supports driving platen to Aux position. 
33. Hardware>C60: AutoStartup Properties View: Add expandable tabs for C60 AutoStartup 

properties dialog. 
34. Hardware>C60: Split off the service information (lifetime, auto-shutdown) values into a separate 

tab. 
35. Hardware>C60: C60 diagnostics menu meter range is red when the gun is off.  Added support to 

show the range is unknown [- - -] when the gun is off. 
36. Hardware>GCIB: Timed Sputter supports driving platen to Aux position. 
37. Hardware>GCIB: Add extractor pressure Large Font dialog. 
38. Hardware>Analyzer: Add unique Gauze Lens Spans and Offsets for HP. 
39. Hardware>Analyzer: Calibration: TFC coefficient A range max increased to 1000. 
 

Service 
40. CommChecker.exe: A new utility called CommChecker is included in the SmartSoft-XPS\bin 

folder. CommChecker is used to check the communication channels as defined in the SmartSoft-
XPS configuration properties file for trouble shooting purpose. 

 
BUG FIXES 
 

1. UI>Tab Stop: Tab stops are removed for all menus. 
2. UI>Menu Bar>Tools>Bake and Sublimation: Final Cool Down Pressure was 5e-10, which is too 

low for many systems to meet in reasonable time.  Changed to 6.7e-8. 
3. UI>Menu Bar>Tools>Bake and Sublimation: Agilent Ion Pump Bake Error: Fixed problem were 

maximum number of retries property was not used. 
4. UI>Menu Bar>Tools>Bake>Diagnostics>MPC: Readback is showing main ion pump current.  It 

should be showing sublimation current. 
5. UI>Menu Bar>System>Task Scheduler…: Fixed problem where the Task Scheduler incorrectly 

reports “AutoTool is already running”. 
 



6. System>SPS: Fixed Initialize Error with Matrox SPS 
7. System>Intro Photo>Take Intro Photo: Corrected bug where intro photo is taking many minutes. 
8. System>Vacuum:  No Ion Pump system configuration still tries to communicate with Ion Pump. 

 
9. Sample>Z-Align: Z-Align Analyzer Lens Values not set correctly (Quantes Only). 
10. Sample>Z-Align: Unable to right-click to get to Z-Align application log. 
11. Sample>Position List>Z Position = 0.0: A default Z position of 0.0 indicates that the Z position is 

unknown at the time the position is created (e.g. platen not on the stage; import from defect file).  
Drive to Position ignores the Z move when the Z position is 0.0.  SmartSoft now displays a 
prompt which clarifies that a  default value of 0.0 maintains the current Z position; while a value of 
0.001 drops the Z to a minimum Z position.  

12. Sample>Position List: When driving to position stage sometimes moves even when already at 
position.  Increase X/Y tolerance. 

13. Sample>Platen Viewer: Photo appears washed out, too light.  Changed default gamma from 0.6 
to 1.0. 

14. Sample>Stage: Fixed Stage Error On Init After Motor Power Cycle. The POS and NEG limit 
status of Arm extension or R axis is limited, and initialization is failed. 
 

15. XPS>SXI: SXI Analyzer Lens Values not set correctly (Quantes Only). 
16. XPS>Spectrum>Element Database: Default transition energy window for Ru3p3 is 458-478 eV.  It 

should be 453-473 eV. Note that element database must be manually updated to get this fix. 
17. XPS>Spectrum>Element Database Element Database: Remove spaces from transition names 

and replace with ‘_’ character to prevent problems managing between SmartSoft and Multipak.  
Note that element database must be manually updated to get this fix. 

18. XPS>Depth Profile: During GCIB depth profile with ion neutralization, the profile often fails by 
Timed Sputter Failure. (OLE Error).   
 

19. Hardware>Analyzer: The Analyzer View was displaying 'Al Photon Energy' in the case of a single 
anode (non-HXPS) system.  Changing the value would update the Photon Energy used correctly 
but would not display the changed value. 

20. Hardware>C60/GCIB: Persist lifetime value to file when values change to protect against crash or 
forced shutdown.  Note that Ion Gun lifetime times are in saved in the firmware and do not need 
to be persisted in SmartSoft. 

21. Hardware>GCIB: PHI USA GCIB: Loading setting file while in standby mode should not load the 
high voltage.  

 
KNOWN BUGS 

1. None 
 
NOTES 

1. This release is not intended for and should not be installed Quantum or Quantera I (EPC) 
systems. 

 
___________________________________________________________________________ 
 
Release 3.9.3 – May, 2018 (Win7: 32-Bit)  
Release 4.0.3 – May, 2018 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Bug Fix Version, fixes Cr FXS Motor Hardware Control WinUSB 
 
BUG FIXES 

1. HXPS: Fix Cr FXS Motor Hardware Control WinUSB support. 
 
___________________________________________________________________________ 



 
Release 3.9.2 – March, 2018 (Win7: 32-Bit)  
Release 4.0.2 – March, 2018 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Bug Fix Version, fixes EPC Spectrum Stop Acquire 
 
BUG FIXES 

1. XPS: EPC: Fix Stop Acquire with Spectrum acquisitions not stopping until acquisition or position 
is complete. 

 
___________________________________________________________________________ 
 
Release 3.9.1 – November, 2017 (Win7: 32-Bit)  
Release 4.0.1 – November, 2017 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Bug Fix Version, fixes EPC Profile Acquisition failures 
 
BUG FIXES 

1. XPS: EPC: Fix Comm Device errors occurring when Ion Gun Neut is selected for Depth Profile 
Acquisitions.  Setting Ion Gun Float State failures.  Also fix similar issue with X-Ray Auto Beam 
Park enabled, failing to set X-Ray mode. 

2. Intro: Add support for 42AUC03 model USB cameras for SPS. 
3. XPS: Fix the right-click context menu in the Lab Book.  Right-clicking the columns should bring up 

SmartSoft menu instead of OS menu.  Previously had to right-click on column headers. 
4. Hardware: Fix Photon Energy displayed in the Analyzer View.  Changing value would change 

value used in acquisition, but not display properly in view. 
5. XPS: Fix issue where Image Registration (IR) Active column was always displayed in Acquisition 

Setup Region Tables. 
6. System: Change maximum bake time from 100 hours to 200 hours. 
7. XPS: EPC: Fix LoadSetting on Map/Line Acq Setup tabs would cause Non-EPC parameters to 

appear. 
 
___________________________________________________________________________ 
 
Release 3.9.0 – October, 2017 (Win7: 32-Bit)  
Release 4.0.0 – October, 2017 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Windows 10 support, SXI Image Registration, Varian(Agilent) Ion Pump support, Element database 
editor, Bug Fixes 

 
NEW FEATURES 

UI 
41. SmartSoft-XPS Icon: New Icon. 
42. Configuration Manager: Exit dialog is now more intuitive with ‘Save’ options. 
43. Configuration Manager: Support both ‘DFx41BU02’ and ‘DFK41BU02’ USB SPS Camera models. 
44. Configuration Manager: Add Analyzer Control to UI. 

 
AutoTool 

 
Intro 



45. Ion Pump: Support Varian(Agilent) Ion Pumps.   
46. Tools: Bake: New Bake Control Views. 
47. Improve Bake Application Log and Bake Report. 
48. Tools: Chart Recorder:  Revamped Chart Recorder tool for plotting short-term history of 

designated parameters. 
49. Tools: System Log Setup:  Add right-click context menu to “System Log…” button for selecting 

system log viewer to use. 
50. GigE Intro Camera: Support two light controls for GigE Intro Camera configuration, SLI Lights and 

typical Intro Light Source. 
51. Turbo Speed Interlock: Support turbo speed interlock for Non-EPC systems (close valves). 
52. Removed ‘None’ option for platen overlay when creating platen. 
 
Sample 

 
SXI 

 
XPS 
53. Database: Element Database can now be edited through right-click context menu on periodic 

table elements. 
54. Profile: Updating data displays after each region 
 

Hardware 
55. GCIB: Display dialog when GCIB interlock is tripped to notify users. 
56. XRay: Properties: Scan Pattern: Add Cr Anode Skew and Rotation Corrections for multiple 

angles. 
57. XRay: Add ‘Clear Registers’ button to FXS Registers Diagnostics View.  Clear Registers on 

Reinitialize automatically. 
58. Ion Gun: Add application logging to Ion Gun Application Log. 
 

Misc. 
59. Vacuum Pressure Log:  A simple version of a vacuum pressure log is written to a file in the 

Settings/Log directory.  The interval of entries is in Vacuum Settings “Properties.phi” file. 
60. Anode Position Delta: Open up “Anode Position Delta (mm)” min/max range so that Stage 

Settings “Properties.phi” file can be altered to reduce this value if needed.  
 
 

BUG FIXES 
8. Sample: Platen Image: Fix display issues with Zalar Range circle and Stage Limits box. 
9. Sample: Position List: Fix parent SXI remaining unchecked if child point was made on an 

unchecked SXI. 
10. XPS: Profile Acq: Sputter Layer Table: Use lighter highlight color for read-only columns such as 

Sputter Depth to improve visibility. 
11. XPS: Profile Region Table: Fix problem where starting More Profile Acquisition, PE always 

changes to 6.5 PE and acquisition runs with this PE. 
12. Hardware: Analyzer: Narrow vs. Standard acceptance angle set in queue to manage switching 

properly between different acquisitions in queue. 
13. XPS: Periodic Table: Fix right-clicking on K or Ca to choose alternative regions. 
14. Intro: Intro Camera: Fix issue where single Intro Camera configured systems with GigE camera 

would require the camera to have "Device User ID" set to "Intro" to work.  Now it behaves like the 
Canon camera which by default doesn't look for device name with single camera, only with 
multiple cameras such as SS-VP Prep. 

15. Intro: Vacuum Diagnostics:  Fixed Turbo Speed in diagnostics being displayed as ‘N/A’. 
16. Hardware: HXPS GCIB: Fixed issue where changing GCIB mode fails with an interface 

marshalling error. 



17. XPS: Presputter, Peak to Noise, Narrow Acceptance Angle, Zalar Rotation Speed:  These 
parameters are set in UI through autotool tasks instead of behind-the-scenes. 

18. Hardware: Beam Parking: Maintain beam parking mode differently, which fixes bug of X-Ray 
mode changing from ‘Park’ to ‘On’ after and SXI file save, even though beam is still parked. 

19. Intro: Aux Chamber:  Fix problems with aborting Profile Acquisitions while transferring to/from 
Auxiliary Chamber. 

20. Sample: SXI Data File: Fixed problem where Pass Energy saved to data file header was 
incorrect. 

21. Intro: Intro Sample Transfer: Fixed problem when Intro Pressure > 2.7E-4 Pa and drag platen 
from Intro to Stage, transfer sequence fails by Turbo Pump read error.  

22. Intro: Valves:  Vacuum glyph was showing V9 on EPC systems, when Ar leak valve is V21. 
23. Intro: Vacuum Diagnostics:  Fix bug where MPC Voltage Readback was clamping negative 

values to zero. 
24. Intro: Bake Zone Temperatures: Fix bug where Bake Zone Temperatures were not updating. 
25. XPS: Acquisition Setup: Fix loading data file, not loading X-Ray Setting. 
26. SPS: Fix bug where system configured with SPS and a non-analog Intro Camera would get an 

error when introducing a sample when the Intro Photo was taken. 
 
KNOWN BUGS 

1.  
 
NOTES 
 
 
___________________________________________________________________________ 
 
Release 3.8.2 – June, 2017 
___________________________________________________________________________ 
 
OVERVIEW 

SmartSoft-XPS V3.8.2 Adds: EPC configuration support for 64-bit SmartSoft. 
 
___________________________________________________________________________ 
 
Release 3.8.1 – Januaury, 2017 
___________________________________________________________________________ 
 
BUG FIXES 
1. Depth Profile > More acquisitions would change all region pass energies to default or in most cases 

6.5 PE 
 
___________________________________________________________________________ 
 
Release 3.8.0 – December, 2016 
___________________________________________________________________________ 
 
OVERVIEW 

SmartSoft-XPS V3.8.0 Adds: USB SPS Camera Support, TFC Correction update, RBD Ammeter 
Support, Bug Fixes 

 
NEW FEATURES 

UI 

1.  
AutoTool 

2.  
System 



3. SPS:  Add support for USB SPS Camera. 
4. Bird’s Eye View:  Add support for Aux Intro Chamber with EMSL Transfer Probe. 
5. Allow resizing of large pressure display. 
6. Modified default bake timeouts for Vacuum Properties.phi file, which will allow greater success rate 

when pumping down chamber for bake (note: does not overwrite pre-existing values). 
Sample 

7.  
SXI 

8. Z-Align with SXI:  Right-click context menu shows “Z-Align …” option to access Z-Align Properties 
View. 

9. Contrast Enhancement: Right-click context menu shows “SXI Image Properties…” option to access 
Image tab of the SXI Image Properties View. 
XPS 

10. TFC Correction:  New TFC Correction function using variable number of data points from TFC curve. 

Hardware 
11. RBD Ammeter: RBD Ammeter is now supported. 
12. Sample Current: Sample Current readings now default the Bias Box Mode to “Target”. 
13. Ion Gun/E-Neut: If gun setting is selected in Acquisition Properties and is deleted from hardware tab, 

SmartSoft will block the action and show a warning dialog. 

Misc. 
14. Add “Zip Log Files …” utility under ‘System’ toolbar menu 

 
BUG FIXES 
1. Canon Camera > Attempt to fix software freezing issues related to auto focus overdrive 
2. Sample > SXI FOV combo box was displaying FOV larger than set maximum 
3. Sample > If ‘Auto Beam Parking’ is selected in Acquisition Properties, restore X-Ray to ‘Park’ mode 

after SXI Preview 
4. Sample > Stage max enterable zalar speed should be capped at 4 RPM instead of 5 RPM 
5. XPS > Fixed bug where AR acquisitions would fail when setting area dwell time 

 
 
KNOWN BUGS 
1. .  
 
NOTES 
 
 
___________________________________________________________________________ 
 
Release 3.7.0 - Oct 2016 

___________________________________________________________________________ 
 
OVERVIEW 

SmartSoft-VersaProbe V3.7.0 adds: GigE Intro Camera, 11-426 X-Ray Diagnostics Support, Bug 
Fixes 

 
NEW FEATURES 

UI 

1. Icon: New SmartSoft-XPS icon. 
AutoTool 

2.  
System 

3. Intro/Prep GigE Camera:  Implemented support for GigE camera, redesign the intro process to 
improve clipping and calibration procedure. Intro Camera and SPS support moved into System 
Session, no longer a Prep Session. 



Sample 

4. Position List: Set All now works for R and Tilt. 
SXI 

5.  
XPS 

6. Acq Setup: Default Pass Energy: Made this a setting from a property 

7. Acq Properties: Add option to validate stage position after stage position move, before acquisition 
starts 
Hardware 

8. X-Ray: Support Diagnostics for 11-426 X-Ray Control. 
 Misc. 

9. PhiLogFilesZipper:  Utility in bin directory “PhiLogFilesZipper.exe” is available for combining system 
and application logs, optionally settings, into a .zip file for emailing.  Future versions will have menu 
option to access in SmartSoft UI. 

 
BUG FIXES 
1. Hardware > Xray Diagnostics:  1 sec diagnostics continuous reads, if multiple reads are running or 

are left on for extended periods, seem to lock up UI. 
2. Hardware > USB Comm: When the software starts up with the communication device not opened, all 

the calls error out and clog the sys log and make the software unstable. Changes were made to the 
CoAcqHdwrCtrl and CoAnalyzerHdwrCtrl DLLs to not make the early calls go down to the hardware 

3. Hardware > Ion Gun: Ion gun Auto shutdown.  Switching auto shutdown parameter is ignored. 
4. Sample > SXI - Clear Image : When doing SXI live imaging with Slow scan, 'Clear Image' does not 

work. 
5. Sameple > Stage Properties - Tilt Offset: Tilt Offset entry field was not working. 
6. System > Platen Manager: Auto Directory: - Create Directory button: We check 'Use Auto Directory' 

and click 'Create Directory' button. But software does not create directory. 
7. System > Bake: - Error of ValidZalarRotate: In System Baking Task, when turning Stage Control 

power off, software shows error message for failure of ValidZalarRotate, and system baking does not 
start until closing the error message. 

8. System > Bake Stage Init: Staze initizlization after system bake always fails.  When executing 
'Sample: Initizalize Stage' in AutoTool menu, software cannot open the device of stage control. 

9. XPS > More Map: More Map does not work. Starting More Map shows unexpected error. It seems to 
fail to display map image. 

10. Sample > Queue Pre-Check:  Auto-Z fails by ‘GCIB is not Blank’ error 
11. XPS > Queue Pre-Check:  Set up a profile with Ar Ion Gun. Add to Queue. Change sputter mode to 

sputtering w/ C60. Run queue.  It will complain about C60 not in standby/blank mode. 
12. XPS > Queue Restore Position List: Remove the AutoTool Restore Position List task since it causes 

loss of any updated Z heights in position list due to Auto Z.   
13. XPS > Acq Setup Load File:  Loading from acquisition file is not loading region information. 
14. XPS > Region Sweeps Load From File:  When loading acquisition parameters from File, the range of 

sweeps/ratio/Peak to Noise becomes wide open and values in scientific notation. 
15. XPS > Map\Line Acq: Only at Map and Line region table, when right-clicking at first column of Sweep 

does not show Set All feature. 
KNOWN BUGS 

1.   
NOTES 
 
___________________________________________________________________________ 
 
Release 3.6.3 - March 2017 

___________________________________________________________________________ 
 
OVERVIEW 



SmartSoft-VersaProbe V3.6.3 further supports systems utilizing Matrox framegrabbers such as SPS 
station systems.  It also includes Bug Fixes for validating stage position during queue and removing 
the restore position list task in queue. 

 
NEW FEATURES 

XPS 

1. Acq Properties: Add option to validate stage position after stage position move, before acquisition 
starts 

 
BUG FIXES 
1. XPS > Queue Restore Position List: Remove the AutoTool Restore Position List task since it causes 

loss of any updated Z heights in position list due to Auto Z.   
2. Motors > Change axis error limits and resetting current faults for zalar. 

 
KNOWN BUGS 

1.   
NOTES 
 
___________________________________________________________________________ 
 
Release 3.6.2 - Aug 2016 

___________________________________________________________________________ 
 
OVERVIEW 

SmartSoft-VersaProbe V3.6.2 adds: Bug Fixing for SXI Preview feature 

 
NEW FEATURES 

XPS 

1. SXI Preview: SXI Preview was not using queue to set SXI X-Ray Setting or to start E-Neut. 

 
 
BUG FIXES 
3. XPS > SXI Preview: E-Neut after SXI Preview in Queued Acq fails to reach emission. 
4. XPS > SXI Preview: If Ion Gun Neut is set to Auto, Z-Align Ion Gun Neut is Continuous, Ion Gun is left 

On during SXI in queue. 
5. XPS > SXI Preview: If Ion Gun Neut is set to Auto, Acq Ion Gun Neut is Continuous, Z-Align Ion Gun 

Neut is Pulsed, Ion Gun is pulsed (timed Neut) for first position only, then left on continuously. 
6. XPS > SXI Preview: When SXI Preview with E-Neut is run, acquisition can sometimes freeze on last 

frame and never complete. 
7. XPS > SXI Preview:  Changing persistence for SXI was not affecting persistence for SXI Preview. 
8. XPS > SXI Preview:  SXI Preview would sometimes freeze when last SXI frame was missing data. 
 
KNOWN BUGS 

2.   
NOTES 
 
___________________________________________________________________________ 
 
Release 3.6.1 – January, 2016 
___________________________________________________________________________ 
 
OVERVIEW 

SmartSoft-XPS V3.6.1 Adds: Bug Fixing; In addition to V3.6.0 Bug Fixes 
 
NEW FEATURES 



UI 

2.  
AutoTool 

3.  
System 

4.  
Sample 

5. Platen Image: Add right-click context menu option to toggle stage cursor and FOV display On/Off. 

6. Intro Camera: Add new Canon camera SDK support to support newer cameras. 
SXI 

7.  
XPS 

8. Acquisition: Before starting acquisition, software checks the "WaterFlowOn" status in 11-425. If the 
status is Off, show warning message. 
Hardware 

9. C60: Read the user ranges from the controller instead of using hardcoded manufacturer numbers. 
The effect is we do better calculating in converting between DAC numbers and user values. Also 
updated the calibration offsets so the readbacks matched those from Ion Optica. 

10. E-gun:  Electron gun hysterisis causes large changes in beam diameter when switching between FXS 
settings, especially when transitioning from high-power to low-power.  Automatically reset the 
objective lens current when loading any setting. 

BUG FIXES 
9. Sample > Bake: Help stage initialization failures after system bake by clearing stage controller first. 
10. Sample > Platen Transfer: Fix issue of platen transfer timeout being too short. 
11. XPS > Ion Neutralization: Fix issue with Ion Neut emission current automatically changing during 

depth profiling with Ion Nuet enabled. 
12. Hardware > E-Neut: Extractor voltage range changed to 0-75V. 
13. System > Startup: Fixed bug where firmware version checking could report current firmware version 

as older than expected when actually newer. 
14. System > Vacuum: Fix issue   
 
KNOWN BUGS 
3.  XPS > Auto-Multiplex:  Default Pass Energy is used for all found and imported element regions. 
4. Hardware > Sample Current: Default bias box mode for sample current is ‘Off’, so ellipses button 

should be used to modify ‘Bias Box Mode’ through Ammeter view.  
 
NOTES 

1. As V3.6.0 was intended to be released before this version, note that V3.6.0 features and 
bug fixes below are also included in this release.      

 
___________________________________________________________________________ 
 
Release 3.6.0 – March, 2016 
___________________________________________________________________________ 
 
OVERVIEW 

SmartSoft-XPS V3.6.0  Adds: Quantes CQR; Bug Fixing  
 
NEW FEATURES 

UI 
1. Overview: Added new visual glyphs and controls for Quantes system configuration 

AutoTool 

2.  
System 

3. Intro Camera:  Improve Canon intro camera take picture reliability. 



Sample 
4. Platen Image:  Beam Diameter display glyph is added to toolbar. 
5. Platen Image:  Zalar range circle glyph is added to toolbar. 

SXI 
6. SXI: Support "Preview" feature.  Collect N number of frames for an SXI image. 

XPS 
7. PlatenManager:  Display warning to users when lab book size is over 200 positions. Could slow down 

performance. 
8. Acquisition Setup: Support variable scan area dwell time which is tied to time/step of acquisition. 

Hardware 
9. Cr Anode Motor:  Support new motor control. 
10. Analyzer: Support new analyzer control. 
BUG FIXES 
1. XPS > Profile Data: Area mode intensity calculations no longer showing negative intensities. 
2. XPS > Acq Setup: min and max region energy ranges no longer display values that are not able to be 

entered by user at endpoints. 
3. Sample > Position List:  Fix error that could occur when switching platens from a platen with no 

positions to a platen with a position list large enough to display scroll bar ( >14 positions). 
4. XPS > Acq Setup: When setting low BE energy to min allowed, acquisitions could fail with a invalid 

parameters error returned from the 20-390 Analyzer. Fixed. 
5. XPS > SXI:  Remove SXI histogram, which did not work well and was not currently valuable to users. 
6. XPS > Acq Setup: When loading data file into Map or Line Acq setup, "Time Per Pixel" or 

TimePerStep would not load from file.  Fixed. 
7. XPS > Acq Setup: When loading data file, region sweeps would load in scientific notation. Fixed. 
8. XPS > Depth Profile:  When setting up a More acquisition, we load region parameters from a data file.  

PE and Step Size would not get set correctly from the data file.  Fixed. 
9. XPS > Depth Profile:  Sputter Layer table read-only columns are difficult to read when highlighted due 

to color scheme. Fixed. 
10. System > Startup: Expected firmware version mismatch dialogs changed to warnings instead of 

errors.  
 
KNOWN BUGS 
1.  
 
NOTES 
1.  
       
___________________________________________________________________________ 
 

Release 3.5.4 - May, 2015 

___________________________________________________________________________ 
 
IMPORTANT: IF INSTALLING THIS VERSION OVER V2.1 OR OLDER - AFTER  

UNINSTALLING THE OLD VERSION, DELETE THE IDLE.PHI AND WARM.PHI SETTINGS FOR THE  

C60 ION GUN IN THE SETTING DIRECTORY AND RERUN THE CONFIGURATION MANAGER. 

 

NEW FEATURES IN THIS VERSION 

1. Updated FTDI drivers 

 

FIXED IN THIS VERSION 

1. Fixed some issues leading to Z-Align failures. 

2. Fixed bug where application logs would fail to write and cause acquistions to fail. 

3. Fixed issue where computer delays could cause data retreival from acq hardware 

    control to fail, causing acquisition failures. 



4. Fixed XPS Element Database having bad energy range bounds for N KLL region 

 

MINIMUM FIRMWARE VERSIONS 

Acq Hardware Control 38-101: V1.3.0 

Ion Gun Hardware Control 20-066: V1.15.1 

 

___________________________________________________________________________ 
 
Release 3.5.1 - June, 2014 

___________________________________________________________________________ 
 
IMPORTANT: IF INSTALLING THIS VERSION OVER V2.1 OR OLDER - AFTER  

UNINSTALLING THE OLD VERSION, DELETE THE IDLE.PHI AND WARM.PHI SETTINGS FOR THE  

C60 ION GUN IN THE SETTING DIRECTORY AND RERUN THE CONFIGURATION MANAGER. 

 

NEW FEATURES IN THIS VERSION 

1. Changed Ar Ion Gun emission current ramping routine for increased stability. 

   viewer in different colors. 

 

FIXED IN THIS VERSION 

1. Fix for XPS Depth Profile Acquisitions that fail with Saving Data busy error. 

2. Fixed bug where stopped Angle Resolve Profile would lose last angle data. 

 

___________________________________________________________________________ 
 
Release 3.5 - June, 2014 

___________________________________________________________________________ 
 
IMPORTANT: IF INSTALLING THIS VERSION OVER V2.1 OR OLDER - AFTER  

UNINSTALLING THE OLD VERSION, DELETE THE IDLE.PHI AND WARM.PHI SETTINGS FOR THE  

C60 ION GUN IN THE SETTING DIRECTORY AND RERUN THE CONFIGURATION MANAGER. 

 

KNOWN ISSUES 

1. With Embedded PC systems:  First SXI run after starting up SmartSoft may not work. 

   subsequent SXIs will work normally. 

2. SXIs are failing on Embedded PC systems due to firewall protection being enabled. 

   firewalls need to be disabled so that EPC can establish connection with SmartSoft 

   PC for sending SXI data. 

 

NEW FEATURES IN THIS VERSION 

1. Additional 15 seconds delay added to backfilling Intro after turning off Ion Gauge. 

2. Add ability to delete several positions by active or inactive status, or by viewable  

   positions in platen viewer. 

3. Add support for 777A GCIB pressure control. 

4. Setting Auto-Filename parameters and platen directory at a queued acq level is 

    now done by context menu in acquisition setup "Add Q" buttons. 

5. Settings combo boxes now store history of settings used and groups settings. 

6. Alignment pins for different alignment types are now displayed on platen image  

   viewer in different colors. 

 



FIXED IN THIS VERSION 

1. Fix issue where Platen Preview wasn't display platen image correctly (white box). 

2. Change some remaining micrometer symbols to "u" to fix display issues. 

3. Due to amount of 'Out of Tolerance' errors happening with E-Neut, E-Neut 

    will wait a little over 2 minutes before erroring out for tolerance to be reached. 

4. GCIB focus and objective percentages now limited to 75% to avoid problems. 

5. Retries added for reading valve status to avoid Depth Profile acq failures with 

    checking sputter shutter status with Quantums. 

 

___________________________________________________________________________ 
 
Release 3.4.1 - April, 2014 

___________________________________________________________________________ 
 
IMPORTANT: IF INSTALLING THIS VERSION OVER V2.1 OR OLDER - AFTER  

UNINSTALLING THE OLD VERSION, DELETE THE IDLE.PHI AND WARM.PHI SETTINGS FOR THE  

C60 ION GUN IN THE SETTING DIRECTORY AND RERUN THE CONFIGURATION MANAGER. 

 

KNOWN ISSUES 

1. With Embedded PC systems:  First SXI run after starting up SmartSoft may not work. 

   subsequent SXIs will work normally. 

2. SXIs are failing on Embedded PC systems due to firewall protection being enabled. 

   firewalls need to be disabled so that EPC can establish connection with SmartSoft 

   PC for sending SXI data. 

 

FIXED IN THIS VERSION 

1. Fix issue where EPC Ion Gun hardware control would not handle source tolerance  

    errors correctly. 

 

___________________________________________________________________________ 
 
Release 3.4 - Feb, 2014 

___________________________________________________________________________ 
 
IMPORTANT: IF INSTALLING THIS VERSION OVER V2.1 OR OLDER - AFTER  

UNINSTALLING THE OLD VERSION, DELETE THE IDLE.PHI AND WARM.PHI SETTINGS FOR THE  

C60 ION GUN IN THE SETTING DIRECTORY AND RERUN THE CONFIGURATION MANAGER. 

 

KNOWN ISSUES 

1. With Embedded PC systems:  First SXI run after starting up SmartSoft may not work. 

   subsequent SXIs will work normally. 

2. SXIs are failing on Embedded PC systems due to firewall protection being enabled. 

   firewalls need to be disabled so that EPC can establish connection with SmartSoft 

   PC for sending SXI data. 

 

NEW FEATURES IN THIS VERSION 

1. New deconvolution support.  Fewer parameters to set up. 

3. Add acq hardware control firmware version check.  

4. Add ability to keep Ion Neut on between positions during acquisitions. 

5. Added more 20-066 diagnostics. 



6. Add ability to set file numbering per acquisition basis. 

 

 

FIXED IN THIS VERSION 

1. Fix issue where Egun Neut emission saved to data file was always 0.0. 

 

___________________________________________________________________________ 
 
Release 3.3 - Apr, 2013 

___________________________________________________________________________ 
 
IMPORTANT: IF INSTALLING THIS VERSION OR NEWER OVER V2.1 OR OLDER - AFTER  

UNINSTALLING THE OLD VERSION, DELETE THE IDLE.PHI AND WARM.PHI SETTINGS FOR THE  

C60IONGUN IN THE SETTING DIRECTORY AND RERUN THE CONFIGURATION MANAGER. 

 

KNOWN ISSUES 

1. With Embedded PC systems:  First SXI run after starting up SmartSoft may not work. 

   subsequent SXIs will work normally. 

2. SXIs are failing on Embedded PC systems due to firewall protection being enabled. 

   firewalls need to be disabled so that EPC can establish connection with SmartSoft 

   PC for sending SXI data. 

 

NEW FEATURES IN THIS VERSION 

1. Auto Multiplex option through right-click on "Start" through Spectrum Acq tab. 

3. Displaying both intensity and eV at cursor position, using Energy Cursor.  

4. Added ability to delete completed queue jobs. 

5. Can now change color of Stage Marker and Field Of View box on platen view. 

6. Can change platen filename prefix and comment prefix on a per acq basis. 

7. Sputter tables can now be edited by number of cycles. 

8. Increased maximum bake time in hours to 500 hrs. 

 

FIXED IN THIS VERSION 

1. Fix issue where currently displayed X-Ray setting being written to acuisition file 

   instead of X-Ray setting being used while running queue. 

2. If Z-Align fails before acquisition, no longer continue with acquisition as user 

   may be sputtering at incorrect height. 

3. With Quantum systems only:  After closing sputter shutter, sometimes EPC 

   is still busy when attempting to do a following Argon leak or Diff Pump 

   operation. 

4. GCIB Filament timer:  Fix lifetime timer to read filament current and compare 

   this instead of setpoint value so lifetime is monitored correctly. 

5. Fixed some coloring issues where some tables had black lettering when blue 

   highlight present which was hard to read. 

6. Remove yello box around current platen name in status bar when current platen 

   isn't on the stage. 

7. Fix problem where position list scroll bar wasn't handled correctly when 

   tiling and untiling the view. 

8. X-Ray and Delay Before Sputter times are now added to estimated acq times. 

 



___________________________________________________________________________ 
 
Release 3.2 - Nov, 2012 

___________________________________________________________________________ 
 
IMPORTANT: IF INSTALLING THIS VERSION OR NEWER OVER V2.1 OR OLDER - AFTER  

UNINSTALLING THE OLD VERSION, DELETE THE IDLE.PHI AND WARM.PHI SETTINGS FOR THE  

C60IONGUN IN THE SETTING DIRECTORY AND RERUN THE CONFIGURATION MANAGER. 

 

KNOWN ISSUES 

1. With Embedded PC systems:  First SXI run after starting up SmartSoft may not work. 

   subsequent SXIs will work normally. 

2. SXIs are failing on Embedded PC systems due to firewall protection being enabled. 

   firewalls need to be disabled so that EPC can establish connection with SmartSoft 

   PC for sending SXI data. 

 

NEW FEATURES IN THIS VERSION 

1. Use current platen image FOV to generate points (new point generation method). 

3. Add X-Ray parking mode during sputtering cycles of depth profile.  

4. SmartSoft-XPS now sets the names of the gauges on the Varian control. 

 

FIXED IN THIS VERSION 

1. Remove Z-Align 'Low Count Error'. 

2. Acq Region: 224 PE/ 0.100 eV step size added for V3.0 channel maxing/deconvolution 

   would cause EPC systems to crash.  Removed this step size from EPC configurations. 

3. Increase C60 X & Y Steering by one significant figure (ie 0.00). 

4. Added retry mechanism for data acquisition to help with gauze lens errors. 

5. Fix problem of hitting 'Stop' followed by 'Abort' in acq status window not  

   working. 

6. Fix problem where target emission for sputter setting would get overwritten 

   with queued acuisitions with pulsed neut Z-Aligns as part of queue. 

7. Fix memory management issue that was causing various memory leaks. 

 

___________________________________________________________________________ 
 
Release 3.1 - Jul, 2012 

___________________________________________________________________________ 
 
IMPORTANT: IF INSTALLING THIS VERSION OR NEWER OVER V2.1 OR OLDER - AFTER  

UNINSTALLING THE OLD VERSION, DELETE THE IDLE.PHI AND WARM.PHI SETTINGS FOR THE  

C60IONGUN IN THE SETTING DIRECTORY AND RERUN THE CONFIGURATION MANAGER. 

 

KNOWN ISSUES 

1. With Embedded PC systems:  First SXI run after starting up SmartSoft may not work. 

   subsequent SXIs will work normally. 

2. SXIs are failing on Embedded PC systems due to firewall protection being enabled. 

   firewalls need to be disabled so that EPC can establish connection with SmartSoft 

   PC for sending SXI data.  

 

FIXED IN THIS VERSION 



1. Add support for 38-101 data acquisition. 

2. Fix error that appears if no serial port exists (COM1) on PC, even when no SPS is  

   configured. 

3. Swap Bake Intro and Bake Chamber interlock status readback displays (were reversed) 

4. Improve starting bake process to be more friendly to motor power being off. 

5. Make sure that Scan X and Y increment is set when restarting SXI clipping warning  

   occurs. 

6. Add delays in power loss recovery routine to give units ample time to shutdown  

   before being enabled again. 

7. Minimize excessive UI flashing when 'Close All' is performed on multiple data files. 

8. Make sure that profile acquisition stops when motor failure occurs. 

9. New enhanced Peak ID. 

10. Energy range in region table is now unique for each row depending on PE. 

11. Add 'Point' or 'Area' type to Multipak header information. 

12. Fix eV step values list not being populated on import in region tables. 

13. Fix File Load causing Egun Neut to turn On and max out filament current. 

14. Fix 10kVC60 Calibration Y in Properties being set to X value. 

15. Duplicate delay fix from 20kV to 10kV to wait a second after turning on high  

    Voltage so that it settles before loading setting occurs.  Else temperature  

    (first value loaded) fails to load. 

16. C60: When set X, Y Calibration values in Properties, restroke Scan Size in dll  

    to make changes take effect 

17. Fix method for clearing errors with Varian Gauge controller (reading revision). 

18. Fix problem with initializing 32-355 deflection for C60 on startup. 

 

___________________________________________________________________________ 
 
Release 3.0 - Oct, 2011 

___________________________________________________________________________ 
 
IMPORTANT: IF INSTALLING THIS VERSION OR NEWER OVER V2.1 OR OLDER - AFTER  

UNINSTALLING THE OLD VERSION, DELETE THE IDLE.PHI AND WARM.PHI SETTINGS FOR THE  

C60IONGUN IN THE SETTING DIRECTORY AND RERUN THE CONFIGURATION MANAGER. 

 

FIXED IN THIS VERSION 

1. Add support for C60 Auto Startup routine. 

2. Support single and multiple plot displays. 

3. Fix 'Set All' for area type so that area sizes are set correctly. 

4. Low/High Mag photo support changed to Standard and Angle Platen photo support. 

5. Queue summary now displays SXI or Map child position IDs instead of SXI or Map IDs. 

6. Platen directory now set for each queued acquisition to allow this to be changed 

   for each acquisition. 

7. Add new load from file feature that allows multiple hardware and acquisition 

   parameters to be loaded from a single load file action. 

8. Add Ability to save and download C60 calibration values. 

9. Use HP scan pattern when running HP EMS or MCD acquisitions. 

10. Stage status now displays auto Z-Align status and has right-click menu control. 

11. Add Max FOV in SXI properties that can be set to cut down on clipping error msgs. 

12. Sync up live and saved SXI image gamma. 



13. Add Tools -> System Colors menu option for adjusting system colors that may 

    be difficult to see. 

14. Add option for adding acquisition parameters to generated data file comments. 

15. Add logging of SmartSoft-XPS version number to system log. 

16. 20kVC60: Sputter vs. Blank mode command was backwards. Raster Calibration 

    values in properties window fixed. 

17. Fix Beam Power button getting stuck when anode move fails. 

18. Fix Color display issues with Win 7 and OS color scheme. 

 

___________________________________________________________________________ 
 
Release 2.3.1 - Apr, 2011 

___________________________________________________________________________ 
 
IMPORTANT: IF INSTALLING THIS VERSION OR NEWER OVER V2.1 OR OLDER - AFTER  

UNINSTALLING THE OLD VERSION, DELETE THE IDLE.PHI AND WARM.PHI SETTINGS FOR THE  

C60IONGUN IN THE SETTING DIRECTORY AND RERUN THE CONFIGURATION MANAGER. 

 

FIXED IN THIS VERSION 

1. Add Support for Main Chamber Turbo. 

2. On Startup, do not turn on Heat Exchanger if Up-to-Air. 

3. Requires MIL 9.0, supports new Morphis framegrabber and Win 7 

 

___________________________________________________________________________ 
 
Release 2.3.0 - Feb, 2011 

___________________________________________________________________________ 
 
IMPORTANT: IF INSTALLING THIS VERSION OR NEWER OVER V2.1 OR OLDER - AFTER  

UNINSTALLING THE OLD VERSION, DELETE THE IDLE.PHI AND WARM.PHI SETTINGS FOR THE  

C60IONGUN IN THE SETTING DIRECTORY AND RERUN THE CONFIGURATION MANAGER. 

 

FIXED IN THIS VERSION 

1. Add Support for GCIB. 

2. Add Support for 20kVC60. 

3. Power Loss Recovery now will always disable, then enable card rack power. 

4. 'Open' Queue through Acq Setup views will now display last user queue being 

   built, mimics 'Add' Queue for clarity. 

5. Default user queue renamed from 'Queue' to 'User-1' for clarity 

6. Fix bug where Timed Sputter would start while Zalar was moving to intial  

   Zalar position. 

 

___________________________________________________________________________ 
 
Release 2.2.0 - Oct, 2010 

___________________________________________________________________________ 
 
IMPORTANT: IF INSTALLING THIS VERSION OR NEWER OVER V2.1 OR OLDER - AFTER  

UNINSTALLING THE OLD VERSION, DELETE THE IDLE.PHI AND WARM.PHI SETTINGS FOR THE  

C60IONGUN IN THE SETTING DIRECTORY AND RERUN THE CONFIGURATION MANAGER. 



 

FIXED IN THIS VERSION 

1. Fixed C60 default IDLE and WARM settings so that they are read correctly. 

2. Platens can be created/loaded and moved between the Intro and Prep stations 

   while acquisitions are running (if second diff pump configured). 

3. Platen Preview added to allow editing of platen information and positions on 

   platens that are not the 'Current' platen (while acquisitions are running). 

4. Added support for Dry Scroll Pumps. 

 

___________________________________________________________________________ 
 
Release 2.1.1 - Aug, 2010 

___________________________________________________________________________ 
 
FIXED IN THIS VERSION 

1. Improve timed sputtering handling in AutoTool. 

2. Fix Angle Resolved Acq duplicate filename handling. 

3. Fix bug where Analysis regions could get clipped when loading region tables of same size. 

4. Fix saving of stage position when coming back from sputtering in Auxillary chamber. 

5. Support XGS-600 Gauge Controller and TC 400 and TC 110 Turbo Pumps. 

6. Allow closing acquisition results not being acquired. 

7. Add pixel size calculator for Map and Line acquisitions. 

8. Zalar rotation controlled by minutes per rotation instead of rotations per minute. 

9. Fully supporting EPC, Non-EPC, and Quantum systems. 

10. Supporting Dual Turbo option with controls and readbacks. 

11. Fix bug where resting SCA Multiplier between positions could cause extra background (EPC). 

 

___________________________________________________________________________ 
 
Release 2.0.6 - June, 2010 

___________________________________________________________________________ 
 
FIXED IN THIS VERSION 

1. Fixed bug where Argon Flow rate may not get set to Diff Pump On value when 

   Argon and Diff Pump are both in 'Auto' mode. 

 

___________________________________________________________________________ 
 
Release 2.0.5 - May, 2010 

___________________________________________________________________________ 
 
FIXED IN THIS VERSION 

1. Fixed bug where anode position was not being logged correctly in Z-Align Log. 

2. Fixed bug where extra background counts could be picked up while E-Gun Neut 

   was on during consecutive acquisitions. 

3. Fixed bug where system could lose track of an Angle Resolve Platen being on 

   the stage after the stage was initialized. 

 

___________________________________________________________________________ 
 



Release 2.0.3 - March, 2010 

___________________________________________________________________________ 
 
FIXED IN THIS VERSION 

1. Fixed bug where software hangs up when executin Queue task. 

2. Fixed bug where software losts anode position after stage initialization. 

3. Fixed bug where software does not recognize a stage error during stage initialization. 

4. Fixed bug where software executes acqusition with wrong numbers of Cycle. 

 

___________________________________________________________________________ 
 
Release 2.0.1 - Nov, 2009 

___________________________________________________________________________ 
 
FIXED IN THIS VERSION 

1. Fixed bug where reading Beam Power was not using proper delay time after turning 

   the X-Ray gun on and switching Bias Box mode. 

 

___________________________________________________________________________ 
 
Release 2.0.0 - Sept, 2009 

___________________________________________________________________________ 
 
FIXED IN THIS VERSION 

1. Fixed bug where stage was not initializing on startup of SmartSoft-XPS when system  

   user level of 'User' or 'SuperUser'. 

2. Fixed bug where Sample/SXI Image Size X and Y entry fields were not capped to  

   maximum SXI resolution size of 1400 um. 

3. Fixed bug where digital intro camera and SPS photos in Prep session were sometimes  

   sized incorrectly and scroll bars would appear when shouldn't have been needed. 

4. Fixed bug where 'Last Acq' Multipak button could open a currently running acquisition  

   file and then prevent this file from being updated by the running acquisition. 

5. Fixed bug where Ion Gauge Units could not be changed in Configuration Manager  

   when 'EPC' was selected in 'Embedded PC' combo box field. 

6. Fix errors occuring when Beam Power was run or X-Ray beam was parked after startup  

   of SS-XPS before running any other acquisition type that downloads a scan pattern. 

7. Fixed bug where 'More' acquisitions for No Sputter and Continuous profiles would  

   complain that 'More' was not allowed after 'More' button was hit, acquisition  

   was set up, then 'Profile' was selected. Fix dithers the 'More' button for No  

   Sputter and Continous profile Sputter Modes. 

8. Fixed errors occurring when other file types are loaded into XPS/Profile tab. 

9. Fixed bug where Pass Energies in Acquisition Properties/Region View was not displaying  

   the Pass Energies from SCALens.txt file that is used in Pass Energy selection fields. 

10.Improved Queue performance when adding many queue items to the list.  Improved  

   performance for all list (position list, data manager, …). 

11.Limit Ion Gun grid voltage minimum to 120 when emission is > 8mA. 

12.Fixed bug where spaces in region names would cause problems opening data files  

   in Multipak.  Replaces spaces with underscores when acquisition is started. 

13.Fixed calculation rounding error that would sometimes result in incorrect number  

   of steps being calculated, causing final data point to get zero data counts. 



14.Fixed bug where some repeated parameters in the main Ion Gun View and the Ion Gun 

   properties View were not updating each other when one set was changed. 

15.Fixed bug where C60 Depth Profile acquisitions were not displaying initial 

   remaining acquisition time estimates. 

16.Fixed bug where undepressing the 'Start' button from the Queue -> Auto Tool View 

   would make the currently running task unable to abort. 

17.Acquisition 'Delay (sec)' is used during every cycle of a Profile Acquisition if the 

   'X Ray Off During Sputter' option is selected. 

18.'X Ray Off During Sputter' no longer turns off the X Ray during preacquire cycles. 

19.'Delay After Sputter' is now called 'Delay Ion Gun (sec)' and is only applied before 

   the acquisition cycle if Ion Neutralization is selected. 

20.Fix bug where C60 Profile acquisitions could lose communication with the C60 Ion Gun 

   control. 

21.Fix bug where attempting to save an SXI image when no SXI acquisition had been run  

   since startup would result in default exception. Now gives user friendly message. 

22.Fix bug where potential loss of eucentric tilt positions used for eucentric tilt  

   calibration due to min and max limits of these fields being updated as current stage 

   positions were changed.  Removed ability to drive to eucentric tilt positions so  

   that this updating of min/max values isn't needed. 

23.Open up bake pressure upper limit from 5.0e-5 to 5.0e-4. 

24.Give 'Unknown' platens a max Z-height of 10mm so that they can be moved around easier 

   if needed. 

25.Save current platen setting when saving 'Previous' platen setting so that new positions 

   and files added to platen are saved in case of hard quit or crash of SmartSoft-XPS. 

26.Fix bug where 'Load File' from an acquisition setup view would incorrectly mark the  

   acquisition type as the type of file loaded (ie. loading a Line file in a Spectrum 

   setup view would try to run the Spectrum as a Line acquisition). 

 

 

NEW FEATURES IN THIS VERSION 

1. Added logging of current Stage X, Y, Tilt at beginning of Z-Align acquisitions  

   in Z-Align Log. 

2. Added Emission Current, Target Current, and Filament Current reading values to  

   X-Ray Application log when these readings are updated.  This replicates functionality  

   that was present in Compass software through the 'CurrLog'. 

3. Added ability to draw on SXI for use in system checkout. 

4. Added 0.2 eV Step Size option added for 26 Pass Energy. 

5. Added Z-Align Plot to Tools menu to complement Z-Align Log. 

6. Added ability to right click element in element table view to select specific  

   region transitions instead of always getting default transition from element database. 

7. Added Beam Size specific Anode Position control in X-Ray/Properties.  Controls  

   which position is used when Beam Size Acquisitions are run.  Does not have live  

   control over current anode position. 

8. Analyzer Settings have been removed in favor of having a table in Analyzer/Properties/Lens,  

   which holds specific Lens and Binding Energy values for SXI, Z-Align, and MCD  

   acquisitions. 

9. Added new <read> and <read continuous> button to diagnostics menus.  Supports  

   continuous reading of hardware. 

10.Max Target Emission of Ion Gun is now 25mA instead of 50mA. 



11.Added 15M Canon Intro Camera support. 

12.When Depth Profile Acquisitions are stopped in the middle of sputter layers, these 

   layers are now split and completed layers are read-only when doing 'More'. 

13.On Angle Profile Acquisition setup, the Angle Table now displays the sine of the 

   angle in addition to the angle in degrees and number of cycles. 

14."Cleaning Up ..." message dialog after stopping a Beam Size acquisition changed 

   to a more informative "Restoring Hardware Parameters ..." message dialog. 

15.Peak ID now displays all transitions with the 'Label' flag from the element 

   database instead of just the primary transition with 'Select' flag. 

16.Can now change 'Service' and 'Superuser' level passwords from within SmarSoft-XPS 

   in the 'User Level' menu. 

 

 

___________________________________________________________________________ 
 
Release 1.1.2 - July, 2009 

___________________________________________________________________________ 
 
FIXED IN THIS VERSION 

1. Changed the minimum limit of 'Atmospheric SetPoint' to support purging with another gas. 

2. Fixed the bug of IonGun floating in depthprofile sputtering. 

3. Fixed the bug that the Xray filament value is reached to filament limit when loading after  

 HP mode. 

 

___________________________________________________________________________ 
 
Release 1.1.1 - March, 2009 

___________________________________________________________________________ 
 
OVERVIEW 

  SmartSoft-XPS V1.1.1 completely replaces COMPASS (and the UNIX emulator) as the  

  system control software for the Quantera SXM instrument.  

  

NEW FEATURES IN THIS VERSION 

1. SmartSoft Look and Feel 

   a) Single window with predefined data views 

   b) Session tabs guide user through analysis 

   c) MS Windows based package 

2. New 12 MegaPixel Intro Camera Support 

   a) Enhanced intro photo quality 

   b) Supports digital zoom over whole platen 

3. Integrated Platen File Management 

   a) No restriction on number of platen files 

   b) All data files recorded and available using an on-line lab book 

4. Fast and Easy Platen Alignment 

   a) Uses proven SmartSoft-AES wafer navigation technology 

5. Interactive SXI Imaging 

   a) Point and click sample positioning 

   b) Point and click analysis area definition and repositioning 

6. Integrated Peak Identification 



   a) Real time peak identification during analysis 

   b) Peak identification results available for analysis region setup 

7. Real-Time System Status During Acquisitions 

   a) Descriptive status messages are displayed during each step of data  

      collection 

8. Data Recovery for Profile Acquisitions 

   a) Data stored after each cycle to facilitate file recovery if needed 

9. Enhanced Service Tools 

   a) Real time photo calibration 

   b) Interactive center-of-rotation and eucentric tilt calibration 

10. Password Protection for Critical System Parameters (Password needs to entered  

    just once) 

 

HELPFUL HINTS 

1. Entry fields must be 'terminated' either by selecting the <Enter> key or by  

   moving to another parameter field.  If the application is exited before the  

   value is terminated the change will not be saved.   

            

KNOWN ISSUES AND LIMITATIONS 

1. SmartSoft-XPS is designed to be run on the Windows/XP operation system only.  

   SmartSoft-XPS has not been tested on Windows/Vista or Windows/NT computers.   

 

2. SmartSoft-XPS does NOT support the following hardware: 200mm Stage, 11-085 Ion  

   Gun (non-float), 72-030(W) E-Gun Neutralizer 

 

3. For additional information on known issues, please see the following document:  

   C:\SMARTSoft-XPS\Bin\SmartSoft-XPS.ServiceBulletins.htm  


