
SmartSoft-VersaProbe Software Release Notes 
 
 
___________________________________________________________________________ 
 
Release 3.5.1 – August, 2025 (Win10\Win11: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Bug Fix release that also adds some improvements and new features. Reduce sample transfer time, 
Improve acquisition startup time.  

 
NEW FEATURES 

Sample 
1. Reduce Sample Transfer time. 

 

XPS 
2. Reduce Acquisition Start time. 

 
 
BUG FIXES 

Sample 
1. Position List: Fix bug where saving images to position list could be added at wrong level 

(being parent or child position), whether using sample folders in position list or not. 
2. Fix problem where if sample folders in position list is not enabled, acquired mosaic .sps 

image will display as platen overlay, but lose reference to old platen overlay image for 
switching back (zooming out or selecting other position). 

 
 

XPS 
3. Map\Line Acq: Fix problem with data saved to data file when acquiring channel max regions 

(region step sizes resulting in larger than native number of detector channels). Bug 
introduced in V3.5.0 release 

4. Depth Profile Acq: Fix queue validation failing, claiming no valid Profile regions, when valid 
regions defined. Was wrongly checking Spectrum acq regions during validation.  

5. Fix issue where Amp/Disc Threshold value was not getting reset correctly after cardrack 
reset. 

6. Fix issue where during last cycle of Pre-Sputter Acquisitions for Depth Profiling, 
Analyzer/Multiplier would be turned off after each region, also excitation source would cycle 
off for each region. 

 
Hardware 

7. Detector Channels: Fix bug with interpolated disabled channels not displayed correctly in 
SmartSoft (ok with data file and Multipak). 

8. UPS: At end of queue, don’t blindly turn the UPS to blank mode, if it is Off leave it Off. 
 
KNOWN BUGS 

1. AES Line Acquisitions do not support multiple line acquisitions on SEM position in the 
position list (poor support). Recommend queuing single SEM position list line acquisitions 
until this support is improved. 

2. AES point position acquisitions followed by XPS HP acquisitions can result in the X-Ray 
Watchdog not being satisfied with the HP scan area and blanking X-Ray emission.  Known 
workaround is to run a SEM acquisition after AES point mode acquisition, before XPS HP. 



3. Dynamic Correction Factors: Before running Dynamic Correction Factors, be sure to create a 
position list position to run at, drive there, and have that position active and selected.  This 
way Spectrum acquisitions are sure to run and pass position validation. 

4. USB Camera DFK42AUC03: Setting camera properties Hue, Saturation, Gamma does not 
work through SmartSoft when video format is BY8 (1280x960). 

 
NOTES 

1. Note that the ‘VersaLock’ Intro station configuration option has been removed in previous 
versions.  This configuration option did not cause any functional differences in SmartSoft.  
Should configure ‘Standard’ Intro for systems with ‘VersaLock’. 

 
 
___________________________________________________________________________ 
 
Release 3.5.0 – May, 2025 (Win10\Win11: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

UI Updates, Tuning Improvements, X-Ray Settings Names Updated, UPS Imrovements, LEIPS 
Improvements, Hot/Cold Improvements, Bug Fixes. 

 
NEW FEATURES 

Configuration 
1. Remove S3 configuration option. 

 
UI  

2. Menu Bar>Data>System Colors…: Add Chamber Camera Center Marker color control 
3. Menu Bar>Automation>Queue Editor: Add ‘Zoom to Task’ button that expands current job 

and highlights the current running task. 
4. Menu Bar>Automation>Queue Editor: Add settings name to Timed Sputter task summary. 
5. Menu Bar>Help: Add ‘Contact Us…’ support, brings up support information contained in 

‘Contact.txt’ file in root of SmartSoft directory. 
6. Menu Bar>Tools>Outgas Conditioning…: Updated the outgas preview for readability. 
7. Menu Bar>Tools>Acquisition Data Tuning…: Make improvements to process. 
8. Ribbon>Data Manager: Add Comment Control for easy access to editing file comments 
9. Fix some list font color issues. 
10. Improved saving setting feedback by temporarily displaying a green thumb up glyph and 

changing the caption to ‘Saved’ 
11. Header Bar: Replaced header bar gun hourglass indicators with animated wheel indicator. 
12. Expand Controls: Add expand arrow to show zoom and cursor mode controls to the left of 

Platen View and Image Views. 

 
System 

13. Settings: Moved ‘history’ sections above ‘favorites’ sections. 

 
Sample 

14. Chamber Camera: Fixed rogue windows popping up when starting chamber camera imaging 
for the first time after starting SmartSoft. 

15. Allow Sample Transfer to take Intro Photo while Queue is running. No longer require platen at 
intro to be current platen. 

16. Support Tall Tilt platen type. 
17. Hot/Cold: Able to read temperature from target station when control is Off. 
18. Hot/Cold: Multiple improvements to 20-311B Hot/Cold support. 
19. Hot/Cold: Update Hot/Cold temperature ranges for VersaProbe vs. Genesis. 
20. Hot/Cold: Add varying temperature polling speeds to speed up H/C stabilization time. 



 
Hardware 

21. Detector: Channels: Add control for disabled channels behavior with new Interpolate option 
for disabled detector channels. 

22. GCIB: Move warning about GCIB iso valve being closed to before queue run validation 
instead of before each individual acquisition. 

23. GCIB: Change default Filament Limit (A) from 0.0 to 4.0. 
24. Ion Gun: Add default neutralize setting “NEUTRALIZE_NEUT”. 
25. E-Neut: Add default neutralize setting”NEUTRALIZE”. 
26. Tuning: When looping through settings for tuning, skip DEFAULT, PREVIOUS, and INITIAL 

settings. 
27. Tuning: Allow for aborting tuning via tune button in the hardware views. 
28. Tuning: Do not attempt to build a tuning queue when showing tuning properties (‘…’ button). 
29. Tungsten E-Gun: Add precision to diagnostics readback of emission. 
30. UPS: Make UPS ignition gas regulation target pressure tolerance accessible in UI, change 

default from 100 Pa to 50 Pa (100 Pa was found to be too large). 
31. UPS: Change gas target pressure min default values to 50 Pa. 
32. UPS: Make sure gas pressure readback is within target pressure’s tolerance for 15 seconds 

before moving on as if pressure is within tolerance. 
33. UPS: After ignition is complete start gas regulation (PID), let gas regulation adjust the gas 

flow rate instead of stepping it to avoid arc failure. 
34. X-Ray: Update X-Ray Settings naming convention. Anode material ‘Al’/’Cr’ is placed at 

beginning of setting name to organize settings. 
35. X-Ray: Change valid ranges (min/max) of ‘Beam Diameter (um)’ and ‘Beam Power (W)’ to 

reasonable limits. 
36. X-Ray: Beam Size Output View: Added anode gain controls found in SXI setup view. 
37. X-Ray: Make Photon Energy read-only to prevent accidental changes. 

 
 
BUG FIXES 

Configuration 
 
UI  

1. Fix bug where SmartSoft can come up and not be visible when Top or Left values in 
Properties.phi file were outside of monitor’s bounds. 

2. Menu Bar>Tools>Chart Recorder…: Fixed Chart Recorder ‘Setup’ tab not displaying 
correctly. 

3. Show platen information with platen image when hovering over the platen thumbnail in the 
bird’s eye view and header bar. 

4. Fix popup properties views to limit their height size to available screen size. 
5. Queue: Fix validation of Drive to Position Name task to check position list settings being 

loaded by queue. 
6. Queue: Fix validation of acquisition load setting tasks, grabs a snapshot of the setting to be 

loaded for validation. 
7. Menu Bar>Tools>Chart Recorder…: Fix Chart Recorder not recording Hot/Cold temperature 

at Intro or Stage. 
8. Menu Bar>Tools>Chart Recorder…: Differentiate Al and Cr heater readbacks in Chart 

Recorder. 
9. Status Bar: In status bar on bottom of UI, display absolute max Z (stage limit) rather than 

platen type max Z. 

 
System 

10. Allow all user levels to overwrite PREVIOUS and DEAULT reserved settings for usability. 
11. Fix aborting pump intro logging “Not able to abort Pump Intro” in Vacuum Application log, 

when abort works. 



12. Reduce some system resource usage, to lower SmartSoft-VP handle usage. 
13. Queue: If queue is modified while queue is running, a warning icon pops up next to ‘Add to 

Queue’ acquisition setup buttons to let users know that queue should be validated again at 
some point. Queue Editor also shows warning icon on queue validation button. 

 
Sample 

14. Platen Image: Fixed an issue with zooming out of SPS image (also mosaic image) not 
displaying the platen reference image. 

15. Platen Image: Fixed platens without image overlay set displaying the last successfully loaded 
platen image. 

16. Stage>Comp Z: Fix dithering CompZ button not dithering during stage moves. 
17. Fix unable to move anode error during queue, when platen transfer is happening between 

Prep and Intro stations. 
18. Photo Preview: Fix number of frames progress indicator when running Photo Preview. 
19. Platen Transfer: Fix problem where Prep to Stage transfer (or elsewhere in chamber) would 

complete after taking Intro Photo and leave platen at Intro. 
20. Z-Align with SXI: Run SXI validation before running Z-Align w/ SXI. 
21. Z-Align: Fix Z-Align behavior with empty image position list positions, skip empty image 

positions as invalid. 
22.  

 
Options 

23. LEIPS: Fix single acquisition and Add to Queue to utilize queue correctly. 
24. LEIPS: Improve Bias settling times, was causing unnecessary overhead. 
25. LEIPS: Add ability to configure LEIPS delay times in Properties view. 
26. REELS: Fix single acquisition to have Platen To Stage queue task settings to make sure 

correct platen settings are loaded. 
27. REELS: The REELS acquisition setup, fix the Tungsten E-Gun settings controls showing up 

when system is not configured with Tungsten E-Gun. 

 
XPS 

28. Map: Fix region parameters not loading correctly when loading from a data file. 
29. Acquisition Properties: Refactor logic for shutting down or keeping I-Neut and E-Neut after 

acquisitions complete to try fix issues with I-Neut and E-Neut staying on after acquisitions. 
30. Data File Header: Fix some missing and incorrect file header information. Presputter Gun 

Type, Presputter Time, Presputter Setting, Defect Position Name, Defect Position Alignment. 
31. Raw Data File: Improve saving raw data file to make sure that it gets saved in the SmartSoft 

bin directory. 
32. SXI Image Registration: Fix SXI Image Registration failing if E-Neut mode of SXI reference 

image did not match XPS acquisition E-Neut mode. 
33. Z-Align: Fix problem where Z-Align acquisitions could cause a divide by zero failure if initial 

acquisitions acquired zero signal when calculating an average background signal. 
34.  

 
AES 

35. Auto Video: Change default resolution to 512 and time/point to 1.0.  Old defaults of 128 
resolution and time/point 5.0 would cause Auto Video to fail. 

36. AES Line Acq: Fix live spatial area multiple lines acquisition acquiring multiple lines of data, 
but only saving a single data file for the first line. 

37. FRR Lens Table: For 20-376A configuration, fixed the FRR SCA Lens table missing some 
entries. 

 
 
Hardware 

38. C60 Tuning: Fix some issues that caused C60 tuning to not work. 



39. Data Acq: Fix some memory leak issues with Data Acq Hardware Control, also add some 
memory cleanup to Acquisition Process Control. 

40. Detector: Fix missing channel number captions in Detector Channels Properties. 
41. E-Neut: Fix X/Y Steering slew functionality not working. 
42. Ion Gun: Changed default Ion Gun baud rate from 115200 to 9600. 
43. Ion Gun: Ion Gun: Fixed Ion Gun ramp log message units. 
44. UPS: If configuration does not have UV Shutter, turn source Off when acquisition is not using 

UPS.  Also manage turning UPS Off at end of queues if UPS was Off when starting the 
Queue. 

45. UPS: Fix blank mode showing up in Queue Set Source State Task when UPS shutter config 
set as Manual. 

46. UPS: Fix UPS sometimes ramping down beyond properties values (ramp down pressure 
infinitely). 

47. UPS: Wait for 10 seconds after gas pressure is turned on instead of before. 
48. UPS: When there is a UV Fault Interlock or Waterflow Interlock, turn Off UPS. 
49. X-Ray: Beam Size: Add Beam Size Gain Setting in X-Ray Properties in Beam Size controls. 
50. X-Ray: Add X-Ray Tuning support. 

 
KNOWN BUGS 

1. AES Line Acquisitions do not support multiple line acquisitions on SEM position in the 
position list (poor support). Recommend queuing single SEM position list line acquisitions 
until this support is improved. 

2. AES point position acquisitions followed by XPS HP acquisitions can result in the X-Ray 
Watchdog not being satisfied with the HP scan area and blanking X-Ray emission.  Known 
workaround is to run a SEM acquisition after AES point mode acquisition, before XPS HP. 

3. Dynamic Correction Factors: Before running Dynamic Correction Factors, be sure to create a 
position list position to run at, drive there, and have that position active and selected.  This 
way Spectrum acquisitions are sure to run and pass position validation. 

4. USB Camera DFK42AUC03: Setting camera properties Hue, Saturation, Gamma does not 
work through SmartSoft when video format is BY8 (1280x960). 

 
NOTES 

1. Note that the ‘VersaLock’ Intro station configuration option has been removed in previous 
versions.  This configuration option did not cause any functional differences in SmartSoft.  
Should configure ‘Standard’ Intro for systems with ‘VersaLock’. 

 
 
  



 
___________________________________________________________________________ 
 
Release 3.4.5 – February, 2025 (Win10\Win11: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Remove LEIPS Tilt Platen Restriction, LEIPS Queue Improvement, Bug Fixes. 
 
NEW FEATURES 

Options 
1. LEIPS Acquisition: Removed Tilt Platen restriction to run LEIPS acquisition. Show dialog that 

LEIPS should be run with sample perpendicular to electron beam 
2. LEIPS Acquisition: Single Acquisition runs through queue at current stage position only. 

Validation check added to make sure that platen at stage is current 
3. LEIPS Acquisition: Add to Queue adds Sample to Stage queue task with settings, along with Lab 

Book task with settings to queue along with the position list settings.  This makes LEIPS Add to 
Queue similar to other acquisitions 

 
 

BUG FIXES 

1. Configuration: Clean up issues software was having with running on 4700/4800 system 
configurations. 

2. Sample>Stage: Fix issues with CompZ not dithering during stage moves, also dither stage during 
Comp Z moves to prevent starting other stage moves while making compound move. 

3. XPS>Map Acq: Fix problem with loading data file into Map Setup would not load region table. 
4. Hardware>E-Neut/I-Neut: Change software logic to address reports of E-Neut and I-Neut staying 

On after acquisitions complete and they’re expected to change to Standby. 
 
 
KNOWN BUGS 

1. AES point position acquisitions followed by XPS HP acquisitions can result in the X-Ray 
Watchdog not being satisfied with the HP scan area and blanking X-Ray emission.  Known 
workaround is to run a SEM acquisition after AES point mode acquisition, before XPS HP. 

2. Dynamic Correction Factors: Before running Dynamic Correction Factors, be sure to create a 
position list position to run at, drive there, and have that position active and selected.  This way 
Spectrum acquisitions are sure to run and pass position validation. 

3. USB Camera DFK42AUC03: Setting camera properties Hue, Saturation, Gamma does not work 
through SmartSoft when video format is BY8 (1280x960). 

 
NOTES 

1. When changing E-Neut Filament type in Configuration Setup, if this is not a first time install 
(EGunNeut Settings present), E-Neut Work Function and Software Limit (A) will need to be 
manually updated for the new filament type in E-Neut Properties. 

2. With E-Neut changes making Gain, Time Per Step, and Ramp Rate Settings, need to set and 
resave E-Neut settings.  These parameters will be default values if Settings are not changed and 
resaved. 

3. Make sure to review parameters in ConfigurationSetup and select ‘Yes’ when asked to save, to 
make sure all configuration files are present after installation. 

  



 
 
___________________________________________________________________________ 
 
Release 3.4.4 – November, 2024 (Win10\Win11: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Genesis Improvements, YZ stage corrections, Multi-tab pinning, Bug Fixes. 
 
NEW FEATURES 

Configuration 
1. SPS and Chamber camera: Add serial number differentiation of cameras for when USB cameras 

are same model. 
2. Add Cold Probe configuration 

 
UI  
3. Menu Bar>Automation>Queue Editor: Add SEM Setting to right-side editor for editing AES 

acquisition setup queue parameters 
4. Menu Bar>Automation>Queue Editor: Add queue tasks for starting and stopping sample current 

reading 
5. Menu Bar>Tools>Acquisition Data Tuning…: Improve Acquisition Data Tuning 
6. Menu Bar>Tools>Bake and Sublimation…: Remove pre bake shutdown option. This is 

automatically added to the bake queue based on cardrack and motor power status 
7. Tab pinning: Add ability to pin tabs in multiple tab views, also add right-click context menu to pin 

or unpin all tabs 

 
System 

 

Sample 
8. Position List: Set default Tilt to 90 for Genesis systems and 45 for Versaprobe systems 
9. Position List: For 80 mm platen types on Genesis, SPS positions will have R set to 0 or 180, also 

expand this for created positions such as through point generation 
10. Stage>Settings: Add right-click context menu “Settings Editor…” feature 
11. Stage>Comp Z: For Genesis stage add Comp Z support, moves X/Y with Z moves to keep target 

sample in X-Ray focal point 
12. Stage>Properties: In Genesis configuration, removed Tilt and Rotation tabs 
13. Stage>Diagnostics: Removed -15V supply readback from stage diagnostics 
14. Stage>Initialize: Modify Genesis stage initialization sequence (clear touch at begin Z initialize, if Z 

initialize fails stop from moving to next step) 
 

XPS 
15. Spectral Data Viewer: When selecting Fingerprint cursor mode, display warning message about 

Fingerprint feature only being an AES data tool 
 

AES 
16. REELS Acquisition: When Analyzer is configured for 20-377, FAT mode energy range expanded 
 

Hardware 
17. Ion Gun>Startup: Remove load Neut setting from Ion Gun Startup 
18. Source>Properties…>Scan Pattern: Don’t display Tilt/Skew corrections if they’re not used with 

configuration 
19. Source>Properties…>Service: Added Beam Size Offsets that are similar to Beam Power Offsets. 

Overrides X-Ray Setting Offsets for Beam Size acquisitions. 
 



 
BUG FIXES 

1. Installation: Fix missing dll for Gage Check SPS along with Custom Actions support to register dll. 
2. UI: Shutdown: Fix Invalid window handle error dialog showing on SmartSoft shutdown. 
3. UI: Application Log: Restrict Application Log combo box from editing to prevent problems. 
4. Configuration>Ammeter: Restore Keithley Ammeter baud rate hard-coded to 9600. 
5. Menu Bar>File>Save System Parameters: Fix problem where logging in as ‘User’ user level 

would cause save system parameters frequency to be set to ‘Never Save’ for all user levels. 
6. Menu Bar>Automation>Queue Editor: Clean up queue tasks (settings tasks were always 

executing, settings tasks not opening editor view, tasks attached to wrong sessions, 
remove some tasks that should not appear in add to queue drop down). 

7. Menu Bar>Tools>Hardware Utilities>Hardware Manager: Fix SEE Data Sampling staying 
disabled if CardRack or Motor Power is disabled and SmartSoft is restarted. 

8. Menu Bar>Tools>Bake and Sublimation…: If any ‘After Bake’ options selected, include Card 
Rack power and Stage Init in generated bake queue. Also other small issues with display of bake 
parameters. 

9. Menu Bar>Tools>Outgas Conditioning…: Fix Analyzer Outgas to not detect arcs so easily and 
repeat the same steps many times. 

10. Menu Bar>Tools>Outgas Conditioning…: Fix Detector Conditioning to clear any SXI data before 
starting Detector Outgas to prevent SXI data affecting counts monitoring, also do not reset 
multiplier voltage on unexpected stop of detector outgas. 

11. Menu Bar>Tools>Open System Log…: Fix errors about ‘CVPInstrumentIOHdwrCtrl Cannot 
determine …” errors showing up in system logs depending on configuration. 

12. Menu Bar>Tools>Resource Monitor…: Fix defaults for Memory Usage, Handles Usage, and 
Thread Usage, to 99999.0. 

13. System>Chamber Camera: Fix Error message displayed when chamber camera is unable to 
initialize to make it more userful. 

14. Sample>Platen Navigation: Fix issue where on Startup of SmartSoft stage limits would be set for 
incorrect platen type. 

15. Sample>Platen Navigation: Change wording of Auto Alignment initial prompt. Timing marks do 
not need to be used, these are optional. 

16. Sample>Stage: For Hot/Cold stage, fix H/C Stage Start queue task not waiting for temperature to 
reach target, remove confirmation prompt, fix File Group ID error dialog. 

17. Sample>Stage: Fix problem with Genesis stage where zalar validation would fail even though 
defined position was within valid rotation limits for stage. 

18. XPS>Acquisition Setup: Fixed being able to change range in region table for unscanned 
acquisitions when range should be static. 

19. XPS>Mosaic: Fix Stitch Mosaic task failing to launch utility app for SmartMosaic. 
20. XPS>Mosaic: Fix ‘Update Z, R, T’ button swapping R and T values. 
21. AES>REELS Acquisition: Fix problem with REELS acquisitions when configured with AES option 

(not Tungsten E-Gun).  REELS acquisitions were not rastering and always scanning single 
centered point area. 

22. Hardware>Ion Gun: Don’t auto update Ion Gun Settings files when Settings change. 
23. Hardware>Ion Gun: Fix minimum Auto Shutdown Delay to be 0.1 so cannot be set to zero. 
24. Hardware>UPS: Fix minimum Auto Shutdown Delay to be 0.1 so cannot be set to zero. 
25. Hardware>UPS: Fix some Gas Flow Rate issues (ranges, gas type flow rate > ignition flow rate) 

26. Menu Bar>Tools>Outgas Conditioning…: Fix issues with REELS tungsten Egun outgas 
 
 
 

 
 
 
KNOWN BUGS 



1. AES point position acquisitions followed by XPS HP acquisitions can result in the X-Ray 
Watchdog not being satisfied with the HP scan area and blanking X-Ray emission.  Known 
workaround is to run a SEM acquisition after AES point mode acquisition, before XPS HP. 

2. Dynamic Correction Factors: Before running Dynamic Correction Factors, be sure to create a 
position list position to run at, drive there, and have that position active and selected.  This way 
Spectrum acquisitions are sure to run and pass position validation. 

3. USB Camera DFK42AUC03: Setting camera properties Hue, Saturation, Gamma does not work 
through SmartSoft when video format is BY8 (1280x960). 

 
NOTES 

1. When changing E-Neut Filament type in Configuration Setup, if this is not a first time install 
(EGunNeut Settings present), E-Neut Work Function and Software Limit (A) will need to be 
manually updated for the new filament type in E-Neut Properties. 

2. With E-Neut changes making Gain, Time Per Step, and Ramp Rate Settings, need to set and 
resave E-Neut settings.  These parameters will be default values if Settings are not changed and 
resaved. 

3. Make sure to review parameters in ConfigurationSetup and select ‘Yes’ when asked to save, to 
make sure all configuration files are present after installation. 

 
  



 
___________________________________________________________________________ 
 
Release 3.4.3 – June, 2024 (Win10\Win11: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Genesis Improvements, Clear Queue, Bug Fixes. 
 
NEW FEATURES 

Configuration 
1. Change default System Type to ‘None’ to force first installs to select a system type causing other 

parameters to get set to proper defaults 
2. Support more devices baud rates in ConfigManager Properties.phi 

 
UI  
3. Menu Bar>Tools>Outgas Conditioning…: Improve Analyzer Outgas 
4. Menu Bar>Tools>Acquisition Data Tuning…: Improve Acquisition Data Tuning 
5. Menu Bar>Tools>Hardware Utilities>Hardware Manager: Change MOD970 UV Shutter, AR 

Shutter, and Motor Power Voltage parameters to service level 
6. Header Bar: Shorten “AES LaB6” to “AES” 
7. Queue: Improve ‘Clear Queue’ functionality to be more intuitive interacting with Queue-1 setting 
8. Queue: Add validation of Settings being loaded by queue Load Settings tasks 
9. Ribbon/Dashboard>Queue: Display Queue Setting loaded in Queue 
10. Dialog Audible ‘Beeps’: Restore audible notifications to dialogs such as queue task prompts so 

that audible notifications occur during processes such as sample transfers 
 

System 
11. Startup/Shutdown: Retract AR Shutter on startup and shutdown if software controlled 
12. Vacuum: Add dialog prompt before launching service level vacuum tasks 

 

Sample 
13. Stage>Hot Cold Stage> Properties…: Add “Max Heater Current (A)” control for 20-311B 

controllers 
14. Stage>Properties…: Add Z-Height Correction control which enables a Z correction to Y 

movements during SXI point and click movements 
15. Sample Manager: Add 80 mm Transfer platen type for Genesis configurations 
16. Position List>Position: Add current positions and support driving stage using U, V, Z, R, T 
17. Position List>Alignment: There are now 8 renamable sets of alignment pins to use. Numbered 

prefix has changed from a dash to an underscore. Will be backwards compatible with dashes, 
and will change to underscores when renamed 

 

XPS 
18. Mosaic: Add check for SmartMosaic path at start of Mosaic queue 
 

AES 
19. Acq Setup: Improve error reporting if selected SEM Setting was deleted and/or missing 
20. SEM: Clean up SEM errors on startup 
 

Hardware 
21. Update the communication support for serial and ethernet hardware devices to make them more 

robust 
22. GCIB: Add validation for GCIB Iso valve 
 
 



BUG FIXES 
1. Menu Bar>Tools>Hardware Utilities>Hardware Manager: When card rack enable executed on 

non 20-377 analyzer configurations, do not re-enable SEE logging for SCA Analyzer to prevent 
data shifts that could occur 

2. UI: Improve Z ordering of windows to fix issues caused by hidden prompt dialogs locking up the 
UI 

3. SEE: Add missing sample current readbacks to SEE data 
4. Header Bar: Fix flashing occurring at startup 
5. System>Vacuum: Fix some vacuum tasks executing “Backfill Intro” instead of their own tasks 

starting in V3.4.2. “CloseDiffVlv” and “TransferVessel” vacuum tasks 

6. System>Intro: Do not return stage to clear position and square platen on stage if platen transfer 
destination is not Stage 

7. System>Intro>Application Log (Platen): Fix Platen application log being empty 
8. Sample>Sample Manager: Fix problem with 80 mm platen size being limited to 25 mm (Genesis) 
9. Sample>Stage>Properties…>Rotation: On Versaprobe stages reverse directions of center of 

rotation offsets 
10. Sample>Stage>Diagnostics: Fix Park C Platen Status not showing up as Read-Only 
11. Sample>Stage>Diagnostics>Stage Exercise: Fix Stage exercising failing during transfer platen 

(Genesis) 
12. XPS>Data Acquisitions: Fix Invalid Parameter error when attempting to run more than single 

More Acquisition  
13. Hardware>GCIB: Fix problem that after card rack reset GCIB is not setting raster size and offset 

until SmartSoft is restarted 
14. Hardware>Tungsten E-Gun: Add software support to handle firmware returning unexpected 

values for reading filament on time 
15. Hardware>Ion Gun: Fix issue where I-Neut settings were getting set to zero emission current 

 
 
KNOWN BUGS 

1. USB Camera DFK42AUC03: Setting camera properties Hue, Saturation, Gamma does not work 
through SmartSoft when video format is BY8 (1280x960). 

 
NOTES 

1. When changing E-Neut Filament type in Configuration Setup, if this is not a first time install 
(EGunNeut Settings present), E-Neut Work Function and Software Limit (A) will need to be 
manually updated for the new filament type in E-Neut Properties. 

2. With E-Neut changes making Gain, Time Per Step, and Ramp Rate Settings, need to set and 
resave E-Neut settings.  These parameters will be default values if Settings are not changed and 
resaved. 

3. Make sure to review parameters in ConfigurationSetup and select ‘Yes’ when asked to save, to 
make sure all configuration files are present after installation. 

 
___________________________________________________________________________ 
 
Release 3.4.2 – April, 2024 (Win10\Win11: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Single shared Intro TMP support, Bug Fixes. 
 
NEW FEATURES 

Configuration 
1. Add support for Single and Dual TMP intro pumping 

 
UI  



2. Enable maximize button for sizable views throughout the UI 
3. Status Line: Make Arm Ext and Arm Rot position changes more apparent (also stage application 

log) 
 

System 
4. System>Chamber Camera: Disable chamber light controls for VersaProbe configuration 
5. System>Vacuum: For vacuum operations involving Genesis systems and single shared intro 

TMP, turn off Ion Gun and UPS before Intro vacuum operations 
 

Sample 
6. Sample>Z-Align: Improvements: Start/Stop button to plot and log views, Refresh button to log, 

Copy/Print functionality 
 

BUG FIXES 
 

1. System: Fix issue where even if user had done a ‘Save All’ or had periodic save on, a SmartSoft 
crash and restart would still appear to lose some settings such as position list 

2. Sample>Stage: Fix closing the initialize stage dialog using ‘X’ button, will act as if selecting ‘No’ 
3. XPS>Data Display: Fix spectral data viewer not updating when starting Profile Acq when window 

size is small 
4. Hardware>Ion Gun: Fix “Neut Emission” in data file headers always recording zero emission 
5. Hardware>E-Neut: Fix 2nd E-Neut not switching emission control mode correctly 
6. Hardware>UPS: Fix support of Omicron manual UPS configuration not able to run acquisitions 

 
 
KNOWN BUGS 

1. USB Camera DFK42AUC03: Setting camera properties Hue, Saturation, Gamma does not work 
through SmartSoft when video format is BY8 (1280x960). 

 
NOTES 

1. When changing E-Neut Filament type in Configuration Setup, if this is not a first time install 
(EGunNeut Settings present), E-Neut Work Function and Software Limit (A) will need to be 
manually updated for the new filament type in E-Neut Properties. 

2. With E-Neut changes making Gain, Time Per Step, and Ramp Rate Settings, need to set and 
resave E-Neut settings.  These parameters will be default values if Settings are not changed and 
resaved. 

3. Make sure to run ConfigurationSetup to make sure all configuration files are present for new 
Dynamic Correction Factors support. 

 
  



 
___________________________________________________________________________ 
 
Release 3.4.1 – March, 2024 (Win10\Win11: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Save Alignment Pinning (And add 4th set), Mosaic ZRT, REELS Queue Support, 80 mm Handling, 
Bug Fixes. 

 
NEW FEATURES 

UI  
1. Main Menu>View: Add Reset Layout menu option 
2. Header Bar: Add support for GCIB and UPS busy status (hourglass) 
3. Header Bar: Restore Stop support for Sample Handling, with warning confirmation 
4. Queue: Show confirmation dialog when running STARTUP or SHUTDOWN queues 

 
 

System 
5. System>Intro: For Genesis, add Slow Pump Intro context menu in Intro station 
6. System>Aux Intro Photo: Add support to take intro photo from Aux station 
7. System>Sample Extract: With VersaProbe configuration with Hot/Cold Stage, Rotation Limit 

Switch, Pneumatic Cold Probe, check Intro Rod Inserted sensor status to make sure cold probe is 
retracted before sample extraction 

 
 

Sample 
8. Sample>Platen Image View: Show rotation limits box instead of zalar range circle for 40 mm 

platen types with Genesis configuration 
9. Sample>Sample Manager>Platen Type: Add ‘40 mm Transfer’ type for 40 mm Transfer Vessel 
10. Sample>Position List>Alignment: Add 4th set of Alignment Pins 
11. Sample>Position List: With 80 mm platen, set R based on U V value 

 

XPS 
12. XPS>Data Viewer>Map: Add copy button back to toolbar for copying images to the clipboard with 

spatial area definitions 
13. XPS>Profile>Angle Profile: Update Tilt range in Angle Table to reflect range of tilt platens with 

Genesis systems 
14. XPS>Mosaic: Add support for saving Z R T position with Mosaic areas 
15. XPS>Mosaic: Add application log for Mosaic 
16. XPS>Acq Setup>Periodic Table: Add Vb1, Vb2, WF1 custom UPS regions 

 

AES 
17. AES>Data Viewer>Map: Add copy button back to toolbar for copying images to the clipboard with 

spatial area definitions 
18. AES>Profile Data: Remove ‘Show All’ spectra option to match XPS options, only show latest 
 

Options 
19. Options>REELS: Added Open Queue, Add to Queue, and Clear Queue support to REELs acq 

setup view 

 
Hardware 
20. Hardware>Analyzer>Diagnostics: Add reinitialize button in analyzer diagnostics for the 

ethernet/usb controller 
21. Hardware>Analyzer: Various updates to Analyzer Outgas parameters 



22. Hardware>E-Neut: Increase max wait time for tolerance to 600 seconds from 120 seconds 
23. Hardware>GCIB: Prompt user to open iso valve, if closed, when switching gun to on 
24. Hardware>UPS: Add He gas pressure regulation before UV Ignition 
25. Hardware>X-Ray>Properties>Scan Pattern: Add Tilt Corrections (Stretch, Shear) to replace 

Skew Corrections  
26. Hardware>X-Ray>Diagnostics: Add readings for HP Deflection Watchdog values (watchdog 

mode, watchdog expired, egun disabled) to diagnostics 
 

 
BUG FIXES 
 

1. System>Sample Transfer: Check for arm extension before closing Intro Valve V1 
2. System>Sample Transfer: Fixed ‘Outside Request Refused’ vacuum error when transfer from 

Stage to Intro 
3. Sample>Platen Image View: Fix FOV doghouse management with Genesis navigation 
4. Sample>Position List>Point Generation: Keep point generated R values within range of stage 

travel for configured stage 
5. Sample>Stage>Comp R: Fix CompR button loses communication with stage control, problem 

with 80mm and tilt platens (Genesis) 
6. Sample>Stage>Zalar: Fix attempting to run zalar outside rotation limits causing stage control 

lockup and needing SS restart 
7. Sample>Stage: Genesis with 80 mm platen, move XY to zero before rotating 
8. XPS>Queue: Fix AUTO PIN setting being editable when it should be a reserved setting 
9. XPS>Queue: Check UPS On during queue validation, don’t block queue with warning dialog 
10. XPS>Acq Setup: Fix load of Cr data file capping region table range values to 3200 eV 
11. XPS>Z-Align in Queue: Skip to next position in position list if Z-Align fails during queue 
12. XPS>Z-Align: Display notification if HP Z-Align fails due to no HP X-Ray Setting set for Z-Align 
13. XPS/AES>Data Files: Clean up plot and lab book, but don’t delete intermediate data files on 

acquisition error 
14. AES>Profile: Fix Ole error when removing regions from AES Profile More acquisition setup 
15. AES>Profile: Fix GCIB setting in sputter table changing to PREVIOUS setting when acq runs 
16. AES>SEM: Add back Auto Video dialog to offer user choice of Retry or Stop on failure 
17. Options>LEIPS: Keep intermediate data files on LEIPS error, also don’t pause queue 
18. Hardware>Analyzer>Properties>Retard: Allow negative values to be entered into UPS Acquired 

Peak 2 
19. Hardware>E-Neut: Improve handling of E-Neut Out of Tolerance errors, based on Source 

Tolerance Required enabled 
20. Hardware>UPS: Fix UV shutter handling when configured with pneumatic UV shutter 
21. Hardware>X-Ray: Fix Beam Park Scan Pattern using skew corrections 
22. Hardware>X-Ray: Fix mode changes in UI not updating during X-Ray Reinitialize 
23. Hardware>Tuning: When tuning reserved settings, skip ‘Initial’, ‘Zero’, ‘Default’, and ‘Previous’ 

settings 
 

 
KNOWN BUGS 

1. USB Camera DFK42AUC03: Setting camera properties Hue, Saturation, Gamma does not work 
through SmartSoft when video format is BY8 (1280x960). 

 
NOTES 

1. When changing E-Neut Filament type in Configuration Setup, if this is not a first time install 
(EGunNeut Settings present), E-Neut Work Function and Software Limit (A) will need to be 
manually updated for the new filament type in E-Neut Properties. 

2. With E-Neut changes making Gain, Time Per Step, and Ramp Rate Settings, need to set and 
resave E-Neut settings.  These parameters will be default values if Settings are not changed and 
resaved. 



3. Make sure to run ConfigurationSetup to make sure all configuration files are present for new 
Dynamic Correction Factors support. 

 
  



 
___________________________________________________________________________ 
 
Release 3.4.0 – December, 2023 (Win10\Win11: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Genesis, Easy UI Navigator, Header Bar, Intro Photo Pinning Improvement, Outgas, Auto Tuning, 
Weekly Settings Backup, E-Neut Filaments, Bake Control, Startup/Shutdown Process, LEIPS 
Improvement, UPS Improvement, GCIB Cluster Size, RSF Based Sweeps, HXPS Prescan, Bug 
Fixes. 

 
NEW FEATURES 

Configuration 
1. Add Genesis and Genesis w/ AES system types 
2. Add S3 Option 
3. Add Dual Source Ion Gun and GCIB 
4. Add FXS Shutter 
5. Add AR Shutter 
6. Add UPS UV Shutter 
7. Add SPS Support 
8. Add X-Ray Crystal Heaters Support 
9. Add Dual E-Neut support for LEIPS and filament types 
10. Add GCIB Quad Steering 
11. Add Sample Parking 
12. Add 20-377 Analyzer 
13. Support 20-376A on VP II systems 
14. Support Bias Box 80A vs 80B 
15. Ask user and reset default COM port numbers if system type changed 

 
Utilities 
1. CommChecker: Rework CommChecker in SS bin directory to fix functionality 
2. SS Installation sets up weekly backups of SS Settings in Task Scheduler, backs up settings to 

‘SettingsBackup’ folder 
 

UI  
1. Simple UI Navigator: Add Simple UI Navigator 
2. Header Bar: Support system information, status, control through new Header Bar 
3. Status Bar: Information reduced with addition of Header Bar 
4. Ribbon/Dashboard>Sputter Tool: Add Sputter Setting 
5. Multiple UI changes supported for Genesis systems (Bird’s Eye View etc…) 
6. Support more configurable UI experience (pin tabs, SXI vertical slider) 
7. Settings supports marking/unmarking Favorites 
8. Gun Status colors updated (On=Green, Blank/Standby=Yellow, Off=White) 
9. Menu Bar>Tools>Hardware Utilities>Test Hardware…: Add support for Mod 970 controls when 

configured 
10. Menu Bar>Tools>Acquisition Data Tuning…: Add new support 
11. Menu Bar>Tools>Outgas Conditioning…: Add new support 
12. Application Log refactored, error handling support 
13. Diagnostics: Allow basic User level to access Daignostics views, but not able to access controls 

that are service only related 
 
 

System 
14. System>Vacuum: New SmartPumping support for Genesis systems 



15. System>Chamber Camera>Chamber Camera Image: Add chamber camera light and dimming 
control 

 
 

Sample 
16. Sample>Sample Manager: Add new platen types supported for Genesis systems 
17. Sample>Platen Image View: Implement auto alignment pinning routine to simplify process 
18. Sample>Stage: Support new Stage for Genesis systems (See Stage Properties) 
19. Sample>Stage>Diagnostics: Add support to disable motors after move 
20. Sample>Stage>Diagnostics: Update Stage Exercise routine (more like SS-XPS routine) 
21. Sample>Z-Align: Scan area size used by Imaging Z-Aligns is now defined here 
22. Sample>Z-Align: Remove AES Z-Align option for Genesis systems 
23. Sample>Sample Manager>Lab Book>Properties…>Directory: Restore Auto Directory feature 

 

XPS 
24. XPS>Acq Setup: Add RSF button to set region sweeps based on region RSF values 
25. XPS>Acq Setup>Region: Add HXPS Prescan option, which reduces noise in HXPS data when 

scanning large eV ranges 
26. XPS>Acq Setup>Periodic Table: Update Periodic Table (remove H, He, configurable 

behaviors…) 
27. XPS>Refresh: Add mode to display counts with background subtraction, FWHM display 
28. XPS>XPS Setup…: Move narrow acceptance to Acq Setup for consistency 
29. XPS>XPS Setup…: Disable Acceptance Angle controls if configuration does not support 
30. XPS>SXI: Add Grab cursor to SXI Imaging, now the default cursor mode 
31. XPS>SXI: Add Show/Hide support for cursor toolbar 
32. XPS>Spectrum: Save data after each cycle 

 

AES 
33. AES>Acq Setup>Periodic Table: Update Periodic Table (remove H, He, configurable 

behaviors…) 
34. AES>Spectrum: Save data after each cycle 
 

Options 
35. LEIPS: Queue support 
36. LEIPS: Save out data after each cycle 

 
Hardware 
37. Hardware>Analyzer: Add support for Fine Focus and Rotator for 20-377 Analyzer 
38. Hardware>Tuning: Add tuning support for E-Neut, Ion Gun, GCIB, C60 
39. Hardware>Dual Source Ion Gun: Support DSIG for Genesis systems 
40. Hardware>E-Neut: Support different filament types  
41. Hardware>GCIB: Support GCB Nozzle Heater 
42. Hardware>GCIB: Support GCIB Quad Steering 
43. Hardware>GCIB: Add GCIB Cluster Size Measurement button 
44. Hardware>GCIB: Add emission current readback to main view like other guns 
45. Hardware>UPS: Support regulating target pressure using gas regulation % 
46. Hardware>UPS: Support automation of UV shutter 
47. Hardware>X-Ray: Beam Size and Beam Power refactored, support continuous beam size and 

beam power for tuning 
48. Hardware>X-Ray: Beam Power now has unique scan X/Y offsets used instead of X-Ray settings 

X/Y offsets during Beam Power operations 
49. Hardware>X-Ray>Diagnostics: Add support for 11-426 DENKA LaB6 filament 
50. Hardware>C60: Remove old C60 Auto Startup after new Outgas support 

 
 



BUG FIXES 
 

24. System>Vacuum: Fix Pumpdown Intro finishing early 
25. System>Intro Photo: Dither out Take Intro Photo when no Intro Camera configured 
26. System>Intro Photo: Fix issue where GigE Camera fails to take intro photo due to trying to set 

light status 
27. Sample>Stage>Diagnostics: Fix Set Motor Position not working 
28. Sample>Position List>Point Generation: Fix support for stages with rotation range -180.0 – 180.0 
29. XPS>Mosaic: Multiple bug fixes 
30. XPS>Line/Map: Fix starting acquisitions not starting, error about HP setting even though selected 

X-Ray setting not HP 
31. XPS>Test Acquire/Refresh: Fix crashing, Fix restart, Fix button staying pressed after acquisition 

fails 
32. XPS>SXI>SXI Image: Fix clicking on gray area of SXI Image Viewer enabling positions in 

position list, related to SXI Images disabled in position list 
33. XPS/AES Acquisitions: Shorten timeouts for abort acquisitions which was 5 mins to 1 min so 

users don’t think SS is locked up 
34. AES>Acq Setup: Fix how Acquire/Start button status is updated, sometimes buttons would still be 

pressed after errors 
35. Hardware: Notify users of USB disconnect events of PHI devices 
36. Hardware>Ion Gun: Fix Filament usage not updating 
37. Hardware>E-Neut: Change min pulse frequency to 2 to avoid Data Acq errors with SXI  
38. Hardware>E-Neut: Fix bug where extractor/deflection stuck at -50V switching auto emission 

mode while gun is On  
39. Hardware>X-Ray: Do not allow X-Ray mode to be changed while SEM running 
40. Hardware>X-Ray: Remove skew correction from Beam Size Scan Patterns 
41. Hardware>X-Ray>Properties…>Service: Add Crystal Heater Temp controls 
42. Hardware>UPS: Fix bug where mode radio buttons would maintain focus causing errors about 

mode changes 
43. Aux Platen Transfer: Fix bug where unable to transfer Prep to Stage, waiting for V110 Open task 
44. Data File Header: Restore filling in Solid Angle, update for VP-4/Genesis 
45. Data File Header: Fix Presputter Yes/No not always being correct, implemented new way to keep 

track of acquisition position being sputtered as presputter now handled through queue sputter tool 
task 
 

 
KNOWN BUGS 

1. USB Camera DFK42AUC03: Setting camera properties Hue, Saturation, Gamma does not work 
through SmartSoft when video format is BY8 (1280x960). 

 
NOTES 

1. When changing E-Neut Filament type in Configuration Setup, if this is not a first time install 
(EGunNeut Settings present), E-Neut Work Function and Software Limit (A) will need to be 
manually updated for the new filament type in E-Neut Properties. 

2. With E-Neut changes making Gain, Time Per Step, and Ramp Rate Settings, need to set and 
resave E-Neut settings.  These parameters will be default values if Settings are not changed and 
resaved. 

3. Make sure to run ConfigurationSetup to make sure all configuration files are present for new 
Dynamic Correction Factors support. 

 
_____ 
  



______________________________________________________________________ 
 
Release 3.3.3 – February, 2023 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Feature enhancement build for User Displayed System Type control. 
 
NEW FEATURES 

Configuration 
1. Expand configuration properties ‘SystemEx’ support, including Splash Screen picture. 

 
BUG FIXES 

1.  
 

KNOWN BUGS 
1. USB Camera DFK42AUC03: Setting camera properties Hue, Saturation, Gamma does not work 

through SmartSoft when video format is BY8 (1280x960). 
 
NOTES 

1. When changing E-Neut Filament type in Configuration Setup, if this is not a first time install 
(EGunNeut Settings present), E-Neut Work Function and Software Limit (A) will need to be 
manually updated for the new filament type in E-Neut Properties. (V3.3.0 feature change) 

2. With E-Neut changes making Gain, Time Per Step, and Ramp Rate Settings, need to set and 
resave E-Neut settings.  These parameters will be default values if Settings are not changed and 
resaved. (V3.3.0 feature change) 

3. Make sure to run ConfigurationSetup to make sure all configuration files are present for new 
Dynamic Correction Factors support. 

 
  



 
___________________________________________________________________________ 
 
Release 3.3.2 – October, 2022 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Bug fixes for Intro Pumpdown and Transfer from Aux Prep to Stage. 
 
NEW FEATURES 

1.  
 
BUG FIXES 
 

1. System>Intro: Fix Intro Pumpdown finishing before Intro Pressure Setpoint.  
2. System>Intro: VersaPrep: Fix Transfer from Prep to Stage getting stuck on Open V110 task. 

 
KNOWN BUGS 

1. USB Camera DFK42AUC03: Setting camera properties Hue, Saturation, Gamma does not work 
through SmartSoft when video format is BY8 (1280x960). 

 
NOTES 

1. When changing E-Neut Filament type in Configuration Setup, if this is not a first time install 
(EGunNeut Settings present), E-Neut Work Function and Software Limit (A) will need to be 
manually updated for the new filament type in E-Neut Properties. (V3.3.0 feature change) 

2. With E-Neut changes making Gain, Time Per Step, and Ramp Rate Settings, need to set and 
resave E-Neut settings.  These parameters will be default values if Settings are not changed and 
resaved. (V3.3.0 feature change) 

3. Make sure to run ConfigurationSetup to make sure all configuration files are present for new 
Dynamic Correction Factors support. 

  



 
 
___________________________________________________________________________ 
 
Release 3.3.1 – March, 2022 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Add Support for Imaging Source GigE Intro Camera, Bug Fixes 
 
NEW FEATURES 

Configuration 
1. Add configuration options for ‘Imaging Source’ intro camera. 

 
BUG FIXES 
 

1. XPS>SXI>Mosaic: Fix mosaic data file header information having incorrect position information.  
2. XPS>Map>Mosaic: Fix mosaic maps appearing distorted after stitching together. 

 
KNOWN BUGS 

1. USB Camera DFK42AUC03: Setting camera properties Hue, Saturation, Gamma does not work 
through SmartSoft when video format is BY8 (1280x960). 

 
NOTES 

1. When changing E-Neut Filament type in Configuration Setup, if this is not a first time install 
(EGunNeut Settings present), E-Neut Work Function and Software Limit (A) will need to be 
manually updated for the new filament type in E-Neut Properties. (V3.3.0 feature change) 

2. With E-Neut changes making Gain, Time Per Step, and Ramp Rate Settings, need to set and 
resave E-Neut settings.  These parameters will be default values if Settings are not changed and 
resaved. (V3.3.0 feature change) 

3. Make sure to run ConfigurationSetup to make sure all configuration files are present for new 
Dynamic Correction Factors support. 

 

  



 
 
___________________________________________________________________________ 
 
Release 3.3.0 – October, 2021 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

VersaProbe 4, Mosaic Image, Dynamic Correction Factors, Continuous Z-Align, Improved E-Neut, 
Bug Fixes. 

 
NEW FEATURES 

Configuration 
1. Add support for VersaProbe 4. 
2. E-Neut: E-Neut Filament type can be set. Please check ‘E-Neut Filament’ type in System 

Configuration. 
3. Options: Add Mosaic Map option. 
4. Launch ConfigurationSetup automatically after installations complete. 

 
SEE  
1. Data Sampling: Disable data sampling of Data Acq during Beam Size and Anode Imaging 

acquisitions. 
 

UI  
1. Status Line: Display Queue remaining sleep time in status line.  
2. Status Line: Added ‘Bias’ to Acquisition status line when Stage/Sample Bias (5V) is set.  
3. Menu Bar>Tools>Ammeter Tool…: Clean up UI, each gun stores its own settings. 
4. Menu Bar>Tools>Outgas Conditioning…: Display ramp parameters in Queue Task Summary. 
5. Menu Bar>Tools>Chart Recorder…: Add GCIB PressureInKPa to be monitored. 
6. Ribbon/Dashboard>Queue: Delete entire job when ‘-‘ selected from ribbon view. 
7. Ribbon/Dashboard>Queue>Queue Editor: Additional file numbering support, auto increment. 
8. Ribbon/Dashboard>Queue>Queue Editor: Add default ‘SaveAll.csv’ filename for Chart Recorder 

– SaveData to File task. 
9. Ribbon/Dashboard>Queue>Queue Editor: Update editor when selecting or deleting a job from 

ribbon view. 
10. Ribbon/Dashboard>Queue>Queue Editor: Improve Copy/Paste support. 
11. Ribbon/Dashboard>Queue>Queue Editor: Remove obsolete ‘Tasks’ tab. 
12. Ribbon/Dashboard>Queue>Queue Editor: Add new ‘Sleep Until’ task. 
13. Ribbon/Dashboard>Sputter Tool: Add E-Neut during sputter support. 

 

Sample 
14. Sample>Platen Image View: Add support to move from Intro Photo>SPS>Intro Photo using 

GoogleBar zoom. 
15. Sample>Chamber Camera: For DFK42AUC03 camera, change default video format to ‘BY8 

(1280x960)’ and default frame rate to ’25.10’. 
16. Sample>Chamber Camera: Read ranges of Gamma, Hue, Saturation from the camera. 
17. Sample>Z-Align>Properties: Add ‘Stage Movement’ mode. ‘Step’ is original mode. ‘Continuous’ 

keeps the stage moving while acquisitions are running (XPS Z-Align only).  
 

XPS 
18. XPS>Acq Setup: Add combined ‘Add Queue’ and ‘…’ buttons to all acq setup menus. 
19. XPS>SXI>Mosaic: Add Mosaic option SXI support 
20. XPS>Map>Mosaic: Add Mosaic option Map support 
21. XPS>Data Manager: Support Add To Position List for .sps, .pho, .sem, .sxi, .map files.  Only 

supports maps acquired from position list (not from AES SEM Image View). 



 

AES 
22. AES>Acq Setup: Add combined ‘Add Queue’ and ‘…’ buttons to all acq setup menus. 
23. AES>Acq Setup: Single ‘Spe’ acquire button to acquire using position list.  Right-click context 

menu option for acquire using Area Define area(s). 
24. AES>Acq Setup>Area Define: Add acq ‘Start’, ‘More’, and ‘Queue’ buttons to Area Define and 

Line Define views. 
25. AES>Acq Setup: Support E-Neut for AES acquisitions.  SEM IR will blank E-Neut. 
26. AES>Acq Setup>Beam Current: Beam Current Threshold check will be skipped if acquisition is 

using E-Neut.  E-Neut causes threshold check to fail. 
27. AES>SEM>Mosaic: Add Mosaic option SEM support 
28. AES>Data File Header: Restore E-Neut Active and E-Neut Parameters to AES data file headers. 
29. AES>Data Manager: Support Add To Position List for .sps, .pho, .sem, .sxi, .map files.  Only 

supports maps acquired from position list (not from AES SEM Image View). 
 

Options 
30. LEIPS: Add ‘Picoammeter Range’ for LEIPS acquisitions (RBD only). 
31. LEIPS: Have LEIPS Acq Status show up in Ribbon/Dashboard. 
32. LEIPS: Change PMT parameter edit to SuperUser level. 
33. LEIPS: Update filter types and energies. 

 
Hardware 
34. Hardware>Bias Box: Add support for 26 degree input lens SCA, terminator relays change 
35. Hardware>E-Neut: Changing modes and other operations will no longer block UI while operation 

executes. 
36. Hardware>E-Neut: Gain, Time Per Step, and Ramp Rate are now Settings instead of Properties. 

Settings need to be checked and resaved with these changes. 
37. Hardware>E-Neut: E-Neut has a Blank mode for status display only (not selectable mode). 
38. Hardware>E-Neut>Properties: Add maximum wait time for ‘Source Tolerance Required’ 

parameter for adjusting maximum wait time before error occurs. 
39. Hardware>GCIB>Properties: Change range of Raster Calibration X/Y from 10.0 to 50.0. 20-066 

needs larger range for GCIB calibration. 
40. Hardware>Xray: When X-Ray mode is set to ‘On’ force drive to currently loaded anode position. 
41. Hardware>Xray: Change default Beam Parking setting to INITIAL instead of PREVIOUS. 
42. Hardware>Xray>Application Log: Restore X-Ray filament and emission readings log.  New 

application log name is ‘Xray Filament Emission Log’. 
43. Hardware>Detector>Properties>Channels: Add ‘Dynamic Correction Factors’ support, rename 

classic single pass energy acquisition to ‘Single Point Correction Factors’. 
  

Misc. 
44. Installation: Support installing USB drivers through Custom Actions, popup dialog and log file if 

Custom Actions tasks fail. 
 

BUG FIXES 
 

1. UI: Fix issue where Custom Actions would always run on Startup. 
2. Menu Bar>Tools>Outgas Conditioning…: Fix Application Log messages. 
3. Menu Bar>Tools>Outgas Conditioning…: Fix Ion Gun Outgas unable to turn Ion Gun to 

Neutralize when Vacuum Task is running. 

4. Ribbon/Dashboard>Acq Status: Fix Map Frames starting at frame ‘2’. 
5. Ribbon/Dashboard>Queue: Fix bug where Dual Anode SetMode task hangs. 
6. Ribbon/Dashboard>Queue: Fix bug where unable to run SXI with different X and Y FOV. 
7. Ribbon/Dashboard>Queue>Queue Editor: Fix bug with Import Settings feature when task 

selected is the Settings for a task. 
8. Ribbon/Dashboard>Vacuum: Fix display of Prep Gauge when no Prep station configured. 



9. Ribbon/Dashboard>Vacuum: Cleanup alignment for captions and pressure displays. 
10. Ribbon/Dashboard>Sputter Tool: Fix Stopping Zalar causing a long timeout, also fix Zalar Hitting 

Limit Switch not causing error and stopping zalar during sputter. 
11. System>Bird’s Eye View: Fix bug where if Intro and Aux stations have different camera types, 

taking Photo through Aux would use Intro station camera. 
12. System>Prep Photo: Don’t show Prep Camera when no camera configured for Prep Station. 
13. System>Valve Bird’s Eye View: Fix right-click set valve state not working. 
14. System>System Log: Cleanup mismatch of Pass Energy and Step Size error messages. 
15. Sample>Position List: Fix bug where changing default position size through main UI would not set 

default position sizes for positions in Queue. 
16. XPS>Data Manager: Fix bug where while running multiple queue jobs on same platen, was losing 

lab book entries for previous jobs completed. 
17. XPS>Map Acquisition: Fix Stop Failing when Map frame time is fast (ie. 0.5 or 1.0 ms time per 

pixel, small area). 
18. XPS>Map/Line Acquisition: Fix Pixel Size calculator not using highlighted current position in 

position list. 
19. XPS>Profile Acquisition: Fix Alternate Sputter Position depth profile causes subsequent non-

althernate sputter position sputtering to fail and time out. 
20. XPS>Spectrum: Fix unscanned Spectrum Acq not doing Cycle Stop when Stopping Acq. 
21. AES>Acquisitions: Fix bug where aborting AES acquisition with E-Neut and image registration 

while image registration is running would result in an error about ‘Cannot use Set Mode…’. 
22. AES>Image Registration: Fix ‘Position List’ tab displayed in Image Registration Info View when 

‘IR’ option key has not been enabled (required for position list IR support). 
23. AES>Map>Acq Setup: Fix IR Region Interval showing up as ‘1’ when should be ‘n/a’. 
24. AES>Map>Acq Setup: Fix AES Map IR not running. 
25. AES>Spectrum>Fix FAT mode region table shows extra eV Step column. 
26. AES>SEM>Z-Align: Fix Z-Align button always using AES Z-Align, even when ‘Use XPS’ option is 

selected. 
27. AES>SEM>SEM Image: Fix Annotation Shape cursor mode not working. 
28. AES>SEM>SEM Photo: Fix “Imaging Process Control busy..” error when start SmartSoft, Start 

SEM Imaging, then start SEM Photo.  After which cannot stop SEM Imaging. 
29. Options>REELS: Change region information to atomic # 111 and label to ‘Sur1’ so Multipak 

recognizes region. 
30. Options>LEIPS: Fix Stop not working for LEIPS, not saving file correctly at the end of the cycle. 
31. Options>LEIPS: Fix data file header not storing accumulated time per point in seconds. 
32. Options>LEIPS: Fix loading LEIPS data file loading filter energy into filter type field. 
33. Hardware>E-Neut: Fix bug where File Load would set E-Neut Mode. 
34. Hardware>E-Neut: Improve E-Neut error handling in addition to fixing Source Tolerance Required 

feature.  
35. Hardware>GCIB: Fix bug where Blank mode during timed sputter not blanking fast enough (wait 

for bend before raster Off).  
36. Hardware>Xray>Diagnostics: Fix Filament Current readback displaying setpoint instead of 

readback from hardware.  
37. Data Acquisition: Data Acq DLL attempts Abort and Mode Reset operations to address SXI 

Gauze Lens Not Ready errors. 
 

 
KNOWN BUGS 

1. USB Camera DFK42AUC03: Setting camera properties Hue, Saturation, Gamma does not work 
through SmartSoft when video format is BY8 (1280x960). 

 
NOTES 

1. When changing E-Neut Filament type in Configuration Setup, if this is not a first time install 
(EGunNeut Settings present), E-Neut Work Function and Software Limit (A) will need to be 
manually updated for the new filament type in E-Neut Properties. 



2. With E-Neut changes making Gain, Time Per Step, and Ramp Rate Settings, need to set and 
resave E-Neut settings.  These parameters will be default values if Settings are not changed and 
resaved. 

3. Make sure to run ConfigurationSetup to make sure all configuration files are present for new 
Dynamic Correction Factors support. 

  



 
___________________________________________________________________________ 
 
Release 3.2.1 – Feb, 2021 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Add 777B Pressure Control Monitoring 
 
NEW FEATURES 

Sample 
1. Sample>Stage>Initialize: Attempt to turn off X-Ray before initializing stage motors.  Do not 

continue with initialization if X-Ray -> Off fails. 
 

XPS 
1. XPS>Spectrum Acq Setup: Remove ‘Auto-Multiplex’ feature which currently is not supported with 

new Queue Editor. 
 
Hardware 
1. GCIB/IonGun: 777B: Monitor pressure control power. Restore ON state if power OFF. 
2. X-Ray: Don’t allow mode change to Park or On when stage is not initialized. 
3. X-Ray: Anode Motor Initializes on startup. 
4. X-Ray>Properties>Service: Anode Motor will initialize before Beam Power and Beam Size when 

enabled (default enabled). 
5. UPS: Add properties parameters for controlling stepping of Current and Gas Pressure when 

transitioning between source types. 
 

BUG FIXES 
1. System: Change to prevent SmartSoft from refreshing display on Windows group policy updates, 

causing a lot of flickering of UI. 
2. Sample>Navigation:  Fix bug where after Queue finishes, Platen Name would change to 

‘Navigate…’, also changes to position list would not be made to correct setting unless platen was 
reloaded through Platen Manager (or loading Platen). 

3. AES>REELS: Fix recent bug where Tungsten E-Gun REELS acquisitions would give error about 
‘no defined area’. 

4. AES>SEM: Fix bug where SEM without I-Neut suspended by acquisition with I-Neut would 
restore SEM after acquisition, but leave I-Neut ON. 

5. AES>SEM: Fix bug where SEM Photo while SEM Imaging is running could result in unable to 
start the SEM Photo due to “Imaging Process Control is busy” error. 

6. XPS>UPS and FXS Acquisitions:  With Queue editor fix a bug where FXS region values were 
clipped by UPS limits. 

7. XPS>XPS Setup…>Region: Fix bug where default step size values would disappear from combo 
box selections if another step size was selected. 

8. Hardware>E-Neut: Improve error handling when Source Tolerance is not reached. Mode will 
change to Standby on error.  More information logged in application log. 

9. Hardware>E-Neut: Fix problem where E-Neut Source Out of Tolerance error would result in E-
Neut being left on after acquisitions. 

10. Hardware>Ar Gas Pressure Control: Fix reading of gas control power status being reversed. 
11. Hardware>Tungsten E-Gun: Fix bug where loading setting with emission control mode different 

from current mode would not set emission or filament correctly. 
 
 

 
  



 
___________________________________________________________________________ 
 
Release 3.2.0 – September, 2019 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Improved Queue, Ribbon/Dashboard, Bug Fixes. 
 
NEW FEATURES 

SEE  
1. The System Evaluation Environment (SEE) is a new service utility built into the SmartSoft 

software which periodically records all system parameters while SmartSoft is running.  Notes: By 
default this utility is not activated; and Proprietary analytical data is never collected with SEE.  

2. Menu Bar>Hardware>System Configuration>System…>SEE: SEE data collection can be fully 
activated or deactivated in the configuration menu. 

3. Menu Bar>Hardware>System Log Setup>Data Sampling: SEE data collection can be partially 
activated or deactivated for individual hardware devices by selecting Data Sampling.  Note that 
Data Sampling for individual devices is only valid when SEE data collection is activated in the 
System Configuration. 

 

UI  
4. Ribbon/Dashboard: Queue Status: Display Status and Stop/Abort of running Queue. 
5. Ribbon/Dashboard: Acq Status: Display Status and Stop/Abort of running Acquisition. 
6. Ribbon/Dashboard: Queue: Overview and basic control of Queue.  Access to Queue Editor for 

modifying Queue Tasks. 
7. Ribbon/Dashboard: Data Manager: Easy access to common Data Manager parameters. 
8. Ribbon/Dashboard: AES Acquisition: Control of most common AES Acquisition Properties. 
9. Ribbon/Dashboard: XPS Acquisition: Control of most common XPS Acquisition Properties. 
10. Ribbon/Dashboard: Sputter Tool: Easy access control for timed sputtering with configured sputter 

guns. 
11. Ribbon/Dashboard: Stage: Easy access control for stage control. 
12. Ribbon/Dashboard: Vacuum: Display vacuum pressure status. 
13. Menu Bar>Automation>Queue…>Queue Editor: New Tree View style Queue Editor allows editing 

queue even while queue is running. 
14. Menu Bar>Automation>Queue…>Queue Editor>Tool Palette>Service: Outgas can now be 

performed through the Queue. 
15. Menu Bar>Tools>Outgas Conditioning…: Control parameters for Outgas procedures can be 

setup here. 
16. Parameter Hints: Hint display duration now depends on hint text length. 
17. Menu Bar>Tools>Chart Recorder…: The Chart Recorder now displays pressure values in 

scientific notation. 
18. Menu Bar>Tools>Ammeter Tool…: Ammeter Tool has been improved to be more functional for 

more gun types.  When Sample Current readings are launched from the Hardware session, 
Ammeter Tool will display Gun Type correctly.  

 

Sample 
19. Sample>Stage: Stage rotation limit increased from 360.00 to 360.05 to take into account stage 

error and accommodate position verification checks. 
20. Sample>SXI: Change min persistence of N-frame SXI acquisitions (Preview, IR) to 2 frames. 
21. Sample>SXI Image: Added Z-Align with SXI button. 
22. Sample>SXI Image>SXI Image Properties>Photo-Acq: Added SXI Photo options for acquisitions 

separate from SXI Photo button options. 
23. Sample>Stage>Properties: Add ‘Enable All’ and ‘Disable All’ motors buttons. 
24. Sample>Position List>Toolbar:  Across the UI, made list controls more consistent. (ie. Move 

up/down, add/delete, delete all). 



 
 

XPS 
25. XPS>Acq Setup: Remove Default Pass Energy combo box. Default new element region added 

Pass Energy to previous region Pass Energy in region table. 
26. XPS>Acq Setup>XPS Setup…>Region: -5V Sample Bias is now available for all acquisition 

types.  Used to be only for UPS configured systems and UPS acquisitions. 
 

AES 
27. AES>Acq Setup: Default new element region added Resolution to previous region Resolution in 

region table. 
28. AES>SEM: Protect from point & click stage moves when SEM Imaging is Off. 

 

 
Hardware 
29. Hardware>E-Neut>Diagnostics: Add ADC parameters. 
30. Hardware>E-Neut>Add read emission current button. 
31. Hardware>Schematics:  Update hardware schematics diagrams that were missing or needed 

updating. 
32. Hardware>FXS>Lab6: Change emission current threshold from 1.0 uA to 0.8 uA. 
33. Hardware>FXS>Diagnostics: Removed  
34. Hardware>C60: Auto-Startup removed as it is replaced by Outgas Conditioning Tool. 
35. Hardware>GCIB: Add warning when SmartSoft starts up after previously turning GCIB Off at 

shutdown.  This is the same as what is done for C60. 
  

Service 
36. USB Connection Monitor:  SmartSoft logs USB connect and disconnect events in the system log. 
37. Key Click Logging:  Log UI buttons and components interacted with to system log for assisting 

troubleshooting. 
 

Misc. 
38. Installation: Add Eucentric Tilt Excel spreadsheet to installation (“Other” directory). 
39. Installation: Add 64-bit versions of Microsoft dlls msvcp100.dll and msvcr100.dll to 64-Bit 

SmartSoft installations.  This fixes a problem where IC Imaging cameras were not working with 
64-bit installations. 

 
 

BUG FIXES 
 

1. UI>Shutdown: Fix problem where SmartSoft could hang on shutdown if SXI is running. 
2. Menu Bar>System>Zip Log Files…:  Fix bug where Zip Tool could fail due to missing timestamps 

at end of system log files. 
3. System>Vacuum>Main Turbo: Fix bug where call to turn Main Turbo ‘Off’ would not work. 
4. System>GigE Intro Camera: Fix bug where GigE camera control error messages were not 

printing to the system log correctly. 
5. AES>Profile Setup: Fix bug where AES Profiles could potentially get set to run in FAT mode, 

which would fail. 
6. AES>Acq Setup>AES Regions Table>Test Acquiure: Add missing context menu “Test Acquire 

…” option. 
7. AES>SEM: Improve performance of SEM tuning; Focus/Stig1/Stig2. 
8. XPS>Refresh Acq: Fix problems w/ refresh acquire button press and button state in data viewer.  
9. XPS>Map Acq>XPS Regions Table: Fix first component in ‘Frame’ list column looking different 

and not having right-click ‘set all’ option.  
10. XPS>Profile Setup: Fix problem where in ‘Continuous’ or ‘No Sputter’ mode the Ion Gun Settings 

combo box appeared to update rapidly and flicker.  



11. XPS> Depth Profile: Fix bug where Depth Profile with IR enabled fails, then Ion Gun or GCIB 
auto-shutdown occurs before user reacts to IR failure.  Selecting ‘Stop’ would cause a lockup in 
this state.  Fixed ‘Stop’ not working. 

12. XPS>Spectrum>Element Database: Fix bug with Element Database Editor where editing Xe 
transition names would be converted to “CustomXe…”. 

13. XPS>Spectrum>XPS Setup…>Region: Fix typo that prevented setting default ratio for PE 140 
and 224 to 1 (was minimum of 2). 

14. XPS> Timed I-Neut During Acq:  Fix bug where timed I-Neut pulse before Z-Align would cause 
acquisition to lockup trying to switch back to continuous I-Neut after Z-Align. 

15. Hardware>X-Ray>When turning Heat Exchanger Off, prompt users to turn X-Ray Off (if not 
already Off).  This is to prevent an error state in the hardware that is difficult to recover from.  

16. Hardware>X-Ray>Diagnostics: Removed ‘Read’ prefix from captions. 
17. Hardware>Ion Gun: Fix bug where Z-Align pulsed I-Neut or SXI IR with I-Neut could lock up the 

UI for several minutes while the Ion Gun mode changed for I-Neut. 
18. Hardware>Ion Gun (777B Pressure Control): Fix bug with Extractor Pressure edit box displaying 

wide open range in scientific notation. 
19. Hardware>GCIB: Fix a bug where loading GCIB setting from a Queue would load parameters 

correctly, but not the setting name. 
20. Hardware>C60>Diagnostics: Change Filament Current caption units from uA to A. 
21. Hardware>C60: Fix bug where sometimes after loading a setting and switching to ‘Standby’ 

mode, temperature readback (heater power) does not change until temperature field is toggled. 
22. Hardware>Ion gun:Fixed a bug where Auto Argon and Auto Diff Pump status would not save 

between exit and startup. 
23. Hardware>UPS(20-280):Fix bug where UPS being turned off on SmartSoft exit was not 

completing properly. 
24. Hardware>UPS(20-280):Fix bug where Auto-Tuning of switching between He1 > He2 could end 

up stepping gas pressure wrong direction due to readback value offsets. 
25. Hardware>UPS(20-280):Fix bug when UPS mode is turned On (Ignition), would sometimes get 

error “V4 Status: Closed. Turning off UPS”. 
 

 
KNOWN BUGS 

1. None. 
 
NOTES 

1. None. 
 
___________________________________________________________________________ 
 
Release 2.10.2 – March, 2019 (Win7: 32-Bit)  
Release 3.1.2 – March, 2019 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Additional support for LEIPS,UPS, 777B Pressure Control, Bug Fixes. 
 
NEW FEATURES 

SEE  
1. The System Evaluation Environment (SEE) is a new service utility built into the SmartSoft 

software which periodically records all system parameters while SmartSoft is running.  Notes: By 
default this utility is not activated; and Proprietary analytical data is never collected with SEE.  

2. Menu Bar>Hardware>System Configuration>System…>SEE: SEE data collection can be fully 
activated or deactivated in the configuration menu. 

3. Menu Bar>Hardware>System Log Setup>Data Sampling: SEE data collection can be partially 
activated or deactivated for individual hardware devices by selecting Data Sampling.  Note that 



Data Sampling for individual devices is only valid when SEE data collection is activated in the 
System Configuration. 
 

UI  
4. Menu Bar>Data>System Colors>Sample Viewer: Add ability to change platen thumbnail caption 

color. 
 

System 
5. System>Create Sample: GigE: Add LEIPS platen default platen image. 

 

Sample 
6. Sample>Stage: Rotation range updated to -258 to 100 degrees for H/C stages with limit switches. 

 

Options 
7. Options>LEIPS Data File Header: Updated fields in data header to be more compatible with 

Multipak. 
 

XPS 
8. XPS>Data File Header: For both XPS and AES data files, storing Ion Gun Neutralizer parameters 

separate from Ion Gun  Presputter parameters. 
9. XPS>Data File Header: For both XPS and AES data files, storing Ion Gun Neut On/Off. 

 

AES 
10. AES>Spectrum: SEM Setting changed back to read only field. 

 
Hardware 
11. Hardware>E-Neut: For LEIPS support, there is now a way to set E-Neut Extractor Blanking 

Voltage for Standby Mode. 
12. Hardware>Source>UPS: Support ‘Auto’ Photon Source tuning for switching to second line (ie. 

He1 -> He2). 
13. Hardware>Source>UPS: When V4 interlock is triggered, turn UPS UV state to Off so that 

Pressure Control is stopped and Rough Pump Valve is closed. 20-280 Control. 
14. Hardware>GCIB>Diagnostics: Disable Heat Exchanger State and Heat Exchanger Interlock with 

777B Control. 
 

 
 

BUG FIXES 
 

1. System>Turbo Status: For Leybold Turbo Control, check turbo speed status to determine On/Off 
status. 

2. System>Shutdown: Fix missing logic to shutdown SXI and SEM imaging on SmartSoft shutdown. 
3. XPS/AES>Profile>Profile Properties: Fix bug where when running zalar sputter at alternate 

sputter position (Sputter Offset), zalar was occurring at incorrect X and Y position. 
4. AES>More Acq: Fixed bug where AES acquisition ‘More’ would load incorrect resolution values 

into the region table. 
5. Options>LEIPS: Fixed bug where failed LEIPS acquisitions did not clean up data plot area. 
6. AES>Energy Range: Min energy range updated to 10 eV to prevent issue of possible drop-off of 

collected data when starting at 0 eV. 
7. AES>IR Info: Fix imags shift X/Y Offsets accumulating when setting up Registration Area. 
8. Hardware>Ion Gun: Fix ‘Auto’ pressure control not getting set on startup of SmartSoft with 777B 

pressure control. 
9. Hardware>Ion Gun: Fix ‘Auto’ pressure control checkbox status not being saved between restarts 

of SmartSoft with 777B pressure control. 



10. Hardware>Ion Gun: Update sizing of Ion Gun view to help with scroll bars appearing when not 
needed. 

11. Hardware>Ion Gun: Fix bug where when neutralizing or sputtering, previously loaded setting 
extractor pressure could get used. 

12. Hardware>GCIB: GCIB Diagnostics: Fix “Power Status” being displayed backwards with 777B 
pressure control.  

13. Hardware>GCIB: Fix when presputter or timed sputter completed, GCIB would not ‘Auto’ close 
the Ar leak valve. 

14. Hardware>UPS: With 20-280 control, fix Rough Pump Valve Status not being updated on 
change. 

15. Hardware>UPS: With 20-280 control, fix V4 Interlock message popping up about turning UPS 
‘Off’ when UPS is already in ‘Off’ mode. 

16. Hardware>Detector>Properties>MCD: Fixed X-Ray Settings being shown instead of SEM 
Settings, since AES MCD acquisition always uses SEM Settings. 

 
KNOWN BUGS 

1. Before acquisitions with Ion Neutralization are queued, the Ion Gun mode should be set to 
‘Standby’, so that it is returned to this mode after the acquisition.  If the mode is ‘Off’, the Ion Gun 
will be restored to the ‘Off’ mode. 

2. Ion gun pulsed neutralization before Z-Align feature is broken in this release.  This will be fixed in 
future releases. 

 
NOTES 

1. None. 
 
___________________________________________________________________________ 
 
Release 2.10.1 – November, 2018 (Win7: 32-Bit)  
Release 3.1.1 – November, 2018 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

Bug Fix Release 
 
BUG FIXES 
 

1. Sample>Position List>: Default Exception Error when editing position list when IR option not 
enabled. 

2. XPS>Depth Profile: IR Setup is visible in Depth Profile Setup tab when IR option not enabled 
3. Menu Bar>Hardware>System Configuration: Turbo Pump Type change is not saved. 

 
___________________________________________________________________________ 
 
Release 2.10.0 – October, 2018 (Win7: 32-Bit)  
Release 3.1.0 – October, 2018 (Win10: 64-Bit) 
___________________________________________________________________________ 
 
OVERVIEW 

SEE Diagnostics, REELS, LEIPS, PHI-UPS Controller, SXI Image Registration Enhancements, Bug 
Fixes. 

 
NEW FEATURES 

SEE  
1. The System Evaluation Environment (SEE) is a new service utility built into the SmartSoft 

software which periodically records all system parameters while SmartSoft is running.  Notes: By 
default this utility is not activated; and Proprietary analytical data is never collected with SEE.  



2. Menu Bar>Hardware>System Configuration>System…>SEE: SEE data collection can be fully 
activated or deactivated in the configuration menu. 

3. Menu Bar>Hardware>System Log Setup>Data Sampling: SEE data collection can be partially 
activated or deactivated for individual hardware devices by selecting Data Sampling.  Note that 
Data Sampling for individual devices is only valid when SEE data collection is activated in the 
System Configuration. 

 
UI  
4. Menu Bar>Tools>System Configuration: Simplified UI: configuration options are organized by 

sessions; property dialogs are added for configuration details. 
5. Menu Bar>Tools>System Configuration>Options: Add REELS option. Activation key required. 
6. Menu Bar>Tools>System Configuration>Options: Add LEIPS option. Activation key required. 
7. Menu Bar>Tools>System Configuration>Options: Add PHI-UPS option. 
8. Menu Bar>Tools>System Configuration>Chamber Camera: Add support DFK 42AUC03 USB 

camera. 
9. Menu Bar>Tools>System Configuration>Turbo Pump Type: Add Configuration Support for 

Leybold Turbos 
10. Menu Bar>Tools>System Configuration>Electron Gun.  Add support for Tungsten filament 

electron gun which is used for REELS. 
11. Menu Bar>Tools>System Configuration>Ion Gun: Add support for the 777B Piezo Valve. 
12. Menu Bar>Tools>Chart Recorder…: The Chart Recorder now includes an ‘Auto Scale’ feature 

which optimizes the data displays for all plots. 
13. Menu Bar>Tools>Resource Monitor: Add monitoring of C: hard disk space.  A warning message 

is displayed when the available disk space falls below an enterable threshold value. 
14. Menu Bar>System>Task Scheduler: A ‘Once’ checkbox option is added to the task scheduler to 

run task only one time. 
15. Menu Bar>System>Zip Log Files: Include timestamp in the default filename. 
16. Status Bar: Add Acquisition Setup Properties indicators. 

 
System 
17. Intro>Intro Camera: GigE: Log error description along with error code in system log. 

 
Sample 
18. Sample>Z-Align: Check if Z-height is equal to or lower than initial Z-Align drop. If this is true start 

Z-Align at current Z-height. 
19. Sample>Stage>Stage Properties: Add Protection During Acquire and Protection During Drive.  

Protection During Acquire: lowers the Z and R when the stage is moved to the next analysis point 
during an acquisition; Protection During Drive: lowers the Z and R when stage is moved using the 
stage Drive All feature. 

 
XPS 
20. XPS>Data Manager>Lab Book: The lab book can now include an unlimited number for data file 

entries.  Previous limit was 150. 
21. XPS>Spectrum>Properties: Support selecting pre-sputter gun type. 
22. XPS>Acquisition Setup>Refresh Acquisition Viewer: Add Restart button. 
23. XPS>Acquisition Setup>Refresh Acquisition Viewer: Add FWHM reading to data display. 
24. XPS > SXI Properties>Image: Add enhanced live image processing options: Bright Band 

Correction, Noise Reduction, and Contrast Enhancement. 
25. XPS >SXI Viewer>Image Registration: The saved reference image is now displayed as part of 

the image registration setup dialog. 
26. XPS > SXI Viewer>Image Registrations>Properties: One can now pre-select the acquisition 

behavior when an image registration fails (Prompt User, Continue, Stop).  Prompt User - will 
display a dialog box and wait for operator intervention; Continue - will continue the data 
acquisition without image registration; Stop - will stop the acquisition at the current frame or cycle.   

27. XPS > SXI Viewer>Image Registrations>Properties: One can now select the number of IR retries 
before reporting a failure.   



 

AES 
28. AES>Spectrum: Add FAT analyzer mode (REELS Option).  

 
Hardware 
29. Hardware>C60: C60 diagnostics menu meter range is red when the gun is off.  Added support to 

show the range is unknown [- - -] when the gun is off. 
30. Hardware>Analyzer: Add unique Gauze Lens Spans and Offsets for HP. 
31. Hardware>Analyzer: Calibration: TFC coefficient A range max increased to 1000. 
 

Service 
32. CommChecker.exe: A new utility called CommChecker is included in the SmartSoft-

VersaProbe\bin folder. CommChecker is used to check the communication channels as defined 
in the SmartSoft-VersaProbe configuration properties file for trouble shooting purpose. 

 
BUG FIXES 
 

1. UI>Tab Stop: Tab stops are removed for all menus. 
2. UI>Menu Bar>System>Task Scheduler…: Fixed problem where the Task Scheduler incorrectly 

reports “AutoTool is already running”. 
3. System>Intro Photo>Take Intro Photo: Corrected bug where intro photo is taking many minutes. 
4. Sample>Position List>Z Position = 0.0: A default Z position of 0.0 indicates that the Z position is 

unknown at the time the position is created (e.g. platen not on the stage; import from defect file).  
Drive to Position ignores the Z move when the Z position is 0.0.  SmartSoft now displays a 
prompt which clarifies that a  default value of 0.0 maintains the current Z position; while a value of 
0.001 drops the Z to a minimum Z position.  

5. Sample>Position List: When driving to position stage sometimes moves even when already at 
position.  Increase X/Y tolerance. 

6. Sample>Platen Viewer: Photo appears washed out, too light.  Changed default gamma from 0.6 
to 1.0. 

7. XPS>SXI: SXI files (.sxi) are missing the photo file name which causes a problem when 
displaying spatial areas.  Fixed. 

8. XPS>Spectrum>Element Database: Default transition energy window for Ru3p3 is 458-478 eV.  It 
should be 453-473 eV. Note that element database must be manually updated to get this fix. 

9. XPS>Spectrum>Element Database Element Database: Remove spaces from transition names 
and replace with ‘_’ character to prevent problems managing between SmartSoft and Multipak.  
Note that element database must be manually updated to get this fix. 

10. XPS>Depth Profile: During GCIB depth profile with ion neutralization, the profile often fails by 
Timed Sputter Failure. (OLE Error).   

11. Hardware>X-Ray>Diagnostics: Log application error when arc is detected. 
12. Hardware>C60/GCIB: Persist lifetime value to file when values change to protect against crash or 

forced shutdown.  Note that Ion Gun lifetime times are in saved in the firmware and do not need 
to be persisted in SmartSoft. 

13. Hardware>GCIB: PHI USA GCIB: Loading setting file while in standby mode should not load the 
high voltage.  

 
KNOWN BUGS 

1. Before acquisitions with Ion Neutralization are queued, the Ion Gun mode should be set to 
‘Standby’, so that it is returned to this mode after the acquisition.  If the mode is ‘Off’, the Ion Gun 
will be restored to the ‘Off’ mode. 

 
NOTES 

1. None. 
___________________________________________________________________________ 
 



Release 2.9.0 - October 2017 (Win7; 32-Bit) 

Release 3.0.0 - October 2017 (Win10; 64-Bit) 

___________________________________________________________________________ 
 
OVERVIEW 

Windows 10 support, SXI Image Registration, Element database editor, Bug Fixes 
 
NEW FEATURES 

UI 
1. SmartSoft-VP Icon: New Icons. 
2. Configuration Manager: Exit dialog is now more intuitive with ‘Save’ options. 
3. Configuration Manager: ‘4-Contacts’ Hot/Cold Stage selection renamed to ‘PreVac 4-Contacts’ to 

avoid further confusion. 
4. Configuration Manager: Support both ‘DFx41BU02’ and ‘DFK41BU02’ Chamber Camera models. 

 
System 

5. Tools: Chart Recorder:  Revamped Chart Recorder tool for plotting short-term history of designated 
parameters. 

6. Tools: System Log Setup:  Add right-click context menu to “System Log…” button for selecting 
system log viewer to use. 
 
Sample 

7. SXI: Add SXI Image Registration Support 
 
XPS 

8. Element Database: Element Database can now be edited through right-click context menu on 
periodic table elements. 
 
AES 

9. Element Database: Element Database can now be edited through right-click context menu on 
periodic table elements. 

10. Acq Setup: Change min KE to 10 eV from 30 eV. 
 
Hardware 

11. GCIB: Display dialog when GCIB interlock is tripped to notify users. 
12. FXS: Add ‘Clear Registers’ button to FXS Registers Diagnostics View.  Clear Registers on Reinitialize 

automatically. 
13. Ion Gun: Added logging to Application Log for Ion Gun. 

 
Misc. 

14. Vacuum Pressure Log:  A simple version of a vacuum pressure log is written to a file in the 
Settings/Log directory.  The interval of entries is in Vacuum Settings “Properties.phi” file. 

15. Anode Position Delta: Open up “Anode Position Delta (mm)” min/max range so that Stage Settings 
“Properties.phi” file can be altered to reduce this value if needed.  
 

BUG FIXES 
2. AES: Periodic Table: Fix right-click element popup menus for selecting transitions. 
3. XPS: Periodic Table: Fix right-clicking on K or Ca to choose alternative regions. 
4. Hardware: Analyzer: TFC parameters Narrow or Standard were written to data file header based 

on analyzer mode when queue started instead of how queued acquisition was designated. 
5. Navigation: SXI Position: When adding a analysis position to a non-square SXI Image, acquisition 

was running at wrong position. 
6. System: Intro Camera: Fix issue where single Intro Camera configured systems with GigE 

camera would require the camera to have "Device User ID" set to "Intro" to work.  Now it behaves 



like the Canon camera which by default doesn't look for device name with single camera, only 
with multiple cameras such as SS-VP Prep. 

7. Intro: Intro Camera: Fixed bug where GigE Intro Camera configuration would default to GigE 
camera simulation ‘On’. 

8. XPS: Data File Header: Fixed bug where wrong Presputter mode would get recorded in data file 
header. 

9. XPS: Presputter, Peak to Noise, Narrow Acceptance Angle, Zalar Rotation Speed:  These 
parameters are set in UI through autotool tasks instead of behind-the-scenes. 

10. Hardware: Beam Parking: Maintain beam parking mode differently, which fixes bug of X-Ray 
mode changing from ‘Park’ to ‘On’ after and SXI file save, even though beam is still parked. 

11. Hardware: Lab6 E-Gun with AES:  When AES acquisitions are stopped, no longer turning the E-
Gun off. 

12. XPS: UPS acquisitions with FXS acquisitions: Fix bug where transitioning from a UPS acquisition 
to an FXS acquisition would incorrectly clip region ranges. 

13. Sample: Stage Position Check:  Increased Rotation tolerance when deciding if stage needs to be 
moved when starting acquisitions (problem was stage moving when already at acquisition 
position). 

14. Sample: Save SXI E-Neut: Fixed a bug where E-Neut would get turned off when saving SXI 
Image. 

 
KNOWN BUGS 
1.  

 
NOTES 

1. SCA Lens Table Updates: To pick up SCA Lens Table changes when updating existing software, 
move or rename SCA Lens Table files in SmartSoft ‘Configuration’ directory and rerun the 
Configuration Manager to get new files.  Or manually copy and rename the files from the 
‘PredefinedSetting’ directory to the ‘Configuration’ directory. 

 
___________________________________________________________________________ 
 
Release 2.8.0 - January 2017 

___________________________________________________________________________ 
 
OVERVIEW 

SmartSoft-VersaProbe V2.8.0 adds: Support for 64-Bit OS; New TFC Correction; RBD Ammeter; 
GigE Intro Camera; Bug Fixes 

 
NEW FEATURES 

UI 
1. SmartSoft-VP Icon: New Icon. 

 
System 

2. Turbo Speed Interlock: Put in check for if turbo speed drops below 80% V4 is closed. 
3. Intro/Prep GigE Camera:  Implemented support for GigE camera, redesign the intro process to 

improve clipping and calibration procedure. 
4. Dual Anode Stage Init: Request warning when initializing stage to retract Dual Anode. 
5. Sample Max Z-Height: If Sample Max Z-Height is set below stage transfer position, user will be 

notified to change Max Z-Height to allow transfer process to complete. 
6. Transfer Vessel: Added “Transfer Vessel” task to SmartSoft so to not have to run only through 

Watcher. 
 

SEM 
7. SEM Image Properties >  Added expandable tabs. 
8. Histogram Dialog > Ability to resize. 



9. SEM: Reduced Image: Automatically take the SEM out of Auto Contrast mode when using reduced. 
image.  Return the Auto Contrast to the previous state when completed. 

 
XPS 

10. Acq Setup: XPS: Default Pass Energy is now saved as a Setting. 
11. Support ‘Use Auto Directory’ through Queue. 
12. TFC Correction: New TFC Correction function using variable number of data points from TFC curve. 
13. Allow 2500V analyzer retard range for Al or Mg dual-anode. 
14. Profile Sputter Offset: Added warning to users when ‘Sputter Offset’ is enabled when adding to 

Queue. 
 
Hardware 

15. RBD Ammeter:  RBD Ammeter is now supported. 
16. GCIB: Auto Standby mode now supported. 
17. Ion Gun/E-Neut: If gun setting is selected in Acquisition Properties and is deleted from Hardware tab, 

SmartSoft will block the action and show a warning dialog. 
 
Misc. 

18. Zip Tool: Provide a tool for users or Service to easily save and zip up log files and settings files for 
bug diagnostics.  
 

BUG FIXES 
1. Configuration Manager > Fixed issue where 20-376A Analyzer configuration was not copying over 

correct FRR SCA Lens Files into Configuration Folder 
2. Configuration Manager > When selecting VP-III configuration (32-channels), the correct lens table 

files are not being copied into the configuration directory correctly? 
3. Spectral data view > Finger Print mode clicking on spectral data causes ‘Range check error’ 
4. Ion Gun > Ion Gun Properties: Unchecking Tracking checkbox does not work 
5. Queue Pre-Check > Depth Profile Acquisitions would sometimes fail and state that a sputter gun is 

not in a ready state when that gun was not set up for that acquisition 
6. SXI > Fixed issues with SXI persistence not working as desired 
7. Stage with Platen Intro >  Fixed a bug where sometimes after Platen to Stage, stage would drive Z-

height to max 
8. Platen Max Z-Height > Fixed bug where Platen Max Z-Height was not being reflected in Stage Z 

Motor range 
9. Configuration - Analyzer Control product ID > Fixed 20-376A Product ID 
10. SXI > Fixed problem where ‘Clear Image’ would not work 
11. Ion Gun Diagnostics > +15V and -15V readbacks were backwards 
12. More Map > More Map was not working 
13. More Map > Restrict parameters that should not be altered 
14. Knob Box Logging > When the knobbox is configured and not connected and not simulated; errors 

are continuously generated in the system log(s) 
15. Turbo Speed Interlock > When Turbo Interlock is tripped in software, performs protection action once 

and displays alert dialog to avoid multiple interlocks with backfill 
16. SXI Anode Imaging > Anode image has too much noise if anode motor is connected 

17. Queue Restore Position List > Remove the AutoTool Restore Position List task since it causes loss of 
any updated Z heights in position list due to Auto Z 

18. Motors setup on Startup > For the 4700/4800 where, there's no anode, the Motors dll needs to have 
information set.  Consequence of not setting this up correctly was that Z-motor initialize would not 
initialize correctly an could continue to rise up towards the optics 

19. SEM Date Display > “Date” displayed on SEM view is not reflected even if date is changed. We have 
to uncheck “Date” checkbox and check it to display correct date 

20. AES Map/Line >  In case of 2- or 3-point mode, BG1 and BG2 position should be limited 
21. X-Ray Diagnostics Arc Count > Removed “Total Arc Count”, no different than “Arc Count” 
22. Canon Camera > Attempt to fix software freezing issues related to auto focus overdrive 



23. Ion Gun > Fix Create Sessions error when reserved settings are deleted from Ion Gun Settings folder 
before starting SmartSoft 

24. Sample > Zalar Range Circle: Fix center location to line up with stage 0,0 
25. Sample > Stage Limits Box: Fix range limits and center location to line up with stage 0,0 
26. Data Manager > Fix problem where ‘Auto Directory’ checkbox would automatically uncheck after 

starting an acquisition 
27. Add missing -1600 to -2500 eV range values for 32-channel FAT SCA Lens Table 
28. Fix map displayed titles mistakenly given same name when acquiring more map 
29. Fix Parent SXI remains unchecked if child point created on unchecked SXI 
30. Add new AR lens values for 16-channel FAT SCA Lens Table 

 
KNOWN BUGS 

1.  
 
NOTES 

1. SCA Lens Table Updates: To pick up SCA Lens Table changes when updating existing software, 
move or rename SCA Lens Table files in SmartSoft ‘Configuration’ directory and rerun the 
Configuration Manager to get new files.  Or manually copy and rename the files from the 
‘PredefinedSetting’ directory to the ‘Configuration’ directory. 

 
 
 
 
  



 
___________________________________________________________________________ 
 
Release 2.7.2 - April 2016 (CQR Release Only) 

___________________________________________________________________________ 
 
OVERVIEW 

SmartSoft-VersaProbe V2.7.2 adds: Save SXI Image During Acq 
 
NEW FEATURES 

SXI 
1. SXI>Image Properties>Preview Image: Adds support to automatically collect and save n-number of 

SXI frames.  
 
XPS 

2. Acquisition Setup>Properties>Save SXI: Add support to save an SXI image at each analysis position, 
before the XPS data collection. 
 

KNOWN BUGS 

1.  With VP-III systems, the configuration manager does not copy the 32-Channel lens tables from the 
Configuration\PredefinedSetting directory into the Configuration directory and rename them to 
“ScaLensFat.txt” and “ScaLensFRR.txt” as it should.  This will need to be done manually on VP-III 
systems. 

NOTES 
1.  
___________________________________________________________________________ 
 
Release 2.7.1 - March 2016 

___________________________________________________________________________ 
 
OVERVIEW 

SmartSoft-VersaProbe V2.7.1 adds: Support for VersaProbe-III; Variable Dwell Time; Bug Fixing 
 
NEW FEATURES 

UI 
1. Configuration:  Support VersaProbe-III 

 
Sample 

2. Stage: Add right-click context menu option to toggle stage cursor and FOV display On/Off. 
3. Intro Camera: Add new Canon camera SDK support to support newer cameras. 
4. Alignment:  Remove shortcut icons for alignment pins. 
 

XPS 
5. Acquisition: Show warning when starting XPS acquisition if SAM E-gun is On. 
6. Acquisition Setup: Support variable scan area dwell time which is tied to time/step of acquisition. 
7. Acquisition Setup: Support sputter offset for all sputtering, instead of just GCIB. 

AES 
8. Acquisition Setup: Support sputter offset for all sputtering, instead of just GCIB. 
9. Profile Data: Add View menu option for changing AES profile spectral data display from showing all 

cycles to just showing current cycle (like XPS). 
Hardware 

10. C60: Read the user ranges from the controller instead of using hardcoded manufacturer numbers. 
 

BUG FIXES 
31. Sample > Stage: Update proper tilt range when Y-axis is changed. 



32. Sample > Position List:  Fix problem where user could click on position list while acquisitions are 
running, causing multiple issues. 

33. XPS/AES > Clicking ‘Next Region’ button continually displays “Stopping” message. 
34. XPS/AES > Fixed issue where computer delays could cause data retreival from acq hardware control 

to fail, causing acquisition failures (no data for 20 seconds error). 

35. XPS/AES > Fix issue where if FXS source is in ‘Park’ and SEM or AES spectra is started, FXS source 
is turned on as well. 

36. XPS > UPS selected as source, load FXS acquisition setting, does not load correct acquisition energy 
range. 

37. AES > Wait ‘Delay After Sputter Time’ before running image registration. 
38. Hardware > E-Neut: Extractor voltage range changed to 0-75V. 
39. Hardware > Ion Gun: Fix problem where depth profiling with neut would sometimes corrupt emission 

current. 
40. System > Startup: Fixed bug where firmware version checking could report current firmware version 

as older than expected when actually newer. 
41. System > Photo file:  Stage rotation saved as 45 degrees. 
 
KNOWN BUGS 

1. With VP-III systems, the configuration manager does not copy the 32-Channel lens tables from the 
Configuration\PredefinedSetting directory into the Configuration directory and rename them to 
“ScaLensFat.txt” and “ScaLensFRR.txt” as it should.  This will need to be done manually on VP-III 
systems.  

NOTES 
1.  
 
___________________________________________________________________________ 
 
Release 2.7.0 – December 2015 (AES4800 Only) 
___________________________________________________________________________ 
 
OVERVIEW 

SmartSoft-VersaProbe V2.7.0 Adds: AES4800 CQR; Common UI Features; Bug Fixing 
 
NEW FEATURES 

UI 
1. Menu Bar>Tools>System Log: Backup copies of the system log are now stored in the C:\SmartSoft-

AES\Log directory 
2. Status Bar: The size of the status line fields can now be customized by clicking and dragging the 

edge of the field.  Fields can be returned to their default size by selecting the Reset Default Size 
option from the status line context menu. 

3. Status Bar>Highlight: The highlighting tool indicates which menu items are Settings and which items 
are Properties.  Settings are loaded as a group of values using the Settings>Load command; while 
Properties are common across the entire system. 

4. Menu Bar>System>E-Mail Notification: One can now send custom email messages or text messages 
during the running of an AutoTool sequence.  This is accomplished by using the AutoTool Send E-
Mail task. 

5. Menu Bar>System>Coffee Timer: This feature adds the capability to schedule the processing of an 
AutoTool task at a specified day and time. 

6. Menu Bar>Tools>System Log: Backup copies of the system log are now stored in the C:\SmartSoft-
VersaProbe\Log directory 
 
AutoTool 

7. Menu Bar>Automation>AutoTool:  The Active list item adds the ability to deselect a task from the 
sequence without permanently deleting the task. 



8. Menu Bar>Automation>AutoTool:  An AutoTool task has been added to monitor the system pressure 
and pause AutoTool processing until a target system pressure is achieved. 
 
System 

9. System>Intro Camera: External image files (.bmp, .jpg) can now be imported and used to navigate on 
the sample.   

10. Sample>Park Station: SS-VP/4800 now supports a parking station.  
 
Sample 

11. Sample>Stage: Stage: Backlash correction can now be enable or disabled.  This option is available in 
the stage properties menu.  Backlash correction is used to position the stage more accurately, but 
sometimes makes is more difficult to position a feature using point and click stage moves. 

12. Sample>Stage: Support is added for H/C stage with Pneumatic or Static cold probe.  Static cold 
probe is similar to older cold probe models with a fixed cold probe contact pad. 

13. Sample>Stage: Add Z-height parameter for Eucentric Tilt calibration.  This is to compensate for 
sample thickness with 15-680/5000 stages. 

14. Sample>Sample Viewer: Valid stage limits are displayed graphically on the Sample Viewer overlay. 
15. Sample>Sample Viewer: Valid Zalar limits are displayed graphically on the Sample Viewer overlay. 

 
 
SEM 

16. SEM>Settings>Context Menu>Settings Editor: A new Settings Editor is available for viewing and 
editing the settings text files.  The Settings Editor is accessed through a context menu from the 
Settings Box.  This Settings Editor is available for most hardware applications. 

17. SEM: KnobBox support has been added for the SEM application.  The knob box buttons can now be 
customized to change the behavior of the pressed and un-pressed knob states.  Many users find it 
easier to use the pressed state for coarse moves and un-pressed state for fine moves.  (SmartSoft-
VersaProbe\Settings\Properties\Properties.phi). 

18. SEM>SEM>AutoContrast: Support is added for 38-101A Data Acq.  This improves the image quality 
w/auto contrast. 

19. SEM: SEM/LaB6: An option is added to keep the Lab6 gun running when software is shutdown.  This 
option is included in the properties.phi file. 

20. SEM>SEM/LaB6>Reduced Image.  Added feature for 4700; already available in 4800. 
 
XPS 

21. XPS>Spectrum>XPS Setup...: A Preview feature is added to run n-number of SXI frames; and then 
save the image to a file.  This feature can be configured to save an SXI image prior to each XPS 
acquisition.  

22. XPS>Platen Manager>Lab Book: Lab Book filenames are limited to 200 entries.  This is configurable 
in the Properties.phi file. 
 
AES 

23. AES>Survey: The acquisition range has been extended to 0-3200.  This requires an analyzer control 
upgrade from the 20-378 to the 20-378A.  The 20-378 has a range of 0-2500; compared to the 20-
378A which has a range 0-3200.  Note: the analyzer control model number is set in the hardware 
configuration menu. 

24. AES>Profile>Test Acquire: Test Acquire now supports ‘Area’ and ‘Line’ analysis areas.  The analysis 
area mode can be selected from the SEM context menu. 

25. AES>Analysis Area: When spatial area lines are drawn snap to horizontal or vertical if endpts within 
50 pixels in horizontal or vertical directions 

26. AES>Line: Adds high resolution Line acquisitions (1pt, 2pt, 3pt - 512; Window - 512) – AES only 
configurations 

27. AES>Map: Adds high resolution Map acquisitions (1pt, 2pt, 3pt - 1024; Window - 512) – AES only 
configurations 

 
Hardware 



28. Hardware>Ion Gun: Adds support for manual "Neutralization" mode like SmartSoft-AES 
29. Hardware>Ion Gun: Adds support for imaging with ion gun using the internal/external raster pattern; 

requires a hardware jumper in place on the 20-066 control. 
30. Hardware>Ion Gun>Diagnostics: Systems configured with the 20-066 ion gun control now take 

advantage of an extended set of diagnostics read backs.  Note: this may require a firmware upgrade. 
 
BUG FIXES 
42. Sample>Intro Camera: Update Canon EDSDK toolkit to V3.2 
43. Sample>Intro Camera: Improved communication reliability with Canon camera.   
44. Sample>SVC/Watcher: Improved USB reliability with SVC/Watcher.  Adds configurable delay (3 

msec) to ensure that enough response time is available between WriteDevice() and ReadDevice(). 
45. XPS>Profile Data: Intensity display will sometimes show negative intensity data. - Fixed 
46. SEM>Rotation:  Image rotation does not rotate around the center of the image as expected. - Fixed 
 
KNOWN BUGS 
2.  
 
NOTES 
1. SmartSoft-VersaProbe can now be run on either a 32-Bit or 64-Bit OS.  Contact your ULVAC-PHI 

service engineer for more information. 
            
___________________________________________________________________________ 
 
Release 2.6.3 - December 2014 

___________________________________________________________________________ 
 
OVERVIEW 

SmartSoft-VersaProbe V2.6.3 adds: Improved Gas Gun Emission Current Ramping; Bug Fixing 
 
NEW FEATURES 
1. Changed Ar Ion Gun emission current ramping routine for increased stability. 

 

BUG FIXES 

1. Fix for XPS Depth Profile Acquisitions that fail with Saving Data busy error. 

2. Fixed bug where stopped Angle Resolve Profile would lose last angle data. 

3. Fixed bug where Z-Align timed Neut would use sputter setting. 

 
KNOWN BUGS 
1. Some USB thumb drives can cause a loss of communication with the Bertan. 
 
NOTES 

1.         

___________________________________________________________________________ 
 
Release 2.6.2 - September 2014 

___________________________________________________________________________ 
 

OVERVIEW 
SmartSoft-VersaProbe V2.6.2 Adds: Bug Fixing 

 
NEW FEATURES IN THIS VERSION 

1. Support GCIB Standby mode. 

2. Canon SDK V2.14 

 



FIXED IN THIS VERSION 

1. Removed grey box from bird's eye view. 

2. Fixed bug where Image Registration wasn't working when set to frequency > 2. 

3. Fixed but where region tables remained disabled after more acquisitions completed. 

4. Fixed bug with AES Line 2-pt/3-pt acqs displaying zero intensity data during acquisitions. 

5. Fixed bug with AES Depth Profiles not saving last cycle when stopped. 

 
___________________________________________________________________________ 
 

Release 2.6.1 - August 2014 

___________________________________________________________________________ 
 

OVERVIEW 
SmartSoft-VersaProbe V2.6.1 Adds: Add support for UPS FAT lens table download 

 

NEW FEATURES IN THIS VERSION 

1. New UPS FAT Lens table used for UPS acquisitions. 

 

FIXED IN THIS VERSION 

1. Fixed problem where main turbo status was not read correctly 

 

___________________________________________________________________________ 
 

Release 2.6.0 - June 2014 

___________________________________________________________________________ 
 

OVERVIEW 
SmartSoft-VersaProbe V2.6.0 Adds: FE Gun Support; Dual Sputter Gun Bug Fix; User Settings "Last 
5"; Expanded Tabs; Bug Fixing 

 

NEW FEATURES IN THIS VERSION 

1. New settings combo boxes save history and categorize user settings. 

2. 'Ion Gun Delay' now 'Delay After Sputter' with a 'Only w/ Neut' checkbox 

    to enable old 'Ion Gun Delay' behavior with neutralization. 

3. Setting auto filename parameters and platen directory through queue now 

   done through 'Add Q' right-click menu. 

4. Properties views now are expandable to view all tabs simultaneously. 

  

FIXED IN THIS VERSION 

1. Dual sputter support reworked and improved. 

2. E-Neut out of tolerance error will now take longer to fail. 

3. Fixed chamber camera bug where SmartSoft was looking for a registry 

    key which is no longer needed. 

4. Fixed position list save feature. 

5. Fixed bug where Z-Align wasn't working in stage 'relative' mode. 

6. Fix issue where Egun Neut emission saved to data file was always 0.0. 

 

___________________________________________________________________________ 
 

Release 2.5.1 - April, 2014 



___________________________________________________________________________ 
 

OVERVIEW 
SmartSoft-VersaProbe V2.5.1 Adds: Bug Fixing 

 

FIXED IN THIS VERSION 

1. 800 degree Hot/Cold stage configuration has -260 to 80 rotation limits. 

 

___________________________________________________________________________ 
 

Release 2.5.0 - January, 2014 

___________________________________________________________________________ 
 

OVERVIEW 
SmartSoft-VersaProbe V2.5.0 Adds: Support H/C Stage; Deconvolution V2; 777A GCIB Pressure 
Control; 

 

NEW FEATURES IN THIS VERSION 

1. Support 800 degree Hot/Cold stage configuration. 

2. Set save directory, auto filename, and file number for each acq in queue. 

3. Allow option to keep Ion Gun Neut on in-between positions in queue. 

4. More diagnostics support for 20-066  

5. Ability to delete multiple positions from position list. 

  

FIXED IN THIS VERSION 

1. Changed default lens settings for Auto Z to avoid finding false peaks. 

2. Load X-Ray setting into acquisition setup when load file. 

3. Improved blank mode support for Fig-5. 

4. Fix persistence/histogram/contrast enhancement. Now On/Off running average. 

5. Fix bug where XPS line acqs wouldn't run due to AES spatial line validation check. 

6. Fix bug where AES Z-Align wouldn't run if AES acquisition wasn't run first. 

7. Egun deflection daisy chain address now set by model in configuration manager. 

8. Fix bug where UPS acq would sometimes not run due to setting file containing a reference to high 

power X-Ray setting that wasn't being used. 

9. Fix bug where XPS only configuration would display error if right-click on SXI Image area. 

 

___________________________________________________________________________ 
 

Release 2.4.1 - November, 2013 

___________________________________________________________________________ 
 

OVERVIEW 
SmartSoft-VersaProbe V2.4.1 Adds: Bug Fixing 

 

FIXED IN THIS VERSION 

1. AES Z-Align does not work until another AES acquisition is run. 

2. 60mm sample tilt limit 0-10 instead of 0-5. 

 

___________________________________________________________________________ 
 



Release 2.4.0 - September, 2013 

___________________________________________________________________________ 
 

OVERVIEW 
SmartSoft-VersaProbe V2.4.0 Adds: AES/4700 Support from 710; Auto-Multiplex 
 

NEW FEATURES IN THIS VERSION 

1. Preview photo mode for SEM. 

2. SEM image can now be taken during queue. 

3. Color control for Stage Marker and FOV box on Platen Image. 

4. Low/High Image Registration.  

5. Basic Auto-Multiplex (Survey->PeakID->Import->AcquireMultiplex). 

6. Properties and Settings parameter highlighting. 

  

FIXED IN THIS VERSION 

1. Intro Pumpdown will not timeout anymore. 

2. Chamber Camera active X file and dlls installed with SmartSoft. 

3. Fixed issues with Test Acquire annotation on graph and previous/next element buttons. 

4. Make righ-click menus and annotation handling more consistent between SXI/SEM/Saved Image 

views. 

 

___________________________________________________________________________ 
 

Release 2.3.0 - February, 2013 

___________________________________________________________________________ 
 

OVERVIEW 
SmartSoft-VersaProbe V2.3.0 Adds: Hot/Cold Stage Support; Bug Fixing 

 

NEW FEATURES IN THIS VERSION 

1. Prevac Yes/No configuration option changed to Rotation Limit Switch Yes/No to support new Hot/Cold 

stage which has same limits as Prevac Hot/Cold. 

2. Alternate Sputter position is supported for GCIB depth profiling. 

3. 32 channel SCA FRR mode supported (New SCA Lens table configuration).  

  

FIXED IN THIS VERSION 

1. Multiple step hysterisis correction for large changes to X-Ray Objective. 

2. Fix GCIB lifetime timer, which wasn't working. 

3. Fix problem where Ion Gun argon On/Off would sometimes say that the process timed out righ away 

before the normal 30 second timeout. 

4. Data files now show source/analyzer angles for different source types. 

5. Fixed problems with image registration Shift X/Y parameters editing/updating. 

6. Removed restriction to disallow E-Neut during UPS acquisitions. 

7. Default Z-Align 375.5 PE is now added to selections for Z-Align. 

 

___________________________________________________________________________ 
 

Release 2.2.1 - November, 2012 

___________________________________________________________________________ 
 



OVERVIEW 
SmartSoft-VersaProbe V2.2.1 Adds: Dual Intro Cameras Fix, Energy Cursor, SXI/SEM/Saved Copy 
to Clipboard 

 

NEW FEATURES IN THIS VERSION 

1. Add copy to clipboard button for SXI, SEM, and Saved Image viewers. 

2. Add intensity value to energy cursor display. 

 

FIXED IN THIS VERSION 

1. Fix problem with V2.2.0 where dual intro cameras would only use one set of calibration values. 

 

___________________________________________________________________________ 
 

Release 2.2.0 - November, 2012 

___________________________________________________________________________ 
 

OVERVIEW 
SmartSoft-VersaProbe V2.2.0 Adds: New FRR Lens Table; Dual Intro Cameras (Intro and Prep); 
Gauze Lens Retry 
 

IMPORTANT: V2.2.0 introduces a new ScaLensFRR.txt file which adds support for the 0.6% FRR mode.  

The old file: C:\SmartSoft-VersaProbe\Configuration\ScaLensFRR.txt should be removed or renamed 

before the installation, as the old file is not automatically overwritten.  The ScaLensFRR.txt file can also 

be manually copied from the installation CD. 

 

NEW FEATURES IN THIS VERSION 

1. Use current platen image FOV to generate points (new point generation method). 

2. Add 0.6% FRR mode (See important note above). 

3. Add X-Ray parking mode during sputtering cycles of depth profile.  

4. SmartSoft-XPS now sets the names of the gauges on the Varian control. 

  

FIXED IN THIS VERSION 

1. Add support for systems with two intro cameras. 

2. Fixed zalar rotation error wording to state that platen must be 'close to flat'  

   instead of '45 degrees'. 

3. Fix drag stage move failing with 4-contact prevac stage locked when just U/V move. 

4. Fixed energy step size for AES (1.0eV etc). 

5. Make FOV of image registration independent of FOV for SEM. 

6. Added retry mechanism for data acquisition to help with gauze lens errors. 

7. Fix problem of hitting 'Stop' followed by 'Abort' in acq status window not  

   working. 

8. Fix problem where target emission for sputter setting would get overwritten 

   with queued acuisitions with pulsed neut Z-Aligns as part of queue. 

9. Fix memory management issue that was causing various memory leaks. 

 

___________________________________________________________________________ 
 

Release 2.1.1 - August, 2012 

___________________________________________________________________________ 
 



OVERVIEW 
SmartSoft-VersaProbe V2.1.1 Adds: PHI USA GCIB Control; Bug Fixing 

 

NEW FEATURES IN THIS VERSION 

1. Show center mark option on center of chamber camera. 

2. Support new PHI USA GCIB controller. 

  

FIXED IN THIS VERSION 

1. Don't allow 'User' password to be changed through Change Password Dialog. 

2. Add 0.33 zoom factor so that there is an option that displays full FOV of camera without resizing the 

window. 

3. Remove excessive flashing when 'Close All' performed on muliple open data files. 

4. Set ScanX and ScanY increment when clipping error occurs on SXI restart. 

5. Add maximum count value back into display of Test Acquire. 

6. Fix bug where changing position of Refresh Acquisition while it was starting 

   up would cause hardware parameters to skip getting setup. 

7. Open up TFC coefficient max values. 

8. Fix bug where stopping an acquisition, then selecting 'More', SmartSoft wouldn't remember how many 

cycles were completed. 

9. Remove 'Low Count Error' from Auto Z. 

10. Add support for Chamber Camera communication recovery when computer is rebooted. 

11. Increase C60 X & Y steering by one significant digit. 

12. Fix bug where AES E-gun Stig 2 wobble gets stuck ON. 

 

 

___________________________________________________________________________ 
 

Release 2.1.0 - April, 2012 

___________________________________________________________________________ 
 

OVERVIEW 
SmartSoft-VersaProbe V2.1.0 Adds: CoSputtering; Improved Peak ID; AES updates from 700xi; Bug 
Fixing 

 

NEW FEATURES IN THIS VERSION 

1. Add “Administrator“ user level to access 'Service' features. 

2. Save system parameters at selectable intervals or 'Never Save' option. 

3. Add option for users to disable prompt when Settings change, but haven't been  

   saved. 

4. Auxiliary Prep chamber configuration support. 

5. Dual Sputtering with C60 or GCIB and Argon secondary sputtering. 

6. Grab cursor in SEM view for interactive image shift. 

7. SEM histogram display. 

  

FIXED IN THIS VERSION 

1. Do not require stage initialization after motor power cycle, unless SmartSoft 

   was not shut down cleanly. 

2. Stage Center position moved to properties page. 

3. Pan buttons in Sample google toolbar now control stage similar to SXI and SEM. 

4. Improved XPS Peak ID. 



5. Improved Deconvolution. 

6. Improved Test Acquire. 

7. AES analysis points can now be defined on previously acquired map. 

8. Current Directory now split into Acquisition Directory and Browse Directory. 

9. Fix setting of Peak and Background cursor positions. 

10. Fix Image Registration for 2nd or later regions not working properly. 

11. Fix SEM magnification value being display correctly when changed. 

12. Image Registration FOV is independent of SEM FOV. 

13. Improvement with C60 Auto Startup to allow temperature ramping to overshoot 

    and move on instead of waiting for temperature to settle back. 

14. 10kVC60: Fix X/Y Calibration values and resend size and offsets upon change. 

15. 10kVC60: After turning on High Voltage, wait a second before loading setting 

    this is the same fix that was done for 20kVC60 w/ V1.2.0. 

16. Fix memory leak with Bias Box mode changes and Heat Exchanger On/Off calls. 

17. Channel Maxing option is defaulted to 'Enabled'. 

 

___________________________________________________________________________ 
 

Release 2.0.0 - November, 2011 

___________________________________________________________________________ 
 

OVERVIEW 
SmartSoft-VersaProbe V2.0.0 Adds: Channel Maxing; PreVac Stage Support; Canon X4; 

 

NEW FEATURES IN THIS VERSION 

1. Channel Maxing and Deconvolution. 

  

FIXED IN THIS VERSION 

1. Fixed AES Beam Size acquisitions with scintillator configured. 

2. Fix bug where changing SEM Magnification from combo box wasn't updating the  

   AES Beam Size acquisition X-axis 

 

 

___________________________________________________________________________ 
 

Release 1.2.0 - September, 2011 

___________________________________________________________________________ 
 

OVERVIEW 

  SmartSoft-VersaProbe V1.2.0 Initial Release of SmartSoft-VP for VersaProbe II Instruments 

 

NEW FEATURES IN THIS VERSION 

1. Added logging of SmartSoft-VersaProbe's version number in System Logs. 

2. Add Support for PreVac stage with 4-Contacts heating module  

   (Lock stage, rotation protection) 

  

FIXED IN THIS VERSION 

1. 20kVC60 command to set 'Sputter' vs. 'Blanking' was backwards. 

2. Fix GCIB tracking beam voltage when raster is changed. 



3. Issues reading cold cathode pressure and state, so Sample Transfer procedure  

   will perform Intro Pumpdown when cold cathode pressure readback is  

   questionable. 

4. Add delay when switching 20kVC60 mode from Off -> Standby to avoid issue of  

   target temperature not being set correctly while controller is turning on  

   high voltage. 

5. Fix C60 pressure display on vacuum glyph.  It was not updating the C60 fields  

   with the correct pressure readback. 

6. Fix blanking status in 20kV C60 diagnostics menu, change of logic. 

7. Fix 20kVC60 Raster Calibration values in Properties view not being set  

   correctly. 

8. Change default Max Stage Z height to 20 mm. 

9. When running acquisition with UPS allow Neutralization to be On. 

10. Disable meters 2&3 in diagnostics.  Hardware supports 3 meters, but is only  

    using 1 currently. 

11. Fix issue where bend voltage is clipped to -350 when profile setting is  

    loaded. 

12. Fix bug where Read Beam Power would fail to move anode and Beam Power button  

    is then stuck. 

13. Fix bug where positions could be lost on SmartSoft crash or force quit. 

14. Fix issue with SXI gamma value having incorrect default value and not 

    reading/writing from/to property file correctly. 

 

HELPFUL HINTS 

1. Entry fields must be 'terminated' either by selecting the <Enter> key or by  

   moving to another parameter field.  If the application is exited before the  

   value is terminated the change will not be saved.   

             


